LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   Holowan Laboratories (http://www.lucasforums.com/forumdisplay.php?f=324)
-   -   Mod Compatibility Question (http://www.lucasforums.com/showthread.php?t=215198)

Hawkflight 07-03-2014 03:29 AM

Mod Compatibility Question (Updated 07-03-2014, 5:44 PM EST)
 
Hello everyone, I recently downloaded KotOR II to play on a vacation next week. I'll be away from the internet as of Monday, so I want to make sure I know everything I need to know about some of these mods.

Basically, I want to know if these mods are compatible, and if there's any special instructions I need to follow when installing them together.

http://deadlystream.com/forum/files/...98-tslrcm-183/ (TSL Restored Content Mod)
http://www.nexusmods.com/kotor2/mods/8/?#content (Dustil Restoration Mod)
http://deadlystream.com/forum/files/...-78ep-patched/ (M4-78 Restoration Mod)
http://knightsoftheoldrepublic.filef..._Upgrade;66535 (Onderon Museum Upgrade Mod)
http://knightsoftheoldrepublic.filef...e_Powers;43066 (High Level Force Powers 2.0 Mod)
http://knightsoftheoldrepublic.filef...ancement;91526 (Droid Enhancement Mod)
http://knightsoftheoldrepublic.filef...TOR_TSL;105781 (Movement Animation Fix for KOTOR & TSL (1.3))
http://deadlystream.com/forum/files/...pikes-for-tsl/ (Lightsaber Pikes Mod)
http://knightsoftheoldrepublic.filef...nfluence;87769 (Remote Tells Influence Mod)
http://knightsoftheoldrepublic.filef...ll_Movie;93256 (Fixed Kreia's Fall Movie)
http://deadlystream.com/forum/files/...or-tslrcm-183/ (Handmaiden 4 Females Mod)

Fair Strides 2 07-03-2014 04:36 AM

Quote:

Originally Posted by Hawkflight (Post 2850824)
Hello everyone, I recently downloaded KotOR II to play on a vacation next week. I'll be away from the internet as of Monday, so I want to make sure I know everything I need to know about some of these mods.

Basically, I want to know if these mods are compatible, and if there's any special instructions I need to follow when installing them together.

http://knightsoftheoldrepublic.filef...ent_Mod;115177 (TSL Restored Content Mod)
http://www.nexusmods.com/kotor2/mods/8/?#content (Dustil Restoration Mod)
http://knightsoftheoldrepublic.filef...ile/M478;89207 (M4-78 Restoration Mod)
http://knightsoftheoldrepublic.filef...aber_Mod;73530 (Ultimate Saber Mod)
http://knightsoftheoldrepublic.filef...al_Touch;72996 (Final Touch Mod)
http://knightsoftheoldrepublic.filef..._Upgrade;66535 (Onderon Museum Upgrade Mod)
http://knightsoftheoldrepublic.filef...e_Powers;43066 (High Level Force Powers 2.0 Mod)
http://knightsoftheoldrepublic.filef...tent_Mod;89554 (90SK's SUPER Content Mod)
http://knightsoftheoldrepublic.filef...llection;66487 (Kreia's Assorted Robe Collection 1.1 Mod)
http://knightsoftheoldrepublic.filef..._Content;91955 (TSL: Un-Restored Content Mod)

Welcome to the Forums!

First off, I will be redirecting you to the updated version the restored content mod(which includes the features of the TSL: Un-Restored Content Mod), TSL RCM 1.8.3. Also, the M4-78 mod is incompatible with the Restored Content mod, so I recommend downloading the compatible version here.


Dustil Restoration should be compatible with TSLRCM, as should the Onderon Museum Upgrade.

However, the Super Content Mod and the Ultimate Saber Mod are not compatible with TSLRCM.

Final Touch and High Level Force Powers... I want to say no to the first and yes to the second, but I'm not entirely sure. It's been a while since I used the High Level Force PowersMod and I have never used the Final Touch mod.

milestails 07-03-2014 12:29 PM

No on Kreia's Assorted Robe Collection.

Hawkflight 07-03-2014 05:40 PM

Thanks! I've updated the OP with a new list of mods. I installed the ones without the TSL Patcher first, then the RCM mod and its M478 patch, then the ones with a Patcher. Does that sound right?

Phildevil 07-03-2014 06:29 PM

I'd ask Hassat Hunter about the Museum Upgrade, because frankly, I'm not convinced it is. I concur on the Kreia's Assorted Robe Collection, there are errors when installing with TSL RCM and M4-78EP.

For ultimate Saber mod, why don't you try that mod instead: http://deadlystream.com/forum/files/...lisaber-alpha/

milestails 07-03-2014 09:41 PM

You should install TSLRCM first, then M4-78 EP, then any other compatible mods thereafter.

As far as your new list is concerned:

No on Droid Enhancement
Yes on Movement Animation Fix
Yes on Lightsaber Pikes
Yes on Remote (Make backup of remote.dlg from TSLRCM in your Override folder)
Yes on Kreia Movie (Make backup of KreMov01.bik in your Movies folder)

Hawkflight 07-04-2014 12:22 AM

Quote:

Originally Posted by milestails (Post 2850855)
You should install TSLRCM first, then M4-78 EP, then any other compatible mods thereafter.

As far as your new list is concerned:

No on Droid Enhancement
Yes on Movement Animation Fix
Yes on Lightsaber Pikes
Yes on Remote (Make backup of remote.dlg from TSLRCM in your Override folder)
Yes on Kreia Movie (Make backup of KreMov01.bik in your Movies folder)

Can you please explain why Droid Enhancement doesn't work? Which mod is it incompatible with? I checked the TSL:RCM compatibility notes, and Droid Enhancement is listed as confirmed compatible. Also, what about the Onderon museum mod, the Dustil restoration mod, and the high-level force powers mod?

Also, will it still work if I installed one or two other mods before TSL:RCM, or should I reinstall those mods now? Or will I have to uninstall them and reinstall everything from scratch?

milestails 07-04-2014 12:16 PM

Droid Enhancement won't work because and I quote from the readme 1.8-1.8.1 change list:

* Includes Inverted Droid Feat Gain by Hassat Hunter.
** Fixes the feat gain progression of T3 and Goto being swapped around with the feat gain of HK-47. It's correct now, with HK-47 gaining more feats than them rather than less.

Onderon Museum - I'm not sure. Might be a slippery slope....
Dustil Restoration - It worked with 1.8.2.....not sure about 1.8.3.
HLFP - can't say.....never tried it myself.

Just to be safe, I would reinstall everything from scratch.

Hawkflight 07-04-2014 03:06 PM

I still don't understand. Since the Droid Enhancement mod uses the TSL Patcher, wouldn't the mod just replace the changes from the RCM?

Quote:

IV. Compatibility - This mod should be compatible with just about everything. None of the changed files are very commonly used in other mods. In addition, many of the changes are handled through modification with TSLPatcher. So it'll make the nessicary changes to files already present should you already have mods installed that use the same files, rather than overwriting the files altogether. Only the changes to the Droid items actually need to replace files.

Phildevil 07-05-2014 12:15 AM

TSL RCM mod is essentially installed by means of .mod, which aren't affected by the TSL Patcher.

Fair Strides 2 07-05-2014 01:17 AM

Quote:

Originally Posted by Phildevil (Post 2850919)
TSL RCM mod is essentially installed by means of .mod, which aren't affected by the TSL Patcher.

Actually, .mod files are affected. You can insert files directly into them via TSLPatcher, and you can edit files inside them as well...

Phildevil 07-05-2014 02:01 PM

You have to program TSL Patcher to modify the .mod though, which I doubt this mod does.

Hawkflight 07-05-2014 06:06 PM

Eh, worst case scenario, HK-47 gets about as many feats as a soldier, while still having reliable droid weapons to make up for not being able to become a Jedi.

....Right?

Fair Strides 2 07-05-2014 06:08 PM

Quote:

Originally Posted by Hawkflight (Post 2850958)
Eh, worst case scenario, HK-47 gets about as many feats as a soldier, while still having reliable droid weapons to make up for not being able to become a Jedi.

....Right?

You mean become a Sith, don't you? :P Picture HK preaching peace and love...

Hawkflight 07-05-2014 06:29 PM

Quote:

Originally Posted by Fair Strides 2 (Post 2850959)
You mean become a Sith, don't you? :P Picture HK preaching peace and love...

....Touche.

Hawkflight 07-05-2014 06:33 PM

Is the Handmaiden 4 Females mod compatible with my listed mods above? http://deadlystream.com/forum/files/...or-tslrcm-183/

Phildevil 07-05-2014 07:27 PM

Should be. And use-it in regards with your thread, over there: http://lucasforums.com/showthread.ph...57#post2850957

Hawkflight 07-11-2014 11:09 PM

Are these mods compatible with my current ones?

http://www.moddb.com/mods/the-sith-l...placement-pack
http://www.moddb.com/mods/the-sith-l...w-saber-blades

milestails 07-12-2014 11:55 PM

Yes, but the lightsaber retextures that came packaged with TSLRCM have to be backed up before installing.


All times are GMT -4. The time now is 12:17 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.