LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   General Editing (http://www.lucasforums.com/forumdisplay.php?f=156)
-   -   Can't load my map in JK2 (http://www.lucasforums.com/showthread.php?t=46259)

Marauder Moe 04-22-2002 11:22 PM

Can't load my map in JK2
 
So, I made my room, including a light and a player spawn. I compiled it, made sure it was saved in gamedata\base\maps, and then loaded up JK2 to test it.

I start a server, set sv_pure to 0, and then type "/devmap testroom1", but it can't find maps\testroom1.bsp even though I verified that it is indeed saved in that directory. Any ideas?

UsEr-X- 04-22-2002 11:23 PM

Do you have AIM if so what is your AIM name. Ill IM you there.

UsEr-X-:fett:

Marauder Moe 04-22-2002 11:30 PM

Have you figured out how to get maps to load? No reason to keep it on AIM since I'm sure plenty of other folks would be interested in the answer...

Arawyn 04-23-2002 12:44 AM

I'm having the same problem, i cannot run my map, i can compile it to bsp, i have info_player_start in there, am i missing something? Has someone figured it out yet?

UsEr-X- 04-23-2002 12:49 AM

Actually I was going to ask you how you compile it? I dont see any "bsp_FullVis" options. Can you help me out here?

UsEr-X-:fett:

Marauder Moe 04-23-2002 12:52 AM

Its under the "Bsp" menu.



So anyway... does anyone know how I can get this to work? Do I need a .nav file or is that just for bots?

NoodlyGod 04-23-2002 01:01 AM

I just get a .bak file when I try to compile. I ran the compiler in a dos window and I got the following error: no 'base' in *filename*.

kya4life 04-23-2002 01:03 AM

...
 
Ya i got that error too... of no base.... very strange

UsEr-X- 04-23-2002 01:04 AM

Thanks, I tireid it and the DOS window flashed for a sec then it was gone, i checked in my maps folder and my map is not there (not as a bsp atleast). All you do is hit "bsp_FullVis" ? Or is there something else i am not getting.

UsEr-X-:fett:

Marauder Moe 04-23-2002 01:08 AM

I had no trouble with compliling. I just hit the "Bsp" menu, went down to the bottom and selected "Bsp FullVis", a DOS window popped up, I waited for a little bit, then the window closed and my .bak and .bsp files were there in my base\maps\ directory.

I have no idea why yours isnt working.


So, does anyone have an answer to MY question?

ihavedirt 04-23-2002 01:32 AM

Can't load my map in JK2
 
hey,
i just did the basic quake3 two rooms and a character tutorial for QEradiant I think. I made a test.bsp map and when I tried to load it using:

"/sv_pure 0"
"/map test"

it didnt work

however, I redid that but replaced test with an original map name, then I tried doing it with test and it worked.

hope that helps. there is probably a way about getting around it but im not sure. this is in quake3 but im assuming it might work in jk2 also. ill soon find out

~* beau *~

NoodlyGod 04-23-2002 01:37 AM

Sorry Moe, no idea. Mine worked fine once I got it to compile. I didn't turn off pure server, just typed: map room2 and it loaded. To fix the bak problem I: got rid of the \\ in the base path and rootbasepath in the project settings options, then I copied the .map file into the maps folder before compiling and it worked. I don't know which of those worked but one of them does.

UniKorn 04-23-2002 07:45 AM

I wrote a small tutorial on getting it to work, look for the thread.

jordanisone 10-24-2010 12:07 PM

what radiant
 
when i tried making my map it didnt work i used gtk radiant also make sure you select what gametype for single player or multiplayer coz if you dont you wont be able to play it plus you need to have pak space if you just wanna mess around on your map get a template.pk3 file form google or somthing open it with pak space now what you need to do is try and convert you .map file to bsp and put it in the map section of pak space a freind told me that all you need to get the map to work is the bsp file http://i52.tinypic.com/mu7wxs.jpg

hope this helped


All times are GMT -4. The time now is 02:13 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.