View Single Post
Old 05-24-2003, 03:53 PM   #89
Padawan_7
 
Padawan_7's Avatar
 
Join Date: Jul 2002
Posts: 295
Azymn,

Let me start off by saying I think Forcemod II is going to fantastic! I love the merc abilities. And it is very impressive seeing and playing against bots that fly with the jetpack and shoot at me with two pistols. The class system is great and I think the mod itself has a solid foundation. However, the mod currently has many bugs. Here is what I could find. (Note: I have two versions of JKII installed, one with user-made models, maps, and skins, and one that is basic JKII. I ran Forcemod on both and there didn't seem to be any discrepancies in the following bugs).

Bugs:

Grapple does not extent or retract.

Grapple hook falls to the ground when it touches a wall or ceiling.

Once on the floor, the grapple hook occasionally will not disappear. (A rare occurrence.)

When the Grapple is set to "Mercs only", Jedi can still use it.

When the Grapple is set to "Jedi only", mercs can still use it.

When you use the Shield Recharger, the icon at the bottom left has a transparent green box around it.

On the Scout class descriptions on the "Player Configuration" menu, the line "Weapons:Sniper Rifle" is missing a space in it. (After the colon and before 'Sniper'.)

With "Dual Firearms" set to "Special Mercs only" I can play as a Heavy Soldier and still use two pistols (the same goes for Heavy Soldier bots).

Anytime I start a server and join as any of the 5 mercs, I start with the Stun Baton.

If you switch class Mid-game to a 1. Scout - you spawn holding a Thermal Detonator, 2. Bounty Hunter - you spawn holding a Blaster, 3. Heavy Soldier - you spawn holding a Rocket Launcher, 4. Hot Shot - you spawn holding a Blaster, 5. Trooper - you spawn holding a Detonation Pack. (I think all classes should start with pistols for safety and consistency.)

Level 4 force powers do not work, even thought they are enabled in the menu. (Whenever I allot force points to a level 4 power I respawn with NO force powers.)

Sometimes when spawning as a Jedi you can't switch lightsaber stances.

Sometimes when spawning as a Jedi I will have no force powers, or even rarer, spontaneously chosen force powers that are not reflected in the force powers menu.

Sometimes when dying as a Jedi with the above lightsaber and force power bugs occurring, the game will take me to the "Player Configuration" menu. Then when I select 'Join' it says that I "May not switch teams more than once per 5 seconds".

I followed a Scout bot in spectator view... they do not use cloak, even though it is enabled.

I played against a Scout bot in a dual map... it used the Disruptor until the ammo was gone, then used Thermal Detonators until they were gone, then used the Pistol until the ammo was gone, and then finally switched to the Stun Baton. (In short, the Scout bot will not use Ammo Regeneration, even through it was enabled).

I did the same as above with a Heavy Soldier bot... same result with the Heavy Soldier's respective weapons.

I did the same as above with both a Hot Shot bot and a Trooper bot... they didn't seem to run out of ammo after a good amount of firing (although they ended up getting killed because my saber would eventually reflect their blaster shots back to them - so I'm not totally sure).

The model icon limit is 100 (no more).

Even though the menu saves my rgb saber settings, every time I start the game fresh the saber starts out white.

Wall jumps made by running face front into the wall does not work, even though I have level 3 force jump.

Dualphase lightsabers do not work, even though they are enabled in the menu. (I inspected Force Mod's config. file and the cvar "g_enableextended" is nowhere to be seen.)

Padawan_7

P.S. I've got some suggestions about a few things that I'll type up later when I get the chance.


"For God so loved the world, that He gave His only begotten Son, that whosoever believeth in Him should not perish, but have everlasting life."
- John 3:16
Padawan_7 is offline   you may: quote & reply,