View Single Post
Old 07-11-2004, 12:49 PM   #1
Bell
 
Bell's Avatar
 
Join Date: Jun 2002
Posts: 461
npc strange behavior

my npc isn't walking to his nav goals he is force jumping to them.

here is the script
Quote:
set ( /*@SET_TYPES*/ "SET_BEHAVIOR_STATE", /*@BSTATE_STRINGS*/ "BS_CINEMATIC" );
set ( /*@SET_TYPES*/ "SET_WALKSPEED", 50 );
set ( /*@SET_TYPES*/ "SET_WALKING", /*@BOOL_TYPES*/ "true" );
set ( /*@SET_TYPES*/ "SET_RUNNING", /*@BOOL_TYPES*/ "false" );
set ( /*@SET_TYPES*/ "SET_WEAPON", /*@WEAPON_NAMES*/ "WP_NONE" );

task ( "demowalk1" )
{
set ( /*@SET_TYPES*/ "SET_NAVGOAL", "demopro1nav1" );
}


task ( "demowalk2" )
{
set ( /*@SET_TYPES*/ "SET_NAVGOAL", "demopro1nav2" );
}


task ( "demowalk3" )
{
set ( /*@SET_TYPES*/ "SET_NAVGOAL", "demopro1nav3" );
}


task ( "demowalk4" )
{
set ( /*@SET_TYPES*/ "SET_NAVGOAL", "demopro1nav4" );
}


task ( "demowalk5" )
{
set ( /*@SET_TYPES*/ "SET_NAVGOAL", "demopro1nav5" );
}


task ( "demoturn" )
{
set ( /*@SET_TYPES*/ "SET_DYAW", 180.000 );
}


task ( "demosit" )
{
set ( /*@SET_TYPES*/ "SET_ANIM_BOTH", /*@ANIM_NAMES*/ "BOTH_STAND5TOSIT2" );
set ( /*@SET_TYPES*/ "SET_ANIM_HOLDTIME_BOTH", -1 );
}

dowait ( "demowalk1" );
dowait ( "demowalk2" );
dowait ( "demowalk3" );
dowait ( "demowalk4" );
dowait ( "demowalk5" );
do ( "demoturn" );
dowait ( "demosit" );
strange thing is.. i have two npc's with virtually the same script walking paralell paths..one does everything right, the other jumps from navgoal to navgoal...weird...any idea how to fix this?


Bell is offline   you may: quote & reply,