View Single Post
Old 09-15-2005, 01:02 PM   #4
JeeMonkey
Rookie
 
JeeMonkey's Avatar
 
Join Date: Jan 2004
Location: around
Posts: 138
SHOOT! I'm sorry, my last post was inccorect, so I deleted it. This is what I meant to say:

Quote:
Originally Posted by JeeMonkey
Ok I changed what I think you asked me to, and it didn't work. plus, now the red and black checkered square wont load anymore.


Here is what I started with...
Code:
textures/atlantis/ocean
{
	qer_editorimage	textures/common/water_1
	surfaceparm	nomarks
	surfaceparm	nonsolid
	surfaceparm	nonopaque
	surfaceparm	water
	surfaceparm	trans
	q3map_material	Water
	q3map_onlyvertexlighting
	deformvertexes	wave	100 sin 1 2 2 0.6
    {
        map $lightmap
        blendFunc GL_DST_COLOR GL_ZERO
    }
    {
        map textures/common/water_1
        blendFunc GL_DST_COLOR GL_ZERO
        tcMod turb 0.01 0.03 5 0.1
        tcMod stretch noise 1 0.01 1 1
    }
    {
        map textures/common/water_1
        blendFunc GL_ONE GL_ONE
        tcMod turb 0.02 -0.06 0 0.1
        tcMod stretch noise 4 1 0 0.01
    }
}
Here is what I thought you asked me to change...

Code:
textures/atlantis/ocean
{
	qer_editorimage	textures/atlantis/ocean
	surfaceparm	nomarks
	surfaceparm	nonsolid
	surfaceparm	nonopaque
	surfaceparm	water
	surfaceparm	trans
	q3map_material	Water
	q3map_onlyvertexlighting
	deformvertexes	wave	100 sin 1 2 2 0.6
    {
        map $lightmap
        blendFunc GL_DST_COLOR GL_ZERO
    }
    {
        map textures/common/water_1
        blendFunc GL_DST_COLOR GL_ZERO
        tcMod turb 0.01 0.03 5 0.1
        tcMod stretch noise 1 0.01 1 1
    }
    {
        map textures/common/water_1
        blendFunc GL_ONE GL_ONE
        tcMod turb 0.02 -0.06 0 0.1
        tcMod stretch noise 4 1 0 0.01
    }
}
What am I missing, or what did I do wrong?
There is no textures/atlantis/ocean
That is just what I chose to call this shader.
JeeMonkey is offline   you may: quote & reply,