View Single Post
Old 12-12-2006, 01:46 PM   #1
Mantis01
Rookie
 
Mantis01's Avatar
 
Join Date: Aug 2006
Location: Japan
Posts: 34
Problem - enhanced Linux Server

I'm linux server user.
need help
I compiled souce in rev.303 from SVN, but error.

First I compiled in Windows(VC++2005 Express) dlls (cgamex86.dll, jampgamex86.dll, uix86.dll), and archived from "botfiles" to "ui" directory(named to stuff, yes same official binary).
I guess that those work succeeded.

In addition, compiled Linux(gcc-3.4.6) server binary(jampgamei386.so).
# cd source/game
# make

Result, no error. I got jampgamei386.so.
Finally, start dedicated server......but error

------ Server Initialization ------
Server: mp/ffa1
----- FS_Startup -----
Current search path:
/jampd/ojpenhanced/ojp_enhancedstuff_009s-rev303.pk3 (536 files)
/jampd/ojpenhanced/ojp_enhanceddlls_009s-rev303.pk3 (3 files)
/jampd/ojpenhanced
/jampd/linuxjampded/ojpenhanced
/jampd/base/assets2.pk3 (62 files)
/jampd/base/assets1.pk3 (8320 files)
/jampd/base/assets0.pk3 (15346 files)
/jampd/base
/jampd/linuxjampded/base

----------------------
48534 files in pk3 files
Loading dll file jampgame.
Sys_LoadDll(/jampd/ojpenhanced/jampgamei386.so)...
Sys_LoadDll(jampgame) found **vmMain** at 0x15d27a0
Sys_LoadDll(jampgame) succeeded!
*******************
ERROR: Vehicle extensions (*.veh) somehow exceeded precalculated size! (should never happen)
********************
^1Error: BotLibShutdown: bot library used before being setup
DROPPED
Hitch warning: 608 msec frame time


________________
Mantis
Mantis01 is offline   you may: quote & reply,