View Single Post
Old 09-19-2007, 10:16 AM   #23
Silveredge9
Retired Modder
 
Silveredge9's Avatar
 
Join Date: Sep 2003
Location: United Kingdom
Posts: 710
Veteran Modder Forum Veteran Hot Topic Starter Contest winner - Modding 
Quote:
Originally Posted by stoffe
Nice work. Seems very interesting, though I haven't had the time to play it yet.

I have, however, noticed a few problems with the installer so far you may want to know about
  1. The new entry you add to spells.2da isn't properly linked to the armband item that triggers it. Thus the armband won't work if the player already has a modified spells.2da file, since your armband will point to the first custom spell in it, whatever it might be, and not directly to your addition. (You'll need to store the RowIndex of your new line in spells.2da in a 2DAMEMORY token and then assign that to the property subtype in the armband to fix this.)

  2. When adding new structs to the Categories list in global.jrl you should set the struct TypeID to ListIndex instead of a direct number to have it get a proper value even if the player has an already modified global.jrl. That keyword will be substituted with the structs index in the list field when the patcher runs.

  3. Your mod made me aware of a bug/oversight that happens when an ExoString or ExoLocString substring field contains text with newlines (like your new journal entries does). Due to this bug it would only add the text up until the first newline, the rest would be discarded. I've uploaded a new version of TSLPatcher that fixes this, though the changes.ini file will need to be manually fixed. I've posted some instructions for how to do this in the TSLPatcher thread in the T3M4 tools forum. Sorry about that mess.

I've fixed #2. But I'm having some trouble with #3... I see that it cuts off most of the Journal Entries, so it needs to be fixed asap...

I edited the changes.ini file manually, adding "<#LF#>" where line breaks are supposed to be, but when I check it out in kgff... there are no line breaks, just <#LF#> between the text. :P

Is that supposed to happen?

UPDATE
Wait, nevermind, I just download your update to TSL patcher and it works now. :P
Silveredge9 is offline   you may: