View Single Post
Old 05-26-2008, 08:01 PM   #1
Join Date: May 2008
Posts: 1
JKA Installation Problems

Hi guys. Got some problem installing Jedi Academy. When I bought it about a year ago, I was able to install and play it. No problem there. Then a little over 3 weeks ago, my computer suddenly crashed. So everything was erased(so pissed, I tell ya!). Anyway, I reinstalled Windows XP again and everything worked fine. But when I tried reinstalling JKA again, it won't let me install. Whenever I click the "Install" button. A setup error message always appears, it says: "Application failed to initialize properly (0xc0000005). Click on OK to terminate application"

I don't know what's the problem. First I let JKA analyzed my computer and everything passed. It says that I am qualified to play JKA. So I thought maybe the CD was the problem. But when I tried installing it on my Laptop, it was able to install the game with no problems.

Anybody know what's going on? I really want to play JKA again! So any help would be GREATLY appreciated..

NOTE: I was able to successfully reinstall Jedi Outcast and every other Star Wars Games I have. So why can't I install JKA?
Aljay is offline   you may: