View Single Post
Old 04-28-2009, 11:29 PM   #1
___ACROBAT___
Rookie
 
Join Date: Apr 2006
Posts: 29
lightburn problem in jko but not in jka.

I might have two solutions to the overbright lightburn problem.

The first is that I put boddo's shader on every texture in jk2 to prevent that overbright lightburn that happens so easily in jk2 but not in jka.

Here's the shader

Quote:
textures/duelroom/base_ceiling
{
qer_editorimage textures/duelroom/base_ceiling
{
map $lightmap
rgbGen identityLighting
}
{
map textures/duelroom/base_ceiling
blendFunc GL_DST_COLOR GL_ZERO
rgbGen identityLighting
}
}

However, I may have found another good solution to the problem just now. I was reading over the features of netradiant, a competitor to gtkradiant I guess, and I found the "Lightmap exposure" compile command since it has its own compiler.

Here's what it does
Quote:
The q3map2 light compile parameter -exposure changes the handling of overbright pixels to look more realistic. Try values like -exposure 200! The higher the value, the darker the result gets.

It is most interesting if you intentionally put colored lights of a far too high light value in your map.

This feature was contributed by the Urban Terror team.

I haven't tested this program yet since I'm using that shader that I like but in the future someone may want to try this out.
___ACROBAT___ is offline   you may: quote & reply,