View Single Post
Old 11-01-2009, 05:28 AM   #1
Hydroponixxx
Lurker
 
Join Date: Nov 2009
Posts: 1
Brutal legend, end of game *Please help*

----Maby this is just a glitch but if not please read and let me know what you have to offer. Thanks-----

I have finished the game on normal, watched credits and all. I know I can continue playing after the game is beat but it still shows another primary/current mission ?

Primary/Current mission : Brutal Campaign Complete!
Doviculus has been defeated. This brutal land is once again free... for now

My question is this... I still have another symbol *PRIMARY/CURRENT MISSION* on my map (the mission i mentioned above) on the bridge in the south west area of the map, it has a trail leading to this location. I have tried to explore this area and found an anti christ symbol where the light lands down. I have tried everything I could think of to start this mission but nothing works. can someone help me figure this out.

Thanks
-Ken

Last edited by Hydroponixxx; 11-01-2009 at 05:59 AM.
Hydroponixxx is offline   you may: quote & reply,