View Single Post
Old 12-02-2009, 04:08 PM   #1
xshat
Lurker
 
Join Date: Feb 2009
Posts: 7
Sound Not Working In Game

I tried following the advice here: http://www.gametoast.com/forums/view...hp?f=27&t=9541
And also the tutorial but I still cannot get the lvl to build for the sound.

I added these lines to my LUA
Code:
ReadDataFile("dc:sound\\Phobos.lvl;Phobosgcw") 
OpenAudioStream("dc:sound\\Phobos.lvl",  "Phobos");
OpenAudioStream("dc:sound\\Phobos.lvl",  "Phobos");
When I run SPtest it says
Code:
Message Severity: 3
.\source\LuaCallbacks_Mission.cpp(195)
Lua ReadDataFile: Could not open dc:sound\Phobos.lvl;Phobosgcw
Well the sound LVL file doesn't compile and I don't understand why. Here is the source for my files in BFBuilder\DataPhobos\Sound\worlds\Phobos

Phobos.ASFX
Code:
effects\shot.wav    -resample pc 22050
Phobos.REQ
Code:
ucft
{
    REQN
    {
        "str"
        "align=2048"
        "Phobos"
    }
    REQN
    {
        "lvl"
	"Phobosgcw"
    }

 }
Phobos.ST4
Code:
streams\intro_start.wav Music
streams\intro_end.wav
Phobosgcw.REQ
Code:
ucft
{
    REQN
    {
    "bnk"
    "align=2048"
    "Phobos"
    }

    REQN
    {
    "config"
    "Soundprop"
    "Phobos"
    }
}
Soundprop.SND
Code:
SoundStreamProperties()
{
    Name("Music");
    Group("ambientenv");
    Inherit("ambientfx_template");
    Gain(10.25);
    Stream("Phobos");
    SegmentList()
    {
        Segment("Music", 1.0);
    }
}

SoundProperties()
{
    Name("Shot1");
    Group("weapons");
    Inherit("weapon_template");
    SampleList()
    {
        Sample("shot", 1.0);
    }
}
Also I have shot.wav effect in the effects folder and my intro_start.wav and intro_end.wav in the streaming folder. I also added "FireSound =Fire1" to the all_force_pull.odf and then I created the sphere in zero editor and gave it the correct properties so all the source looks good to me if I'm missing something here let me know ASAP.
xshat is offline   you may: quote & reply,