View Single Post
Old 03-15-2010, 06:39 PM   #5
Firestone
Lurker
 
Join Date: Mar 2010
Posts: 1
Quote:
Originally Posted by Maveritchell View Post
The simple answer is that you're wrong.
Battlefront Extreme 2.2 @ SWBFFiles
You will need to install this unofficial patch first:
Unofficial v1.3 Patch
Well, you might like that mod, but our favorite guy turned into crap, with his 2 handguns instead of a bombingrun with electro binoculars and a powerful sniper-rifle that shoots at the speed of a machinegun!
That's one of the reasons why we prefer our oldie over the 2.2 version.

Do we need that unofficial v1.3 patch for our version, or is that the patch for the 2.2 one?

Last edited by Firestone; 03-15-2010 at 06:40 PM. Reason: typo
Firestone is offline   you may: quote & reply,