View Single Post
Old 05-30-2010, 05:16 PM   #396
Darth_Bane_Wins
Rookie
 
Join Date: May 2010
Location: West Coast
Posts: 10
Current Game: KotOR 1, 2
Found a few bugs Trex, just thought you'd want to know

So here are some bugs I found while playing through KotOR: The Jedi Masters
I thought you might appreciate it if i helped point em out.

WARNING -POSSIBLE SPOILERS-

Planet Specific

Telos
- Most of the items/structures/land formations in the 'true sith' camp are "walk-through able"
- The stone doors at the sith camp entrance are partially see through from the side

Etti IV
-Residential section: "Secretary" with droid bodyguards. In the case of the circuit overload the droids attack you on sight but when hit will not die. Their health will go down to a very small amount then stop there. This makes defeating them impossible and escape extremely difficult.

M4-78-B
Not so much a bug as a nuisance.
- Docking area textures hard on eyes. Far too complicated. Too many wires, circuits, pipes etc. in too smal a space. Simpler design recommended.

Rhen Var
- First (Landing) and second (Run) areas extremely buggy. Third area appears to be accessable on the map but is unreachable.

Aperture Station
- Station unreachable. When standing next to landing shuttle there is no "Travel to Planet/Station" option.
EDIT: Figured out the hatch leads there instead for stations so never mind that.
-Upon entering Aperture I found there was only 1 direction I could run. The way I was already facing. Tried loading several times, same result every time, ending me up in a corner with nowhere to go

Aid Station
- Station unreachable. When standing next to landing shuttle there is no "Travel to Planet/Station" option.
EDIT: Figured out the hatch leads there instead for stations so never mind that.
- Movement problems present. Possibly workable but not well. Its easy-ish to get in and through most of the rooms, but couldn't get out, movement too glitched when going that way

Deep Space Wreckage
- Quest coordinates from man on Etti IV. However, again there is no "Travel to Planet/Wreckage" option when next to shuttle or any hints or clues as to what to do.
EDIT: Figured out the hatch leads there instead, again
-No noticeable movement problems. Enemies (Malfunctioning Droids) too hard to kill for level of character available. Possible, but quite difficult.

General Problems

Movement
-Slowed down/glitched run animation
-Difficulty turning (commands appear not to register)
-when pressing the back up key (s) the character moves foreward more often than back.

Note: Movement problems spiked considerably after visiting Rhen Var, where they were constant.

Plot/Storyline
-There is no way to continue the storyline of the game that I can find once the point in the game is reached where all party members are available except Kriea, Revan, and the two Apprentices. Available members are Exile, Canderous, Kannos, Ootataa, HK-47, Bastila, Tsig, and Shadow. The only thing available is working on the characters personal side stories.

Crash
-Game occasionally crashes, however that may just be the original KotOR 2 problem coming through as the exact same thing essentially happens, or it may be a product of Windows 7 gaming.

I also agree with the Lord of Hunger. As he said:

"1) Lack of Journal Entries - This drives me a bit insane. Sometimes I forget what quest I'm on or what has happened, and I don't have any journal entries to help me remember what I've done. From what I can tell and correct me if I'm wrong, you haven't touched stuff like the .2da and .jrnl files. I hope that you can redo this mod eventually with .jrnl entries, it'd really boost the game quality.
2) Bare bones universe - Unfortunately, the in-game universe you have everything take place in lacks dynamic. This is most likely due to the amount of work it would take to fill up all of those modules with unique characters, but it does wound the game play."

END -SPOILERS-

And... that's it so far. Cheers and good luck with your mod

Last edited by Darth_Bane_Wins; 05-30-2010 at 11:17 PM.
Darth_Bane_Wins is offline   you may: