Thread: SP mod help
View Single Post
Old 07-01-2010, 06:51 AM   #2
New_New_New
Lurker
 
New_New_New's Avatar
 
Join Date: Jan 2009
Posts: 8
Well, I always do it this way:
- put an info_payer_start into new map
- target info_player_start to target_scriptrunner
- set in target_scriptrunner key usescript with value script_folder/name_of _the_start_script (for example new_scripts/start_level)
- compile map
- open BehavEd and write such script (for example):

//Generated by BehavEd

rem ( "script run at start of level" );
rem ( "set up force powers and weapons" );

affect ( "player", /*@AFFECT_TYPE*/ FLUSH )
{
set ( /*@SET_TYPES*/ "SET_FORCE_ABSORB_LEVEL", /*@FORCE_LEVELS*/ "1" );
set ( /*@SET_TYPES*/ "SET_FORCE_DRAIN_LEVEL", /*@FORCE_LEVELS*/ "1" );
set ( /*@SET_TYPES*/ "SET_FORCE_GRIP_LEVEL", /*@FORCE_LEVELS*/ "1" );
set ( /*@SET_TYPES*/ "SET_FORCE_HEAL_LEVEL", /*@FORCE_LEVELS*/ "2" );
set ( /*@SET_TYPES*/ "SET_FORCE_JUMP_LEVEL", /*@FORCE_LEVELS*/ "3" );
set ( /*@SET_TYPES*/ "SET_FORCE_LIGHTNING_LEVEL", /*@FORCE_LEVELS*/ "2" );
set ( /*@SET_TYPES*/ "SET_FORCE_MINDTRICK_LEVEL", /*@FORCE_LEVELS*/ "3" );
set ( /*@SET_TYPES*/ "SET_FORCE_PROTECT_LEVEL", /*@FORCE_LEVELS*/ "1" );
set ( /*@SET_TYPES*/ "SET_FORCE_PROTECT_LEVEL", /*@FORCE_LEVELS*/ "3" );
set ( /*@SET_TYPES*/ "SET_FORCE_PULL_LEVEL", /*@FORCE_LEVELS*/ "3" );
set ( /*@SET_TYPES*/ "SET_FORCE_PUSH_LEVEL", /*@FORCE_LEVELS*/ "1" );
set ( /*@SET_TYPES*/ "SET_FORCE_RAGE_LEVEL", /*@FORCE_LEVELS*/ "3" );
set ( /*@SET_TYPES*/ "SET_FORCE_SIGHT_LEVEL", /*@FORCE_LEVELS*/ "3" );
set ( /*@SET_TYPES*/ "SET_FORCE_SPEED_LEVEL", /*@FORCE_LEVELS*/ "3" );
set ( /*@SET_TYPES*/ "SET_SABER_DEFENSE", /*@FORCE_LEVELS*/ "3" );
set ( /*@SET_TYPES*/ "SET_SABER_OFFENSE", /*@SABER_STYLES*/ "3" );
set ( /*@SET_TYPES*/ "SET_SABER_THROW", /*@FORCE_LEVELS*/ "2" );
}

- name it (for example level_start)
- compile it and put in script folder (for example new_scripts)
- put all new files into .pk3 (of course new map must be in maps folder in that pack and new_scripts folder must be in scripts folder (as in assets packs)) and put a new .pk3 into "base" directory
- to run my map I use command devmap or change newgame.ui (and newgame_first.ui) to run my map when start a new game...
And it always works fine. So I don't know, may be there is some problem in your .bat file?
P.S. Sorry for my English...
New_New_New is offline   you may: quote & reply,