View Single Post
Old 08-06-2010, 10:37 AM   #423
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Quote:
Originally Posted by rhinohoops8 View Post
Ok. Any other suggestions since I already followed post #2?
Yes. You'll need to go into the game's options menu and under "graphics options" you'll need to turn off all of the eye candy. Set anisotropic filtering and antialiasing to 0, turn off frame buffer effects, shadows, soft shadows and grass, and set texture detail to "low". I would also try turning v-sync on. Most of these options are in the "advanced" sub-menu. Make sure to hit "apply" when you're done turning everything off. Once you get the game running, you can try turning this stuff back on one at a time to see what works and what doesn't.

After that, I would go ahead and change the width value to 1280 under both [Display Options] and [Graphics Options] in the swkotor2.ini file (don't forget to save!). 1280x768 is the only widescreen resolution that KotOR 2 supports natively and it will fit your screen better.

Beyond that, if it still won't run, I suspect that it might be a scaling problem, which is fixed by going into your graphics driver's control panel and choosing a different scaling option. You might even have to create a custom resolution of 1280x768, or, less likely, change your desktop resolution to 1280x768. Just play around with the different options, always one at a time, so you'll know what you did to finally get it to work.
Quote:
Originally Posted by lilernie6 View Post
ok well I will have to say mine is the best of pc version of kotor and yes i did try the fix i just deleted the part i was supposed to put in and all of that
OK, let's just start over by uninstalling the game. With the Best of PC version, installation would go like this. Make sure that you're using an administrator's account when you do this:
1) Explore your installation disk and look for "setup.exe". Right-click on it, select "Properties", then "Compatibility", set it to run in XP SP2 compatibility mode, check "run as an administrator", hit "Apply", then "OK". Then right-click on "setup.exe" again, select "Run as an administrator" and install the game.

2) Remove the read-only properties from the entire game folder by right-clicking on it, selecting "properties", un-checking "read-only" hitting "apply", selecting "Apply changes to this folder, subfolders and files" and hitting OK.

3) Go into the game folder, find "swkotor.exe", right-click on it, select "Properties", then "Compatibility", set it to run in XP SP2 compatibility mode, check "run as an administrator", hit "Apply", then "OK".

4) Do the Dantooine lag fix:
Quote:
Originally Posted by stingerhs View Post
  • First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
  • When you find it, just double-click on the file to open it in Notepad.
  • Scroll down the file until you find the Graphics Options
  • Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini), add "Disable Vertex Buffer Objects=1", without the quotes.
  • Goto File, then Save.
The other stuff is GPU-specific, and, since I don't know what kind of graphics card you have, I can't give any instruction regarding that. Just look at steps 9 and 11 in the second post of this thread if you have either an Intel (9) or ATI (11) GPU.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,