View Single Post
Old 11-13-2010, 06:05 PM   #492
Join Date: Nov 2010
Posts: 1
I have a Compaq Presario C770 US laptop (no hardware upgrades, only an OS upgrade, all the drivers are updated) with Windows 7 Professional (64-bit) and I purchased this game (KotOR I) yesterday on Steam as I no longer have access to my sister's Xbox. I also have KotOR 2 for the PC, but have not played it since I upgraded to Windows 7 (It worked fine on XP after downgrading from Vista). The problem I am having is that I am starting the game and after both logos I get a black screen with only the mouse showing up and occasionally the music. I have tried setting it to one affinity core as well as running the compatibility with Windows XP Service Pack 2/3 and running it as administrator and nothing seems to be working. I don't have my desktop set up right now so I cannot play it on that, but I am getting rather annoyed. I have the same problem with KotOR 2, the game worked fine on XP, but Windows 7 seems to not work very well. I seem to have tried everything and have been looking for a few hours for a solution with nothing. Does anyone have any ideas? I have tried the fixes here, but nothing has worked. It seems to be a Windows 7 only thing because as I have stated, KotOR 2 ran fine on this laptop when it had XP.
Those are the specs I have.

Edit: Never mind, the problem has been fixed. I wasn't using a Windows 7 Aero theme (fixed my Minecraft problem as well), if you don't use one with Windows 7 then the black screen with music and cursor thing happens.

Last edited by Aeladya; 11-15-2010 at 02:22 PM.
Aeladya is offline   you may: