View Single Post
Old 11-16-2010, 01:28 AM   #1
impossibletologin1
Lurker
 
Join Date: Nov 2010
Posts: 8
kotor 2 crashes after first movie. Windows 7. Tried everything, nothing works

I have Windows 7, 64 bit. Kotor always crashes after the first intro movie.

I have tried EVERY bit of advice on the internet.
I have tried EVERY combination of settings in the game, the various Win7 compatibility modes, run as admin or not (I get "access denied" if I try to set affinity to one CPU when running as admin), and every combination of settings I can think of in Windows.
I do have an intel built in graphics card but there's nothing in the settings of "Flipping Mode", "Blit", or anything like that at all.

Again, literally NOTHING will make this sadistic game actually work.

Out of all the advice people gave, the only single thing that had any effect was changing the DLL which allowed the game to not crash the very second it was started without using compatibility mode.

And I tried forever and ever on it. If anyone has any ideas, I would like to know. I am not sure what else I can try as I tried everything unless there's some hidden "Flipping Mode" somewhere as my control panel for the intel GPU does not have anything like it or "Flip"/"Blit"/whatever. My control panel is the "Figure 1a: Intel® Graphics and Media Control Panel" as seen on http://www.intel.com/support/graphics/sb/CS-022130.htm Well as I mentioned before there's no "Flipping Policy" or similar setting anywhere for my integrated video card. And before posting the thread I'd even searched the Windows registry too and "Flipping" was not even in there. The closest was some Display1_DisableAsyncFlips or it was set to 0 but I don't think it applied. I think Display1_DisableAsyncFlips had something to do with my monitor and this value was duplicated dozens of times in my registry all set to 0. However, according to this thread http://www.lucasforums.com/showthread.php?t=205631 the "Flipping Policy" setting doesn't actually help anyway with this crash. Maybe there's some way to do video card emulation?


Oh and I just played Star Wars Republic Commando on this machine (I got it as a gift back in 2005 but my previous Windows XP computer was too old to play it) and Republic Commando played flawlessly with no problems at all in WinXP SP2 compatibility mode with admin mode enabled. Yet Kotor 2 is impossible to get working at all. Literally nothing will make this game work.

If anyone has any ideas, it would be appreciated.


My computer:
* • Genuine Windows 7 Home Premium 64-bit
* • Intel(R) Pentium(R) Dual-Core processor E5500 [2.8GHz, 2MB L2, 800MHz FSB]
* • 4GB DDR3-800MHz SDRAM [2 DIMMs]
* • Integrated graphics - Intel(R) Graphics Media Accelerator X4500 [VGA]
* • Integrated sound

Last edited by impossibletologin1; 11-17-2010 at 04:17 AM.
impossibletologin1 is offline   you may: quote & reply,