View Single Post
Old 10-27-2011, 02:55 PM   #8
ChAiNz.2da
Leave Everything to Me!
 
ChAiNz.2da's Avatar
 
Join Date: Oct 2004
Location: Tennessee (USA)
Posts: 6,848
Quote:
Originally Posted by J4ngo View Post
when i run KSE_333 i get a message:Attempted to read past end of end of dialog.tlk
(tried to read string 136366 but dialog.tlk has 136364 entries)

KotOr2 Spells.2da

and then KSE closes. never happened to me before any fixes would be very appreciated
Your particular case is described in the first post as one of the examples

Quote:
Cause:
This error is caused by installing a mod incorrectly or by trying to edit a savegame after uninstalling a mod.

Details:
The dialog.tlk file contains the bulk of all the names and descriptions in the game. Certain files refer to the entries in the dialog.tlk file by an index number. Many game files are GFF-formatted files and can store names/descriptions internally without the need to refer to the dialog.tlk file; however, the .2da files (eg. spells.2da, feat.2da) require dialog.tlk entries to make their descriptions appear correctly in the game. Mods that add new force powers, for example, must provide a dialog.tlk patch so that the power description becomes visible. This patch (usually provided via TSLPatcher installation file) typically adds news dialog.tlk entries. If the patch is not applied, the modded file (eg. spells.2da) will refer to a non-existant entry, causing the KSE error. Alternatively, the error can also be caused if a mod is removed after a game is played with the mod in place where the PC acquires the new power or feat.

Solution:
Re-install the mod while carefully following the readme instructions or delete the offending savegame.


"Eagles May Soar, But Weasels Don't Get Sucked Into Jet Engines"


| Mods (FF) (DS) | Folding | SWK.com | FB: (LF) (Me) | Steam | The Herd |
ChAiNz.2da is offline   you may: quote & reply,