View Single Post
Old 12-25-2013, 03:29 PM   #1
dcora87
Lurker
 
Join Date: Dec 2013
Posts: 2
OpenGL won't work and yes I've read the stickies

Hi,
Just recently, I acquired a copy of Jedi Outcast, which is one of my favorites. My computer right now is running Win7 at 32-bit with an ATI Mobility Radeon HD 3650 card. According to ATI and my computer, the drivers are up to date. I also have Jedi Academy. I just barely installed JA and had it working with the fix in the stickies. This was when I was running 64-bit Win7. I'm not sure if that has any bearing on the issue. Anyways, I thought I would just drop the opengl32.dll into my gamedata folder just like with Academy yet that did nothing. I even replaced the opengl32.dll in my system32 folder (no simple task in Win7). To all my efforts, not a single line of code has changed. It still fails at trying to run the opengl32.dll. If this is a 32 vs 64 bit issue, I will gladly re-install my 64-bit version. But that seems unlikely. Everything minus the 32 vs 64 is the same. So I'm not sure what I'm doing wrong here but I've looked up a million different fixes, none of which have worked. Anyways here's the code line:
Code:
JK2: v1.03 win-x86 May  3 2002
Initialising zone memory .....
----- FS_Startup -----
Current search path:
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets5.pk3 (4 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets2.pk3 (289 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets1.pk3 (8011 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets0.pk3 (6674 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData/base

----------------------
14978 files in pk3 files
execing default.cfg
couldn't exec jk2config.cfg
couldn't exec autoexec.cfg
...detecting CPU, found Intel Pentium IV

------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Working directory: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\Windows\system32\opengl32.dll' ): failed
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem
Any ideas/help? Please? I LOVE this game and I just want to play it. I'm at my wit's end. I just don't understand why the fix worked perfectly for Jedi Academy yet won't work at all for Outcast, as they are essentially the same game.
dcora87 is offline   you may: quote & reply,