View Single Post
Old 12-04-2002, 07:21 AM   #2
bgbennyboy
Festively Plump
 
bgbennyboy's Avatar
 
Status: Super Moderator
Join Date: Feb 2002
Location: England
Posts: 1,986
LFN Staff Member 
Reproduced below is a reply to a help post on Grim Fandango I made. It covers most of the things that you can do with Grim Fandango.


Right, Grim Fandango!
I'll fill this in as I go along (remember I am using XP though):
The solution to your problem with Grim exiting on the loading screen can be solved I think by running in software mode.

1)After uninstalling Grim deleting all registry keys and re-installing I start Grim.
2)It loads fine, in the options, 3D Hardware Acceleration is off and its running in software mode. I assume that this is the default state for Grim to be in so perhaps you are already running in software mode (obviously you cant get far enough into Grim to see).
3)I turn hardware acceleration on and switch to direct3d acceleration instead of software. I exit and restart - it works fine! I dont remember it being like this when I last installed it, hmmm.
4)I remember you installed the patch so I do too.
5)I make Grim as I previously had it - with the data files on hd so I dont need the cds. From the CD1 GRIMDATA folder I copy Data001.lab, Data 003.lab, Movie01.lab, Movie03.lab, Vox0001.lab, Vox0003.lab, Year1mus.lab, and Year3mus.lab to my Grim folder. From the CD2 GRIMDATA folder I copy Data002.lab, Data 004.lab, Movie02.lab, Movie04.lab, Vox0002.lab, Vox0004.lab, Year2mus.lab, and Year4mus.lab to my Grim folder.
6)I remove the cd's and start the game. Doh, it wants the cd in.
7)I start regedit (Start>run>regedit)
I go to /HKEY_LOCAL_MACHINE/LucasArts Entertainment Company LLC/Grim Fandango/v 1.0/
I add a new string value called "good_times" (without quotes)
I set the value of this to TRUE
I start the game. All is fine.
I can also now run in windowed mode by selecting DIBsection windowed display in 3d hardware setup.
I can also run in a window by starting with the -w parameter eg. Grimfandango.exe -w

Okely dokely you can try all those things in order, ive listed all I can think of.
The only other thing I can think of is modifying registry values to make grim start in a particular mode. These values *may* not work for you since they may be dependant on the 3d hardware in your machine but you could give them a try.

So in /HKEY_LOCAL_MACHINE/LucasArts Entertainment Company LLC/Grim Fandango/v 1.0/


Fullscreen Software mode:
Last3DDevice key: all 0's
LastDisplayDevice key: all 0's

Fullscreen Hardware mode:
Last3DDevice key: e0,3d,e6,84,aa,46,cf,11,81,6f,00,00,c0,20,15,6e (the commas just seperate the hex values obviously).
LastDisplayDevice key: all 0's

Windowed mode:
Last3DDevice key: all 0's
LastDisplayDevice key: 00,9f,a6,92,fa,13,d1,11,97,c0,00,a0,24,29,30,05 (again the commas just seperate the hex values).

I can export the reg keys and put them up for download if you cant change the values yourself.

Hope this helps, I cant think of anything else.

bgbennyboy is offline   you may: