lfnetwork.com mark read register faq members calendar

Thread: Rate of Fire on TIEs
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 03-22-2006, 08:01 PM   #1
zmohner
Lurker
 
Join Date: Mar 2006
Posts: 1
Rate of Fire on TIEs

I was just wondering why none of the games have the same rate or fire or sounds for the TIE-series of fighters; in the movies, they all (at least the ones with two guns) have a fast rate of fire with a "ch-ch-ch" sound, while the games give them the same rate of fire as other twin-gunned ships, and the same sound as other ships with green lasers. It seems to me that giving TIEs a higher rate of fire would not only bring the games that much closer to the movies, but also (albeit slightly, but every bit helps) shorten the massive gap between the effectiveness of Imperial versus Rebel fighters. Does anyone know if there's a mod out there that does this?
zmohner is offline   you may: quote & reply,
Old 03-22-2006, 08:12 PM   #2
Wildstar
Can outbowl most of you
 
Wildstar's Avatar
 
Status: Moderator
Join Date: Jun 2003
Location: Brockton, MA, USA
Posts: 1,498
10 year veteran! Forum Veteran LFN Staff Member 
Abolisher's Ashgard Campaign bills itself as an attempt to make the game more movie-like, but I don't know if he edited the rate of fire on the TIEs. I suppose you could always ask about it on the XWA Upgrade forums, as I've seen Abolisher post there recently.


Wildstar is offline   you may: quote & reply,
Old 04-24-2006, 06:40 AM   #3
BattleDog
Terrible in War
 
BattleDog's Avatar
 
Join Date: Aug 2001
Posts: 1,923
Roleplayer 
I can answer both questions. Firstly the ch-ch sound is present in XWA, once you release the trigger and your last bolt is clear you'll hear it.

As to the refire problem, its been present since X-Wing, we can't do anything about it and its basically a bug. There is one value which is applied to the refire rate of all guns which is why they are all the same, that value is, more or less, correct to the movies. However the formular used to calculate the refire of linked guns is wrong

Where r= the generic refire value applied to all guns g= the number of gun sets firing, i.e. the number of salvos per cycle and d= the resulting delay between salvos the formular should be this:

d=r/g

Instead g actually = the number of guns firing and the formular is:

d=r*g

The result is that instead of the delay between every full cycle being the same the delay between every shot is the same, so the more guns linked the slower they fire.

Does that answer your question, its a little complicated but basically some guy 20 years ago got his maths wrong and thats why the guns all fire slow.


Fly Fast,
Shoot Straight,
Live Long!
BattleDog is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > XWingAlliance.net > 1. XwingAlliance > Editing Corner > Rate of Fire on TIEs

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:50 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.