lfnetwork.com mark read register faq members calendar

Thread: Music during missions in XWCD
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 07-18-2006, 07:36 PM   #1
JD Ace
Lurker
 
Join Date: Jul 2006
Posts: 4
Music during missions in XWCD

This is my first post, so be gentile.
I am having a problem hearing music during the missons (only the missions) in X Wing collectors series. The music plays perfectly well at the flagship and in the transitions. However, during any mission (historical or ToD), no music.

I have XP and I have updated all my drivers.

I've seen this problem discussed on a few boards, but no solution. I was just hoping someone came up with the fix. (I just love the way the Star Wars theme plays when you complete a mission!)

Thanks in advance.

JD
JD Ace is offline   you may: quote & reply,
Old 07-19-2006, 10:45 AM   #2
Wildstar
Can outbowl most of you
 
Wildstar's Avatar
 
Status: Moderator
Join Date: Jun 2003
Location: Brockton, MA, USA
Posts: 1,488
10 year veteran! Forum Veteran LFN Staff Member 
You should probably double-check and see that you have music checked in your options. If this doesn't help, I suggest a post in the LucasArts support forums, as I don't know of a fix offhand (you will probably need to register, but if you have an account on the official site's forums {starwars.com}, you can use that login there, too).


Wildstar is offline   you may: quote & reply,
Old 07-19-2006, 05:19 PM   #3
JD Ace
Lurker
 
Join Date: Jul 2006
Posts: 4
Yes, I made sure that music was checked in the options (I even tried it with music off just to see, to no avail)

I noticed in this thread there was a similar problem with TIE Fighter. Anyone have this problem, too?
JD Ace is offline   you may: quote & reply,
Old 07-20-2006, 05:58 PM   #4
Wildstar
Can outbowl most of you
 
Wildstar's Avatar
 
Status: Moderator
Join Date: Jun 2003
Location: Brockton, MA, USA
Posts: 1,488
10 year veteran! Forum Veteran LFN Staff Member 
Emkay1001 on the LucasArts support forums suggests making sure the CD is in the optical drive you installed the game from. If you had removable storage devices on lower letters than your optical drive (say, you had a thumb drive on D: and your DVD burner on E: and the burner was reassigned to D: when the thumb drive was disconnected), then the game probably doesn't see the CD in the correct drive. You have two options: either uninstall the game and reinstall so that the game now sees the CD from the proper drive (back up your .plt files, first, of course), or edit the Windows Registry (run regedit, look in the key:

HKEY_LOCAL_MACHINE\SOFTWARE\LucasArts Entertainment Company LLC\X-Wing95\1.0

and modify the "CD Path" data to the letter of your optical drive by right-clicking on "CD Path" and choosing "Modify", which will bring up the dialog where you can change the drive letter...it wouldn't hurt to change "Analyze Path", "Source Dir", and "Source Path" to reference the optical drive's letter, as well"). Note: I do not recommend mucking w/ the Registry if you don't know what you're doing.



Last edited by Wildstar; 07-20-2006 at 06:07 PM. Reason: Made the Registry key appear on one line
Wildstar is offline   you may: quote & reply,
Old 07-21-2006, 03:56 PM   #5
JD Ace
Lurker
 
Join Date: Jul 2006
Posts: 4
Thanks for the help, Wildstar. I checked the Registry, but found it was pointed to the correct drive letter.

However, that got me thinking. I had loaded the game from my second optical drive (drive E: ). So I uninstalled, then reinstalled with the disk in the D: drive. And, by gum, it worked.

My belief is the game code ALWAYS looks to the D: drive, despite what Windows has in the registry. So there you have it!

JD
JD Ace is offline   you may: quote & reply,
Old 07-21-2006, 04:59 PM   #6
Wildstar
Can outbowl most of you
 
Wildstar's Avatar
 
Status: Moderator
Join Date: Jun 2003
Location: Brockton, MA, USA
Posts: 1,488
10 year veteran! Forum Veteran LFN Staff Member 
JD Ace

Do you have more than one optical drive?


Wildstar is offline   you may: quote & reply,
Old 07-21-2006, 05:37 PM   #7
JD Ace
Lurker
 
Join Date: Jul 2006
Posts: 4
Yes...2. D: and E:. However my E: drive is faster and (generally) better, so I use it preferentially.
JD Ace is offline   you may: quote & reply,
Old 07-22-2006, 11:54 AM   #8
Wildstar
Can outbowl most of you
 
Wildstar's Avatar
 
Status: Moderator
Join Date: Jun 2003
Location: Brockton, MA, USA
Posts: 1,488
10 year veteran! Forum Veteran LFN Staff Member 
Well, I think we deduced that the XWCS looks for the CD in the optical drive with the lowest letter, no matter what the Registry says. It should make no difference which one you use for audio, but if you really want your faster drive to have the lower letter and are using WinXP, what you *can* do is right-click My Computer, choose "Manage", click "Disk Management" in the left-hand tree, and change your optical drive's letter by right-clicking on the drive (found in the lower right pane) and choose "Change Drive Letter and Paths...". You will need to assign one of them to a temporary letter while you swap the assignments. Be sure to reboot after making the reassignment.


Wildstar is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Star Wars Classic Gaming > 2. Star Wars Gaming > X-Wing Trilogy & X-Wing Vs. TIE Fighter > Music during missions in XWCD

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:45 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.