lfnetwork.com mark read register faq members calendar

Thread: lightburn problem in jko but not in jka.
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 04-28-2009, 11:29 PM   #1
___ACROBAT___
Rookie
 
Join Date: Apr 2006
Posts: 29
lightburn problem in jko but not in jka.

I might have two solutions to the overbright lightburn problem.

The first is that I put boddo's shader on every texture in jk2 to prevent that overbright lightburn that happens so easily in jk2 but not in jka.

Here's the shader

Quote:
textures/duelroom/base_ceiling
{
qer_editorimage textures/duelroom/base_ceiling
{
map $lightmap
rgbGen identityLighting
}
{
map textures/duelroom/base_ceiling
blendFunc GL_DST_COLOR GL_ZERO
rgbGen identityLighting
}
}

However, I may have found another good solution to the problem just now. I was reading over the features of netradiant, a competitor to gtkradiant I guess, and I found the "Lightmap exposure" compile command since it has its own compiler.

Here's what it does
Quote:
The q3map2 light compile parameter -exposure changes the handling of overbright pixels to look more realistic. Try values like -exposure 200! The higher the value, the darker the result gets.

It is most interesting if you intentionally put colored lights of a far too high light value in your map.

This feature was contributed by the Urban Terror team.

I haven't tested this program yet since I'm using that shader that I like but in the future someone may want to try this out.
___ACROBAT___ is offline   you may: quote & reply,
Old 04-29-2009, 12:28 PM   #2
CrisG
Aging Jedi
 
CrisG's Avatar
 
Join Date: Dec 2007
Location: Colorado and California
Posts: 856
The Walking Carpets Guild Member 
i found the default light settings to be fine in both JKA and JKO but it is interesting to hear about adjusting shaders. thanks for sharing that.


There is no Chaos, There is Harmony.
----------------------------------------------------
Admin 3D Worlds and Game Developers Group - Linkedin - "We Build Worlds"
DF-JK DF2-DFMOTS-JKII-JKIII-KoTOR I-KoTOR II - XW-TF-XvT-BOP -XWA-Rogue Squad - Starfigher-Racer- RC-Battle for Naboo-Episode I Phantom Menace-Shadows of the Empire-BF I - BF II-EAW-EAW:FOC-Loom-Grim F-MI-MII-MIII-DOTT-IJFOA-IJLC-IJET-IJIM-Dig-Sam and Max HTR
CrisG is offline   you may: quote & reply,
Old 05-04-2009, 03:22 PM   #3
___ACROBAT___
Rookie
 
Join Date: Apr 2006
Posts: 29
jka

Well that's not my opinion. JKA doesn't use overbright (or if it has the capability it's turned off by default I forget), but it's on automatically in JKO.

You can manually turn off overbright but then the maps generally look to dark. You could map for it turned off, but most players wouldn't bother to manually turn it off if you explained what to do in the readme.

That's why I like to turn it off with a shader in jko so that everyone is seeing the same brightness and not seeing big white lightburns.
___ACROBAT___ is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Game Discussion > Jedi Outcast > lightburn problem in jko but not in jka.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:05 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.