lfnetwork.com mark read register faq members calendar

Thread: Windows XP Problem--help!
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 10-02-2003, 12:05 AM   #1
batman55
Lurker
 
Join Date: Oct 2003
Posts: 3
Windows XP Problem--help!

Hi,

I just installed GF, and I have a very up to date computer with Windows XP and Direct X9 installed.

With 16-bit graphics mode on, 3D acceleration off, I still notice problems with the game. The intro ran fine but when you get to the office, if you press F1 for the options screen, half the time all sound and music is gone for the remainder of the time GF is open.

I did analyze the computer and there were flags all over the place and missing files. I took a suggestion to put the game in Win95 compatibility mode, and though the game now runs fine, the cutscenes are extremely choppy and thusly unwatchable.

How does Win95 compatibility mode affect the game's performance? But besides that, what can I do to play this game on XP? Please respond--i'd appreciate it. You can email me at: nvoid3@hotmail.com
batman55 is offline   you may: quote & reply,
Old 10-02-2003, 02:03 AM   #2
Susan
Rookie
 
Susan's Avatar
 
Join Date: Aug 2003
Location: Minnesota, USA
Posts: 43
I recently got a new computer w/ WinXP and haven't tried installing any older games on it yet. I'm curious to see what people have to say.

Susan is offline   you may: quote & reply,
Old 10-02-2003, 06:35 AM   #3
Naughty_Sauce
Lurker
 
Join Date: Sep 2003
Posts: 5
I have to disable Hyper Threading on my P4 3.0 GHz PC (1024 MB PC3200 ram, ATI Radeon 9800 Pro, Windows XP Pro) in order for Grim to work properly. With HT enabled I had the same problems that batman55 described. With HT disabled the game seems to run flawlessly (no need for compatibility mode), although I've only played through year one so far on this PC.

EDIT: Oh, I am experiencing one strange problem. Whenever I launch GF (by clicking on "Play Grim Fandango"), instead of starting at the LA intro the game starts up at the last location I visited in my previous play session, except Manny's inventory is completely empty. I can load a saved game and continue playing without any problems, but there's no way to start a new game unless I uninstall/reinstall.

weird.

Last edited by Naughty_Sauce; 10-02-2003 at 03:02 PM.
Naughty_Sauce is offline   you may: quote & reply,
Old 10-02-2003, 09:41 AM   #4
Tall Guy
Est. 1985
 
Tall Guy's Avatar
 
Join Date: Dec 2001
Location: England
Posts: 1,173
have u downgraded ur Direct X9 to Direct X6.1? cos gf has problems on anything greater than 6.1

Tall Guy is offline   you may: quote & reply,
Old 10-02-2003, 09:42 AM   #5
Tall Guy
Est. 1985
 
Tall Guy's Avatar
 
Join Date: Dec 2001
Location: England
Posts: 1,173
btw could you make sure you read http://www.lucasforums.com/showthrea...threadid=29995 before you start posting about problems in the game, thanks.

Tall Guy is offline   you may: quote & reply,
Old 10-02-2003, 03:05 PM   #6
Naughty_Sauce
Lurker
 
Join Date: Sep 2003
Posts: 5
Quote:
Originally posted by Tall Guy
have u downgraded ur Direct X9 to Direct X6.1? cos gf has problems on anything greater than 6.1
He has Windows XP. I don't think it's possible to downgrade to DX 6.1.
Naughty_Sauce is offline   you may: quote & reply,
Old 10-03-2003, 01:09 AM   #7
batman55
Lurker
 
Join Date: Oct 2003
Posts: 3
How would one disable Hyper Threading? I'm pretty dumb about all the technical stuff, so a little help? thanks a lot.. i hope for a response!
batman55 is offline   you may: quote & reply,
Old 10-03-2003, 03:02 AM   #8
batman55
Lurker
 
Join Date: Oct 2003
Posts: 3
actually i figured it out.. just press F2 at startup.. and the game seems to work! thanx all
batman55 is offline   you may: quote & reply,
Old 10-03-2003, 03:02 AM   #9
Susan
Rookie
 
Susan's Avatar
 
Join Date: Aug 2003
Location: Minnesota, USA
Posts: 43
Quote:
Originally posted by Naughty_Sauce
He has Windows XP. I don't think it's possible to downgrade to DX 6.1.
I think there's a thread that mentions this somewhere ... but in order to downgrade you'd have to completely remove DX from your system. Not highly recommended unless you know what you're doing. Also, many games these days require a higher version of DX, so it'd be hard to to play anything new.

Susan is offline   you may: quote & reply,
Old 10-03-2003, 08:45 AM   #10
colinliew
Lurker
 
Join Date: Oct 2003
Posts: 2
Argh, I'm afraid I'm having problems with GF as well...any help will be greatly appreciated.

I'm running Windows XP, and I've satisfied all the technical requirements. I've also got DirectX 9.0, which may be the problem.

I've downloaded the patch, and when I troubleshoot, I get some exclamation marks telling me files are old or missing, and to reinstall DirectX. Even when I do, the exclamation marks don't go away.

My problem is that the game will freeze up for no apparent reason, or the sound and music will disappear.

I'm not very technically literate, so I can't "downgrade" DirectX, nor do I know how to disable my computer's Hyper Threading technology.

I'll be grateful for any advice.
colinliew is offline   you may: quote & reply,
Old 10-03-2003, 10:30 AM   #11
Thrik
Symbolically Compelling
 
Thrik's Avatar
 
Status: Administrator
Join Date: Dec 2000
Location: Nottingham, UK
Posts: 4,202
Hot Topic Starter Forum Veteran LFN Staff Member 
If your computer is decent then turn 3d Acceleration on, there's barely a computer in existence today which cannot support it and it will greatly enhance your experience.

If that doesn't solve it, I did hear there might be a problem regarding DX9 and GF. Try reading through some older posts and/or the sticky in this forum to research it.


Thrik is offline   you may: quote & reply,
Old 10-03-2003, 03:14 PM   #12
colinliew
Lurker
 
Join Date: Oct 2003
Posts: 2
Thanks a lot. I did turn the 3d Accelerator on, which made the game last about 5 minutes longer before freezing.

The material about uninstalling DirectX 9 doesn't seem to apply to XP, I think? And it does appear very technical...

Looks like I won't be playing GF for a while.
colinliew is offline   you may: quote & reply,
Old 10-04-2003, 05:28 AM   #13
Naughty_Sauce
Lurker
 
Join Date: Sep 2003
Posts: 5
In order to disable Hyper-Threading you first have to make sure your processor is HT Enabled. If you have a Pentium 4C (800 MHz FSB) clocked at either 3.2, 3.0, 2.8, 2.6, or 2.4 GHz then your processor is HT Enabled.

To disable it you need to access your motherboard's BIOS. To access your motherboard's BIOS you have to hold down a key on your keyboard as the system is first booting up (it's usually the delete key, but check the motherboard's manual to be sure). Once you're in the BIOS just follow the manual's instructions to disable HT. It's usually pretty simple. In one of the option screens you should find a setting labeled "Hyper-Threading" which is set to "enabled". Just switch the setting to "disabled" and you're set.

I would keep HT enabled when not playing Grim Fandango if I were you, as it does enhance the processor's performance.
Naughty_Sauce is offline   you may: quote & reply,
Old 12-14-2003, 11:35 PM   #14
Topperfoureight
Lurker
 
Join Date: Dec 2003
Posts: 2
After a lot of experimenting with all suggestions, the ONLY thing that gives both smooth cut scenes and avoids the loss of the sound is to disable hyperthreading on the P4. As described above, you have to get into the bios as the machine is booting to disable it, but it is not a big deal: you can just re-enable it the same way.
Topperfoureight is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Grim Fandango Discussion > General Forums > Glottis' Garage > Windows XP Problem--help!

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:43 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.