lfnetwork.com mark read register faq members calendar

Thread: Help w/alpha channels & shaders
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 12-22-2003, 09:03 AM   #1
Teancum
 
Teancum's Avatar
 
Join Date: Apr 2003
Posts: 187
Help w/alpha channels & shaders

I've been busy modifying the Alora2 skin to work with the default Twilek model, and I'm having trouble with shaders and my alpha channel. I created an alpha channel, but I didn't paint over the 'skin' portion of the model on the RGB. Well, I editid a .skin file and the players.shader, but color selection is a no-go, even though I edited them. Anyhow, here's the info I have:

.skin file
Code:
torsod,models/players/jedi_tf/torso_09.tga
l_handd,models/players/jedi_tf/torso_01_hands.tga
l_handd_cap_l_arm_off,models/players/stormtrooper/caps.tga
r_handd,models/players/jedi_tf/torso_01_hands.tga
r_handd_cap_r_arm_off,models/players/stormtrooper/caps.tga
l_handd_cuff,models/players/jedi_tf/torso_08_cuffs.tga
r_handd_cuff,models/players/jedi_tf/torso_08_cuffs.tga
torsod_lower,*off
l_armd,models/players/jedi_tf/torso_01_arms.tga
l_armd_cap_torso_off,models/players/stormtrooper/caps.tga
l_armd_cap_l_hand_off,models/players/stormtrooper/caps.tga
r_armd,models/players/jedi_tf/torso_01_arms.tga
r_armd_cap_torso_off,models/players/stormtrooper/caps.tga
r_armd_cap_r_hand_off,models/players/stormtrooper/caps.tga
torsod_cap_l_arm_off,models/players/stormtrooper/caps.tga
torsod_cap_r_arm_off,models/players/stormtrooper/caps.tga
torsod_skin,models/players/jedi_tf/torso_09.tga
and players.shader:
Code:
models/players/jedi_tf/torso_09
{
    {
        map models/players/jedi_tf/torso_09
        blendFunc GL_ONE GL_ZERO
        rgbGen lightingDiffuseEntity
    }
    {
        map models/players/jedi_tf/torso_09
        blendFunc GL_SRC_ALPHA GL_ONE_MINUS_SRC_ALPHA
        rgbGen lightingDiffuse
    }
}
The skin shows up, but the color selections don't work on it. But, it did work when I referenced the original .tga, torso_04.tga for the torsod_skin -- However, there's more skin showing, and that alpha will not be enough. I assume I'm just doing the alpha wrong. Can anyone help me?
Teancum is offline   you may: quote & reply,
Old 12-23-2003, 12:00 PM   #2
razorace
Impressive, Terran!
 
razorace's Avatar
 
Join Date: May 2002
Posts: 9,172
Just change the alpha. I don't see the problem in that.


---Jedi Guardian of the Newbie Questions
---Masters of the Force Team Leader / Creator
---Open Jedi Project Lead Moderator / Co-Founder
razorace is offline   you may: quote & reply,
Old 12-23-2003, 06:37 PM   #3
Teancum
 
Teancum's Avatar
 
Join Date: Apr 2003
Posts: 187
I found the problem. It wasn't me at all. It's just that the parts of the Twi'lek skin tone that can be changed are in the model, not the .skin, texture or shader. I made some changes to the texture, and it worked. However, now my new icons look funny, but I'm looking into that.
Teancum is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Editing Central > JA Skinning > Help w/alpha channels & shaders

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:19 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.