lfnetwork.com mark read register faq members calendar

Thread: vehicle ship ->animation
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 04-11-2004, 03:28 PM   #1
|_Stiller_|
Lurker
 
Join Date: Apr 2004
Posts: 9
Question vehicle ship ->animation

hi,
i build a small ship for 3 passangers. (3dsM@x6)
i tried to make an animation like the xwing
(both_wings_open,...)
but it doesnt work.
my ship is in peaces in game, and nothing want to move if i
start or land.
( i added "reset Xform" to all meshes and did "collapes all"..., it diddnt help)
so i tried to do it without the animation.
( rewighted everything to a bone what doesnt move in the animatin.
every peace of the ship is there where it have to be, but the
ship is in a wrong angle, the nose is looking up.
everything els is working.. new sounds,weapons... .

how can i get the animation work?
have i to use a special skeleton?


excuse, my english isnīt good eh.


thx
Stiller
|_Stiller_| is offline   you may: quote & reply,
Old 04-14-2004, 08:17 AM   #2
Duncan_10158
 
Duncan_10158's Avatar
 
Join Date: Apr 2002
Posts: 365
the question is how did you animate your vehicle?

the first step is always to bring the vehicle in game without animation, so can can see that the ship looks right and the orientation is correct. in your case just rotate the vehicle in 3ds max so it will be correct in the game.

for the animation, you have to construt a special bone structure. to just animate the meshed doesnt work. the skeleton have to be so it can do all the animations the vehicle you want to have. weight the vehicle meshes to this skeleton and the animate only the skeleton. the meshes will follow because they are weighted to the bones.

the exporting and assimilate prozess workes the same as not animated vehicles, just the gla file is bigger.

then you have to make sure the right line in animation.cfg file points to the starting frame and animation lenght of the animation in 3ds myx you made.


of course i left out many details, but this is the main direction you have to follow. if you know how to import vehicles, animation is just one step more.

btw, what XSI exporter for 3ds max 6 do you use? lot of people ask me this, would be nice if i could finaly point them to the right place
Duncan_10158 is offline   you may: quote & reply,
Old 04-15-2004, 01:32 PM   #3
|_Stiller_|
Lurker
 
Join Date: Apr 2004
Posts: 9
This one i am using:
Quote:
Originally posted by 7th Jedi
There's a working exporter here:

The direct link for the export plugin is here:
http://sourceforge.net/project/showf...ease_id=205314

(Download the bin file)

getting anything in-game.
--
Quote:
Originally posted by Duncan_10158
the question is how did you animate your vehicle?

i build a skeleton with 19 bones (pelvis in the center/all bones weighted). the animations work in 3dsM@x, but not in game.
i set the frames...20f/s.
Root:
XSISceeneRoot
|
B:modelroot - mesh_root
|
skeleton_root


in assimilate i added the enums:
both_wing_open/close,gears_open/close,root...
for the anim.cfg i tock the x.wing one and changed the frames.

Quote:
Originally posted by Duncan_10158

for the animation, you have to construt a special bone structure. to just animate the meshed doesnt work. the skeleton have to be so it can do all the animations the vehicle you want to have. weight the vehicle meshes to this skeleton and the animate only the skeleton. the meshes will follow because they are weighted to the bones.

[/B]
so i dont need anny tags? and i can name the bones
what i want, right?

thx
Stiller
|_Stiller_| is offline   you may: quote & reply,
Old 04-15-2004, 06:14 PM   #4
Duncan_10158
 
Duncan_10158's Avatar
 
Join Date: Apr 2002
Posts: 365
in assimilate you dont have to added any enums, use assimilate exactly the same way like the non-animated tutorials. you have to edit the animation.cfg file anyway so you dont have to do that in assimilate.

Quote:
i build a skeleton with 19 bones (pelvis in the center/all bones weighted). the animations work in 3dsM@x, but not in game.
all bones weighted? you weight the meshes to the bones, not the bones itself, right?

the bone structure is under pelvis and that is linked to skeleton_root, like you wrote.

Quote:
so i dont need anny tags? and i can name the bones
of course you need the same tags as a non-animated vehicle but you dont need any other. and the bone names can be whatever, also to name the first bone pelvis is not ultimatly needed, i just suggest to keep one convention.
Duncan_10158 is offline   you may: quote & reply,
Old 04-22-2004, 05:40 PM   #5
|_Stiller_|
Lurker
 
Join Date: Apr 2004
Posts: 9
thx

is there a way to fix the model angle outside of 3dsm@x?
for examle a cmd which i can add in the car-file,
like angle x0 y0 z90 ??

Stiller
|_Stiller_| is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Editing Central > JA Modeling > vehicle ship ->animation

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:12 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.