lfnetwork.com mark read register faq members calendar

Thread: Revenge of the sound problems
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 07-11-2004, 05:21 PM   #1
mknote
 
mknote's Avatar
 
Join Date: Jun 2003
Location: Selma, IN
Posts: 163
Revenge of the sound problems

I haven't posted here since December 24, 2003. The reason: sound problems with my map mixed with my impatience. Well, I load her up... same problem. I will tell you: I have four congruent rooms. In the top-left, bottom-left, and bottom-right rooms, the sound is fine. In the top-right room, however, the sound seems muffled. It isn't the target-speaker: I copied one from the other rooms, where it works fine, and put it outside of all the rooms, outside of my "castle." It worked fine; could hear the sound easily, and clearly. I put it in the trouble room... BAM! It becomes basically muted. This is very bothersome. Why are my sounds (FYI, it is torch_burning_lp) work everywhere but one room? More importantly how do I fix it? I've ran every compile, too. If I can fix this, I may release a map after all.

MK
mknote is offline   you may: quote & reply,
Old 07-12-2004, 01:25 PM   #2
shukrallah
White Dragon
 
shukrallah's Avatar
 
Join Date: Nov 2002
Posts: 3,250
Hmm.. Try scripting the sound. Also, it could be that you have to many sounds playing at once, so it just stops playing certain sounds.
shukrallah is offline   you may: quote & reply,
Old 07-12-2004, 01:28 PM   #3
WadeV1589
Veteran
 
WadeV1589's Avatar
 
Join Date: Sep 2003
Location: Leeds, UK
Posts: 952
is this room linked to other rooms that have the same sound? if so it will simply increase the volume of the original sound instead of actually playing a sound itself.

target_speakers have a collective method of working if they're in close proximity.


StargateMods.com - collaborating all the Stargate mods out there.

SG4RealJA - get a bit of SG realism!
SGEgyptJA - flying and dialing a gate only to be killed by it!
WadeV1589 is offline   you may: quote & reply,
Old 07-12-2004, 09:58 PM   #4
mknote
 
mknote's Avatar
 
Join Date: Jun 2003
Location: Selma, IN
Posts: 163
It's spreading

As I put more lights (fires, with the sound), I find that it is nearly an entire quarter of the map without sound. If it does amplify the sound, why can't I hear it in that room. It is simply supposed to make the fire have sound, but now it doesn't in specific parts of the map. My map is just about done (at least with the actual design), and I really need to solve this... any ideas? BTW, my scripting abilities are less than great, and these sounds need to play consistantly.

MK
mknote is offline   you may: quote & reply,
Old 07-12-2004, 10:08 PM   #5
shukrallah
White Dragon
 
shukrallah's Avatar
 
Join Date: Nov 2002
Posts: 3,250
Hmm... I got it! I think...!

You must be using Fxrunners right? I looked under its description in Radiant (im in SP mapping mode, but it should work in MP)

Ok, apparently you can add in a 'soundset'! So instead of the target_speaker, add soundset:

Quote:

From GTK
"soundset" - bmodel set to use, plays start sound when toggled on, loop sound while on ( doesn't play on a oneshot), and a stop sound when turned off
So, for the key put 'soundset' for the value put your sound file. Im not sure if you need the .mp3 or .wav or even if you need the sounds/whatever.... just play around with it. Right now you dont have anything to lose
shukrallah is offline   you may: quote & reply,
Old 07-13-2004, 12:13 PM   #6
mknote
 
mknote's Avatar
 
Join Date: Jun 2003
Location: Selma, IN
Posts: 163
Nope

When I try to load the map, it gives the the "missing soundsets" error. In the consol, it says "missing ambient soundset sound/effects/torch_burning_lp.wav" so that didn't work. Anything else that might help?

MK
mknote is offline   you may: quote & reply,
Old 07-13-2004, 03:09 PM   #7
shukrallah
White Dragon
 
shukrallah's Avatar
 
Join Date: Nov 2002
Posts: 3,250
Oh man, I cant get it working either
shukrallah is offline   you may: quote & reply,
Old 07-13-2004, 07:33 PM   #8
wedge2211
Commander, Rogue Squadron
 
wedge2211's Avatar
 
Join Date: Jul 2002
Location: Ithaca, NY
Posts: 2,320
Yeah, "soundset" is not for a specific sound file. "soundset" refers to one of the sets in sounds/sound.txt, such as impdoor1, rainy, etc.

Individual sound files go with the "noise" and "sound" keys.


wedge2211 is offline   you may: quote & reply,
Old 07-14-2004, 01:46 AM   #9
lauser
 
lauser's Avatar
 
Join Date: Jan 2003
Location: CANADA
Posts: 428
You know it didn't used to be this way. JK2 Radiant was a lot easier to add sound to from what I remember. I guess I'm going to have to add quite a few speakers to my large outdoor area which sucks.....oh well....


My kung fu is also very weak
lauser is offline   you may: quote & reply,
Old 07-14-2004, 06:25 PM   #10
wedge2211
Commander, Rogue Squadron
 
wedge2211's Avatar
 
Join Date: Jul 2002
Location: Ithaca, NY
Posts: 2,320
It's exactly the same as JO... "Sound" and "noise" are for sound files, "soundset" is for sound sets...


wedge2211 is offline   you may: quote & reply,
Old 07-15-2004, 10:04 AM   #11
shukrallah
White Dragon
 
shukrallah's Avatar
 
Join Date: Nov 2002
Posts: 3,250
Sadly, some of the soundsets dont work right at all, a while back I added one to a tram I made, but... no sound. It was a func_train (I think) but it never played the sound, unless func_trains just dont play sounds.
shukrallah is offline   you may: quote & reply,
Old 07-15-2004, 03:44 PM   #12
Ockniel
 
Ockniel's Avatar
 
Join Date: Jun 2003
Location: at a theater near you!
Posts: 608
I guessing that I have no idea whats going on, but couldn't you just use a large trigger that covers everywhere or something to play the sound? or maybe alot of small triggers in certain areas, i dunno, just an idea
Ockniel is offline   you may: quote & reply,
Old 07-15-2004, 07:34 PM   #13
wedge2211
Commander, Rogue Squadron
 
wedge2211's Avatar
 
Join Date: Jul 2002
Location: Ithaca, NY
Posts: 2,320
Yeah, actually, I recall func_trains not being too accepting towards sounds.


wedge2211 is offline   you may: quote & reply,
Old 07-16-2004, 09:05 PM   #14
mknote
 
mknote's Avatar
 
Join Date: Jun 2003
Location: Selma, IN
Posts: 163
I am getting VERY upset... I could send the .map for it, if it will help solve this. Otherwise, help is needed. It has offically taken up 1/4 of the map (the sound problem).

MK
mknote is offline   you may: quote & reply,
Old 07-17-2004, 01:49 PM   #15
mknote
 
mknote's Avatar
 
Join Date: Jun 2003
Location: Selma, IN
Posts: 163
FIXED... maybe

Well, I found a partial fix. I ran -vis (must not have) and the sound worked... well, not as it should. Now, areas where I had sound, I don't. However, this time, I propose that I know what the problem is. I am now outside of one of the four rooms I mentioned earlier. I can't hear the sound of the fires inside the room: since I just ran -vis, it must be that my leaf node is blocking the sound (the outside walls of the rooms are structural, because my framerate could use a boost). When I made them detail brushes, ran -vis, and used /developer 1 /r_showtris 1, the framerate was FAR lower than with them structural, about 30 FPS lower. It wasn't as drastic without the /r_showtris, only about 13 FPS lower. But, I am afriad that it may add up as I add hills around the outside of the castle. So, what should I do, go with realism, or high framerates? Or can I reach a midway? I should be ready to beta-test this in 2-3 weeks, so where should I ask for beta-testers when the time comes? TIA.

MK
mknote is offline   you may: quote & reply,
Old 07-17-2004, 03:11 PM   #16
B00mer
Rookie
 
B00mer's Avatar
 
Join Date: Jul 2004
Location: Maryland, US
Posts: 22
I will beta test it. I really hope your castle works out. This is starting to sound like mapping in JA is too hard.


ESTAS Every Scar Tells A Story
B00mer is offline   you may: quote & reply,
Old 07-18-2004, 01:12 AM   #17
mknote
 
mknote's Avatar
 
Join Date: Jun 2003
Location: Selma, IN
Posts: 163
Well, I made a GROSS understatement... I may be ready for beta-testing as early as tomorrow! I would like to have Wade and/or Wedge and/or lukeskywalker1 to be amongst them, so I can have an expert opinion before I offically release it. Beta-testers, naturally, will be credited in the readme: PM me if you want to be a beta-tester, and if you will be -BSP (just looking for gameplay errors), -vis (looking at framerate, tri count, ect.), or -light (looking at the lighting, and for visual errors). There is the one NEW sound problem (see my last post), and I ask beta-testers to find others. The only thing left on this map is items and spawn points. TIA.

MK
mknote is offline   you may: quote & reply,
Old 07-18-2004, 02:10 PM   #18
WadeV1589
Veteran
 
WadeV1589's Avatar
 
Join Date: Sep 2003
Location: Leeds, UK
Posts: 952
get me on msn and i'll gladly comment on the map, provided you get me tonight or tomorrow, cuz then I'll be busy for the week.

eternus_insilenti[at]hotmail.com


StargateMods.com - collaborating all the Stargate mods out there.

SG4RealJA - get a bit of SG realism!
SGEgyptJA - flying and dialing a gate only to be killed by it!
WadeV1589 is offline   you may: quote & reply,
Old 07-21-2004, 03:53 PM   #19
mknote
 
mknote's Avatar
 
Join Date: Jun 2003
Location: Selma, IN
Posts: 163
Wade, it returned my e-mail. It is quite large (8 megabytes, even while zipped), so maybe I need to send it elsewhere? Ideas?

MK
mknote is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Editing Central > JA Mapping > Revenge of the sound problems

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:44 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.