lfnetwork.com mark read register faq members calendar

Thread: ARrrg stupid fog! need help w custom fog.
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 04-28-2006, 08:16 PM   #1
SD_Radical_Ed
Junior Member
 
SD_Radical_Ed's Avatar
 
Join Date: Oct 2003
Location: Jedi Academy v 1.00!!!!!
Posts: 252
ARrrg stupid fog! need help w custom fog.

ok the shadre:

textures/Angel/cloudlayer2
{
surfaceparm nonsolid
surfaceparm nonopaque
surfaceparm trans
surfaceparm fog
q3map_nolightmap
{
map textures/skies/cloudlayer2
blendFunc GL_ONE GL_ONE
rgbGen identity
tcMod turb 0 1 0 0.1
tcMod rotate -7
}
{
map gfx/effects/alpha_smoke
blendFunc GL_ONE GL_ONE
tcMod rotate 10
tcMod turb 0 0.1 1 0.1
}
{
map textures/skies/cloudlayer4
blendFunc GL_ONE GL_ONE
rgbGen identity
tcMod turb 0.5 0.5 0.2 0.05
tcMod rotate 10
}

}


i made a brush at the bottom of my map and textured it with textures/Angel/cloudlayer2, but when i load the map, the brush is always solid.


HGR_Gaara_Of_The_Sand_TRI
I am the S.H.I.T. (Shinobi Hokage In Training)
SD_Radical_Ed is offline   you may: quote & reply,
Old 04-29-2006, 09:20 PM   #2
MDN14
Rookie
 
Join Date: Sep 2003
Posts: 159
are you sure that in GTK Radiant that the texture in the texture selection area has white lines around the texture and if you shift click the texture it opens the shader for editing? Because if it doesnt then you shader is not being loaded properly in Radiant and so it wont compile as it should either. I find that the most common reason that it isnt loading in Radiant is because the shader didnt get added to a line in the shaders.txt file
MDN14 is offline   you may: quote & reply,
Old 04-30-2006, 02:46 AM   #3
SD_Radical_Ed
Junior Member
 
SD_Radical_Ed's Avatar
 
Join Date: Oct 2003
Location: Jedi Academy v 1.00!!!!!
Posts: 252
how do i fix that so that it loads properly?


HGR_Gaara_Of_The_Sand_TRI
I am the S.H.I.T. (Shinobi Hokage In Training)
SD_Radical_Ed is offline   you may: quote & reply,
Old 04-30-2006, 05:50 AM   #4
{NJO}*Dark
Rookie
 
{NJO}*Dark's Avatar
 
Join Date: Feb 2004
Location: cyberspace.co.uk
Posts: 149
open up the shaders.txt file (found in base/shaders/) and at the bottom add a line saying <yourshadername> (which looks like it will be Angel)


~Dark
{NJO}*Dark is offline   you may: quote & reply,
Old 04-30-2006, 01:11 PM   #5
SD_Radical_Ed
Junior Member
 
SD_Radical_Ed's Avatar
 
Join Date: Oct 2003
Location: Jedi Academy v 1.00!!!!!
Posts: 252
mmm
not working...
what i have been doing is texturing things with the texture and adding the shader in the shaders folder to apply to that texture...


HGR_Gaara_Of_The_Sand_TRI
I am the S.H.I.T. (Shinobi Hokage In Training)
SD_Radical_Ed is offline   you may: quote & reply,
Old 04-30-2006, 03:34 PM   #6
SD_Radical_Ed
Junior Member
 
SD_Radical_Ed's Avatar
 
Join Date: Oct 2003
Location: Jedi Academy v 1.00!!!!!
Posts: 252
ARRRG! ok, now its a nonsolid translucent box with the textures scrolling around it, but its not behaving like a volumetric fog. when i go inside the box, its empty, i.e., no foggy effect.


HGR_Gaara_Of_The_Sand_TRI
I am the S.H.I.T. (Shinobi Hokage In Training)
SD_Radical_Ed is offline   you may: quote & reply,
Old 04-30-2006, 07:09 PM   #7
SD_Radical_Ed
Junior Member
 
SD_Radical_Ed's Avatar
 
Join Date: Oct 2003
Location: Jedi Academy v 1.00!!!!!
Posts: 252
ok i got it workin


HGR_Gaara_Of_The_Sand_TRI
I am the S.H.I.T. (Shinobi Hokage In Training)
SD_Radical_Ed is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Editing Central > JA Mapping > ARrrg stupid fog! need help w custom fog.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:08 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.