lfnetwork.com mark read register faq members calendar

Thread: Need help with HUD
Thread Tools Display Modes
Post a new thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Prev Previous Post   Next Post Next
Old 08-20-2006, 12:05 PM   #1
UDM
 
Join Date: Mar 2003
Posts: 922
Need help with HUD

I'm working on a new HUD, and have made quite a number of changes to the UI files. However, when I go ingame, I get either black boxes or nothing at all

I'm not sure what's wrong with the code. For example, I only changed the rect syntax in this part of the code:

// Metal Frame
itemDef
{
name "frame"
forecolor 1 1 1 1
background "gfx/hud/hudleft"
rect 0 0 100 100 // (these positions are relative to the initial position of the menu)
// X pos, Y pos, char size, char height
}

I bolded the part which was changed.

The game, however, shows a big <censored> black box ingame! Funnily enough, some other itemDef's that I changed actually show up the intended tga! Eg this:

// Right Metal Frame
itemDef
{
name "frame"
forecolor 1 1 1 1
background "gfx/hud/hudright.tga"
rect 0 0 -100 100 // (these positions are relative to the initial position of the menu)
// X pos, Y pos, char size, char height
}

I'm really frustrated now. Spent a whole day trying to figure this out. I thouguht that the background syntax had to be linked directly to shader files, but even after experimenting with that, it still gave me a bloody black box. It's almost as if the game is being choosy, selectively showing what it wants to display

Please help!!!!!!!!!
UDM is offline   you may: quote & reply,
Post a new thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Editing Central > JA Coding > Need help with HUD

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:31 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.