lfnetwork.com mark read register faq members calendar

Thread: Dedicated Problem! net_ip: "localhost"??
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 03-26-2006, 09:21 AM   #1
Jumms65
Lurker
 
Join Date: Mar 2006
Posts: 5
Dedicated Problem! net_ip: "localhost"??

Hello, I see that I'm facing the same problem as a lot of other people here, but my answer hasn't been found through my searching the other posts all day yesterday. Here's my problem. I have started a dedicated server with a correct config. I have the 1.2 DC Public Mod on it. BUT it seems no one can join or find it. I believe the problem lies behind
net_ip: "localhost"
I have forwarded ports "28070~28099" for my LAN connection. I have a linksys modem. I'm not sure how to set a new net_ip for my server. And if that is not the case please help!! My version is up to date, I also have the dedicated server up to date! All replies are greatly appreciated! THANK YOU!

EDIT: This is for a JK2 Dedicated Server. I've heard that I might need a different program to run my jk2ded server besides the jk2ded.exe.

EDIT: Here is the url to my config file:
[edit: removed by bill pending some changes to it]

Last edited by acdcfanbill; 03-26-2006 at 11:29 AM.
Jumms65 is offline   you may: quote & reply,
Old 03-26-2006, 11:28 AM   #2
Jumms65
Lurker
 
Join Date: Mar 2006
Posts: 5
Ok, I think I've found the real problem. My net_ip is "localhost", which is my 192.168.1.0 ip... my static ip. I want to change this to my internet ip. Could anyone tell me how to do this?
Jumms65 is offline   you may: quote & reply,
Old 03-26-2006, 11:30 AM   #3
acdcfanbill
..the wonders I have seen
 
acdcfanbill's Avatar
 
Status: Super Moderator
Join Date: Jun 2001
Location: Random Hell Wholes around the
Posts: 5,697
Imperialist Meatbags Guild Member The Walking Carpets Guild Member LFN Staff Member 10 year veteran! 
i just removed your link, because your server config contains your rconpassword, you might wanna edit that and then relink it. otherwise, im not too keen on ded servers so i dunno.

acdcfanbill is offline   you may: quote & reply,
Old 03-26-2006, 11:39 AM   #4
Jumms65
Lurker
 
Join Date: Mar 2006
Posts: 5
Thank you so much for notifying that! I've fixed it...
here's the link again!
http://www.geocities.com/klunk6590/jk2ded.htm
Jumms65 is offline   you may: quote & reply,
Old 12-29-2006, 03:52 PM   #5
killerDOTcom
Rookie
 
killerDOTcom's Avatar
 
Join Date: Dec 2005
Location: behind you with a knife
Posts: 21
YES PLEase. I'm having the exact same problem, cept im running on JA+ mod, which really shouldn't make a difference. My IP changes every time i reconnect, but that really shouldn't be the problem either.

NOBODY, not even me, can see my freaking server, and I've tried everything on my own-- i set the net_forcenonlocal to 1, did absolutely nothing. I can't set the net_ip to anything but localhost without it completely not working.

I've set the port to 21000, that's default, and dedicated to 2, and set the com_hunkmegs (whatever that is) to 64. That is all the defaults for my dedicated server.

SOMEbody please help us, come on.

EDIT: I forgot to mention, i'm using jedi academy, but it really has the exact same problem as jk2 does, they use the same engine.

EDIT: Also, I work behind a router, but my network admin insists that there is no interference by the router .. is he mistaken??


"If I see one more fricken bag a dirt..." -Allied Engineer, CoH
killerDOTcom is offline   you may: quote & reply,
Old 01-09-2007, 05:27 AM   #6
jedi-Guard
Rookie
 
Join Date: Sep 2005
Posts: 207
I might can help alittle, but not for sure.
If you have internal ip like 192.168.0.1, then you need to forward the ports, i dont remember the Jedi Outcast port numbers.
Even if its working or not, you will see it as local dedicated server, because you are on the same network as the dedicated computer is, doesnt matter if its your or the one next to you.
Disable Firewalls and Virus scanners or what ever you have.
If that doesnt work, try to remove the router and connect only that computer and see if you get Public or Internal ip, if you get internal ip, you might gonna have to pay to get a single Public ip, just like i did couple of times.
Good Luck.
jedi-Guard is offline   you may: quote & reply,
Old 01-22-2007, 10:48 PM   #7
Quebus
 
Quebus's Avatar
 
Join Date: Jul 2002
Posts: 13
Seeing this late but a couple things to verify. Are you sending heartbeats to the master server? If you are, you can try +set net_ip "123.123.123.123" (insert your WAN IP) on the command line to launch your server. Typically though this is used to support multiple server instances/IPs on a single server box. I'm not even sure it's a valid JA/JK cvar but it is in the q3a engine.
Quebus is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Help Center > Dedicated Server > Dedicated Problem! net_ip: "localhost"??

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:55 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.