lfnetwork.com mark read register faq members calendar

Thread: Game Crashing & Freeze/Lag problem
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 08-16-2008, 02:29 AM   #1
Luqkim
Lurker
 
Join Date: Aug 2008
Posts: 7
Game Crashing & Freeze/Lag problem

Hi, I've been trying to replay Battlefront 2 now, and the game has been causing me lots of problems.

Whenever I start a battle, the game would go smoothly for about a few minutes.
Around 2 or 3 minutes of fighting later, the game suddenly starts to freeze or lags terribly and the game becomes totally unplayable.

Also, I can't seem to load Galactic Conquest or "Kashyyyk: First Line of Defence" mission, so I can't get pass that mission to continue the game.

I have both the CD and DVD versions of the game. I can play with the patch with the CD version, but the I cant patch the game with the DVD version (it'll keeps telling me I put in the Wrong Disc if I patch it).

Also, even if I do managed to finish a battle, the game will crash whenever I click "Done" and return me to my desktop.
Luqkim is offline   you may: quote & reply,
Old 08-16-2008, 12:18 PM   #2
M@RS
The New Tax Collector
 
M@RS's Avatar
 
Join Date: Jan 2008
Location: Thailand
Posts: 1,898
With the game crashing, I'm having the same problem, except it's only for the Instant Action Mos Eisley (weird) the freeze and lag, did you check to see that your computer is compatible with SWBF2...


Looks like a fruit cake to me. - Brutus
Quote:
Originally Posted by Q View Post
I don't want to get my hopes up, but it's like the planets are aligning or something.
M@RS is offline   you may: quote & reply,
Old 08-16-2008, 12:30 PM   #3
Luqkim
Lurker
 
Join Date: Aug 2008
Posts: 7
Yeah, my computer should be more than compatible for the game

Here are my specs:

AMD 64 Athlon X2 Dual Core Processor +4600 (2.4Ghz)
Leadtek WinFast PX9600GT
2GB DDR2-667 RAM

I'm using Windows XP and not Vista.
Luqkim is offline   you may: quote & reply,
Old 08-16-2008, 04:35 PM   #4
M@RS
The New Tax Collector
 
M@RS's Avatar
 
Join Date: Jan 2008
Location: Thailand
Posts: 1,898
Hmm, I'm using Vista...But, yeah your computer should run it just fine...have you tried uninstalling and installing again? And, do you have any mods?


Looks like a fruit cake to me. - Brutus
Quote:
Originally Posted by Q View Post
I don't want to get my hopes up, but it's like the planets are aligning or something.
M@RS is offline   you may: quote & reply,
Old 08-16-2008, 11:52 PM   #5
Luqkim
Lurker
 
Join Date: Aug 2008
Posts: 7
Yeah, I tried reinstalling it many times, and no I'm not using any mods.

:C
Luqkim is offline   you may: quote & reply,
Old 08-18-2008, 09:48 AM   #6
TripHammer
Junior Member
 
TripHammer's Avatar
 
Join Date: Sep 2005
Location: Boston, MA USA!!! XFIRE: triphammer666
Posts: 314
When running dual core you may have to turn one of the cores off. The game has a problem specifically with the AMD X2. The procedure to turn one core off when running the game can be found in the SWBF2 Tweakguide. It also has other CTD issues. It sometimes refers to the SWBF1 tweakguide, but that's because the engines are similar.

SWBF2 Tweakguide HERE

GL!


TripHammer is offline   you may: quote & reply,
Old 08-23-2008, 03:33 PM   #7
M@RS
The New Tax Collector
 
M@RS's Avatar
 
Join Date: Jan 2008
Location: Thailand
Posts: 1,898
I know the problem, try turning down your lighting quality in the video options, it worked for me


Looks like a fruit cake to me. - Brutus
Quote:
Originally Posted by Q View Post
I don't want to get my hopes up, but it's like the planets are aligning or something.
M@RS is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > SWBattlefront.net (SWBF I & II) > Star Wars Battlefront II > Tech Help > Game Crashing & Freeze/Lag problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:54 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.