lfnetwork.com mark read register faq members calendar

Thread: Unable to get JK/MOTS to work on Windows XP SP3
Thread Tools Display Modes
Post a new thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Prev Previous Post   Next Post Next
Old 09-20-2009, 01:54 PM   #1
Master Toddy
 
Join Date: Mar 2002
Posts: 76
Unable to get JK/MOTS to work on Windows XP SP3

Okay, so the release of the complete JK collection on Steam has rekindled my interest in the series. Even though I still have original copies of all the old games I wanted the digital copy (in case I lost my original copies, you never know, some of those I've had for 10+ years!). Now I had not actually tried playing Jedi Knight with XP SP3 so did not know of the problems getting it to work...anyway, I purchased the Steam pack, downloaded all the games, and imagine my surprise when I tried launching Jedi Knight and Mysteries of the Sith and...nothing happened. My screen flashes black and I get thrown back to the desktop.

So I tried various things. Based on what others have said I downgraded my graphics drivers to 186.18 and that didn't work. Steam wouldn't let me run in compatability mode but I tried installing my old retail copy of the game and I tried various compatability modes with it and that didn't work...nothing I have been able to try will work on either of those games. The other three games, Dark Forces, Jedi Outcast and Jedi Academy all work fine.

So what can I do to get these games to work? Anything?

My system specs:

Windows XP SP3 32-bit
Nvidia Geforce 8600GTS 512 mb
2 gb PC3200 DDR Ram
Nvidia Nforce 4 motherboard
Creative X-Fi Xtreme Gamer sound card
Maxtor 500GB Sata Hard drive (I have two other drives but this is the one that Steam is installed on)

All drivers are up to date to the best of my knowledge. My system has been defragmented recently and there are no viruses/spyware on my system. I've killed all background applications before launching, I have all Windows system updates...I've searched the internet high and low for an answer and have since been able to find none. Can anybody help me out with this?
Master Toddy is offline   you may: quote & reply,
Post a new thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Game Discussion > Jedi Knight / MotS > Unable to get JK/MOTS to work on Windows XP SP3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:43 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.