lfnetwork.com mark read register faq members calendar

Thread: Modder needs help!
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 11-21-2010, 11:18 AM   #1
Mister_TSquared
Lurker
 
Join Date: Nov 2010
Posts: 1
Modder needs help!

Hello!

Iím trying to make a custom lightsaber and get it in-game using USMís method (link the model to a certain crystal). Iím doing this by ďcloningĒ Dookuís lightsaber (copying the lightsaber files and giving the copies the number 255 instead of 116). Itís currently using the same model as Dookuís, but thatís gonna change once I finish the model Iím making.

Iím running into a couple of problems. When I spawn my lightsaber in-game, it has the same description/properties that I gave it, but itís using the crystal for Dookuís lightsaber (the Vkuen spire crystal). Also, I created a custom crystal for the new saber (again, by copying and renaming the Vkuen files), but the game doesnít seem to understand whatís going on. When I get the crystal using giveitem, the crystal does not register on the workbench. When I spawn the crystal on a corpse (the corpse in the Peragus morgue, after which Kreia speaks to you), the crystal DOES register on the workbench. However, when I go to put the crystal in a standard lightsaber, the saber becomes Dookuís instead of my own, and if I click assemble, my custom crystal turns into the Vkuen crystal.

Iíve renamed the resref, tag items, and model variations appropriately using kotor tool, but that didnít work. Iíve tried using the renamer/replacer option in Mdlops on the ďnewĒ saber model to rename the 116 to 255. That also didnít work.

Can anyone help me solve this without having to remove dookuís saber from the override folder?
Mister_TSquared is offline   you may: quote & reply,
Old 11-21-2010, 11:48 AM   #2
DarthParametric
I bent my Wookiee
 
DarthParametric's Avatar
 
Join Date: Apr 2004
Location: Oz
Posts: 2,724
10 year veteran! Forum Veteran Helpful! 
Custom crystals require an entry in upcrystals.2da. If you have USM installed you'll need to edit the existing one in the Override folder. There's some more info here - http://www.lucasforums.com/showthread.php?t=143991
DarthParametric is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Knights of the Old Republic > Editing / Modding > Holowan Laboratories > Modder needs help!

Tags
lightsaber, mod help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:02 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.