lfnetwork.com mark read register faq members calendar

Thread: Repairing a friend's old TV, LF electronics experts please
Thread Tools Display Modes
Post a new thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Prev Previous Post   Next Post Next
Old 06-18-2012, 02:38 AM   #1
Darth Avlectus
Your point?
 
Darth Avlectus's Avatar
 
Join Date: Dec 2006
Location: Attack on Titan
Posts: 4,255
Current Game: Soul Calibur 5
Repairing a friend's old TV, LF electronics experts please

I wonder how many others here are electronics specilaists be it hobbyists, techs/repair workers, or even full fledged engineers.

Here goes nothing. I think I might bounce it off of anyone here who might know. I'm inquiring elsewhere but I am getting as many opinions everywhere as I can.

Currently I'm back and forth on repairing an old big screen projection TV. It's a Pioneer rear projection manufactured Sept. 1994. Its power supply does fire but the picture is not going.

I've been going through Sam's repair faq. So I have some ideas what could be wrong.

Behavior: Upon inspection I find that powering up the device the high frequency hum lasts for initial ignition period but after discharge the power supply board is silent. This would seem to point to a safety cutoff preventing it from operating.

Here is what I have found:

-Fuses not blown.
-DUSTY (probably its most obvious problem)
-CRTs (being rear projection it has 3 CRTs each with a lens fixture) not receiving power at all
-CRT rear board socket connections are fine and solder job was neat at manufacture

From findings it is safe to deduce critical failure of main power handling components in the horizontal deflection circuit is not causing the problem. Components being Horizontal Output Transistor, associated snubber compnents, flyback transformer.

A CRT, even dead, would still have glowing internal filaments if it were receiving power wouldn't it?
If CRTs are not receiving power and typical problems are eliminated by deduction, then the next logical thing would be that it is not receiving power from the main board of the power supply. Why not?

I looked at the power splitter block fed by the flyback feeding the CRTs, and although it is showing signs of age it should probably work shouldn't it? Wouldn't a failure of this item cause the fuse to blow as well?

The best I can tell if it is not a short from all that dust, it may be X-ray overexposure shutdown. That's one possible safety cutoff. Which would possibly point to a faulty line voltage regulator and its associated components.

Could a chopper transistor also fail without causing the main horizontal deflection components to fail?

Again, I'm just trying to get opinions from others' similar expertise.


Just so you know, I do not own an oscilloscope, and my only candidates for an isolation transformer/lightbulb ballast test fixture are off in storage right now. I'm using my extech 'true RMS' DVM.

I have not taken the circuit out of the TV yet. I'm trying to avoid this and am trying to avoid desoldering components like semiconductors just to test them.


"I cant see S***! --YOU GO TO HELL!" --Tourettes guy
Darth Avlectus is offline   you may: quote & reply,
Post a new thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Community Discussion > General LFNetwork Forums > General Tech Discussion > Repairing a friend's old TV, LF electronics experts please

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:40 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.