lfnetwork.com mark read register faq members calendar

Thread: Linux Server howto
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 04-11-2002, 01:49 PM   #41
Wintrmte
 
Wintrmte's Avatar
 
Join Date: Mar 2002
Posts: 57
Quote:
Originally posted by KandyFLip
OK.. I was looking here for help with the "Sys_Error: Couldn't load mpdefault.cfg" error... but didn't see a solution... then I found the solution. So, for anyone else's reference:

If I try to start jk2 from some other directory (like my home dir) I get that error. But, if I cd to the game dir first it starts up just fine. Hope that helps some peeps.

OK... now for my other problem: How might I start my server running in the background in such a way that I can then log out and it'll still be running?
My server is hidden in some deep dark corner and has no keyboard or monitor, so all I use is telnet. I've tried ending the command with '&' but still, if I log out of telnet, it takes the server down with it.

Any help? please? pretty please? pretty pretty please with Kandy on top?

Oh yeah, if it matters much:
Celeron 733
160 MB RAM (shush!)
SuSe 7.3 on the 2.2.19 kernel (UT webadmin didn't like 2.4 kernel)
T1

Thanks in advance for any help
Use screen. It is a fantastic utility that will let you reattach to the server session and is more friendly than using &

For example, all you have to do to start the server inside screen is:

screen -S jedi ./jk2ded <your server arguments>

The screen will blank, and the server starts up. At this point:

press ctrl+a, then press the d key by it's self. You should see a line that says

[Screen detached]

The server is still running though. You can logout safely at this point.

Now, to get back into your running server, all you have to do is log into your box as the user who is running the jk2ded process (that you screen'd)

and type:

screen -r jedi

You should now be in your server. Do the same (ctrl+a, then d) to get back out.

Hope this helps.
Wintrmte is offline   you may: quote & reply,
Old 04-11-2002, 01:53 PM   #42
rivmin
 
Join Date: Apr 2002
Location: Denmark
Posts: 85
A small screen tutorial:
http://www.gameadmins.com/guides/linux/linuxscreens.htm
rivmin is offline   you may: quote & reply,
Old 04-11-2002, 03:58 PM   #43
KandyFLip
 
Join Date: Mar 2002
Posts: 40
groovy. thanks a lot. KandyLand is now up and running

now if only they'd fix the forcedisable flag....
KandyFLip is offline   you may: quote & reply,
Old 04-11-2002, 04:13 PM   #44
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
Quote:
Originally posted by Wintrmte
press ctrl+a, then press the d key by it's self
You can hold down cntl the whole time, hit a then d and it'll still work.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 04-11-2002, 09:19 PM   #45
neutrino
 
Join Date: Apr 2002
Posts: 2
Anyone try to have multiple servers on one box? I'm going to attempt to run 5 on a p4 2.2 with 1 gig of ram. They are all ladder duel servers so there will only be 2 people per server...

Think it's possible? also could I screen all five servers? Would this be easier on a windows box?
neutrino is offline   you may: quote & reply,
Old 04-11-2002, 10:44 PM   #46
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
Personally, I don't think it would be easier on a win box....but I'm a linux admin. I have 2 servers running on a tbird 900 with 512mb of ram without any problem. One server is 20 max the other is 24 max. I would think that 5, 2 player servers would be cake on a p4 2.2/1gig. Yes, I would screen them all and have them all setup to auto-restart (script). I'd title all the screens too...but I'm just anal about organization.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 04-11-2002, 10:55 PM   #47
Ogmios
 
Join Date: Apr 2002
Posts: 5
Running in background

KandyFLip,

I used nohup '<sever command>' &. Then when I hit enter it would stop the process so I did bg <job number>, you can type 'jobs' at the command line and it will show you the job number, most likely it will be 1. Note that the sever commands are in single quotes.

Hope this helps.

Ogmios
Ogmios is offline   you may: quote & reply,
Old 04-11-2002, 11:00 PM   #48
Ogmios
 
Join Date: Apr 2002
Posts: 5
Screen works just fine too though
Ogmios is offline   you may: quote & reply,
Old 04-13-2002, 07:21 PM   #49
jk2-digger
 
Join Date: Apr 2002
Location: Derby City
Posts: 10
Stay away from Windoze, its da debil! =)

Seriously though I agree with Matrix, it would be much easier and more efficient on a Linux/Unix OS than in Windows. You should have no problems running all of that on a 2Gig-er
jk2-digger is offline   you may: quote & reply,
Old 04-13-2002, 08:54 PM   #50
olgrandad
 
Join Date: Apr 2002
Posts: 3
Alright, I'm about to pull my hair out trying to get this to work correctly. Here's my configuration:
Mandrake 8.2 (Intel)
eth1 - internet interface
eth0 - LAN interface
iptables (MonMotha firewall script)

Now, my problem is that I can't seem to get my server to show up on a master list at all. I am running different services over my external interface and am able to access them via the internet from many locations, so my firewall is working properly (I have poked a hole in my firewall for UDP port 28070). As a matter of a fact, I had a buddy connect, via the internet, to my server by IP address and it was fine, but I wasn't showing on the master list. So, what am I missing? I have used the configuration listed in this post, and a great many others too. Here's my current server.cfg:

// Server Config
set sv_hostname "-:{Naturally Skilled}:-"
set g_motd "STFU Techlogic"
set rconPassword "password"
set g_needpass 1
set g_password "password"
set sv_privatePassword "password"
set sv_privateClients 2

set sv_pure 1
set sv_maxclients 10
set g_inactivity 0
set sv_maxRate 8000
set sv_maxping 200
set g_allowvote 1
set timelimit 20
set capturelimit 40
set g_autoMapCycle 1
set hunkMegs 128
set net_port 28070

map ffa_bespin

And here is my command line:

jk2ded +set dedicated 2 +set net_ip w.x.y.z +exec server.cfg

I thank you all in advance for the help you're going to give
, and as a token of my appreciation, I leave you with this server script I wrote:
Linux JK2 Server Startup Script

Hopefully you will find it useful.

Thanks,
olgrandad
olgrandad is offline   you may: quote & reply,
Old 04-13-2002, 10:10 PM   #51
olgrandad
 
Join Date: Apr 2002
Posts: 3
Doh! Guess I should do a little reading before I ask questions. Turns out that it doesn't report to the master server if the port number is 28070, so I bumped it to 28080 and it showed up! Now, I couldn't get the seta net_port to work from my server.cfg so I set an optional parameter for my script that will allow you to specify the port of your desire, else it will default to 28070.

I'm not much on versioning, but this one will be version 1.0.1 (.1 for the -p option)

I know I didn't give you all much time to reply, but thanks anway. Oh, if you're interested in future version of this script or have a wish list, please send me an email to the address listed when you specify -h or --help.

Thanks again,
olgrandad
olgrandad is offline   you may: quote & reply,
Old 04-13-2002, 11:12 PM   #52
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
If you look, most of the servers on the master list are on 28070. Now, there may have been a particular issue with your setup, but using port 28070 (default) by itself doesn't cause the master list problem. Does the in-game master list include servers that are passworded? I haven't taken the time to look. If that's true, then that could be part of your problem. Did you remove the password prior to changing the port by chance?

Regarding the script, there's no option for a listen server (+set dedicated 0). It doesn't take into account that someone might be running more than one screen window. It also doesn't provide for auto-restart in the event of a crash. I'm sure all those features can be added. I guess I'm just too direct, because using a script of that size to startup my server when I can just use a command line inside an auto-restart script that's 5 lines long (includes logging) seems like a waste. But, it's whatever works for you.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 04-14-2002, 01:36 AM   #53
olgrandad
 
Join Date: Apr 2002
Posts: 3
Yeah, I've been self-learning BASH scripting, for my job, and went a little haywire. But it does the trick and maybe it'll help someone out.

My password is set and it still shows up on the list and I'm positive I have nothing else running on port 28070. I even opened up a wider range of ports on my firewall to see if there were other communications trying to take place, to no avail. After switching the port, all was well, go figure.

In general I have no need for large scripts, I'm more of a minimalist. For that matter, screen is kind of a waste as well, when a nohup and an & would do just as nicely.

Anyhow, good chattin with you.

olgrandad
olgrandad is offline   you may: quote & reply,
Old 04-14-2002, 08:11 PM   #54
neutrino
 
Join Date: Apr 2002
Posts: 2
Server Crashes...

So I have my duel server up now on FreeBSD (quite a learning experience having rarely used linux... but I did it in only a coupel hours, nice OS) Now the game server is crashing at the rate of ~1x per day. This is just not acceptable because I do not have access to this server when I leave work. It's become a real pain in the ass.

Is there a setting on screen or the executable that once the game server crashes it will automatically restart?
neutrino is offline   you may: quote & reply,
Old 04-16-2002, 06:34 PM   #55
[KWA]SaVAgE
 
Join Date: Apr 2002
Posts: 8
Just a note, I've been running linux servers since Quake2, newest builds of screen are almost the same as original.

The easiest way is create the screen FIRST.

screen -R jk (jk is now the name of the screen you can resume and moniter realtime)

This creates a screen session named jk the capitol R is to FORCE it to make not just resume an existing screen.

You have the ability to go back and forth between prompt and the real time feed from your server. In the realtime screen you can issue commands and run it as if from the win32 console.

screen -r jk

NOTE: if you simply do a screen -R it only makes one screen and this is fine if your going to only run on e screen session (i have three sesions jk cs aq)

Also it's the same ctrl a d to detach.

Hope this is also helpfull :





Quote:
Originally posted by Wintrmte


Use screen. It is a fantastic utility that will let you reattach to the server session and is more friendly than using &

For example, all you have to do to start the server inside screen is:

screen -S jedi ./jk2ded <your server arguments>

The screen will blank, and the server starts up. At this point:

press ctrl+a, then press the d key by it's self. You should see a line that says

[Screen detached]

The server is still running though. You can logout safely at this point.

Now, to get back into your running server, all you have to do is log into your box as the user who is running the jk2ded process (that you screen'd)

and type:

screen -r jedi

You should now be in your server. Do the same (ctrl+a, then d) to get back out.

Hope this helps.
[KWA]SaVAgE is offline   you may: quote & reply,
Old 04-20-2002, 09:32 AM   #56
Mastiphal
 
Mastiphal's Avatar
 
Join Date: Apr 2002
Posts: 2
The only problem I see with screen, is that it won't automatically restart the server if it crashes.

I dont know how big a problem this is, but i have seen my server crash from time to time, and therefore I would like it to start automatically again.

So I made a script /usr/bin/jediknight2
which has this line of code:

while true; do cd /usr/local/games/jk2/; ./jk2ded +exec server.cfg > /dev/null 2>&1; sleep 1; done &

And then I just start it by typing "jediknight2" as user jk

Since I cant attach to the server console as one can with screen, does anyone know of a console-program for jk2ded ?
Kinda like "halfd" for Half-Life based servers..
Mastiphal is offline   you may: quote & reply,
Old 04-22-2002, 04:10 PM   #57
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
I run my servers inside of screen AND have auto-restart ability. My scripts look like so:

--startjk2--
#!/bin/csh
echo -n "Starting - "
date "+%D %H:%M:%S"
cd /usr/local/games/jk2
screen -d -m ./holdjk2


--holdjk2--
#!/bin/csh
echo Ok
while 1
date "+%D %H:%M:%S" >> /tmp/jk2_start.log
echo "JK2 Server Started." >> /tmp/jk2_start.log
sh startup.sh
date "+%D %H:%M:%S" >> /tmp/jk2_start.log
echo "JK2 Server crashed, Restarting." >> /tmp/jk2_start.log
sleep 5
end

My startup.sh is a standard command line startup. This setup not only uses screen and provides auto-restart, but it also generates a log letting me know how often and when my server has crashed.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 05-09-2002, 05:01 PM   #58
sab
 
Join Date: May 2002
Posts: 1
Ok I am running Mandrake 8.2,
I had the server running all fine and dandy, then I installed the new Binary 103, now when I start the server I get this,
When it gets to doing the InitGame I get a dump and the error: Segmentation fault.
It started doing this when I put on the new binary, any ideas?
I would like to stay with the current version, IT ran good on 102 just a few bugs.
sab is offline   you may: quote & reply,
Old 05-09-2002, 05:29 PM   #59
Jedi_Jack
 
Jedi_Jack's Avatar
 
Join Date: Apr 2002
Location: Central California
Posts: 23
Quote:
Originally posted by sab
Ok I am running Mandrake 8.2,
I had the server running all fine and dandy, then I installed the new Binary 103, now when I start the server I get this,
When it gets to doing the InitGame I get a dump and the error: Segmentation fault.
It started doing this when I put on the new binary, any ideas?
I would like to stay with the current version, IT ran good on 102 just a few bugs.
saw this problem addressed in another thread, but don't remember the answer. seems the new patch doesn't work in linux servers. ours had the same problem, so we set it back to v 1.02c until there's a patch for the patch


"Um, there are parts of the Jedi Code I don't buy into, and these robes chafe."<BR><BR>
<a href="http://www.roman.clanservers.net" target="_blank">
<img src="http://www.roman.clanservers.net/roman_saber_2.jpg" border="0">
</a>
Jedi_Jack is offline   you may: quote & reply,
Old 05-10-2002, 02:04 AM   #60
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
Most of the time, what is causing the problem is that the 1.03 client patch includes a new .pk3 file--assets2.pk3. You need to patch your client and upload a copy of that file into your server base dir. Without that extra file, you'll get a seg fault every time.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 05-17-2002, 01:52 PM   #61
skeep
 
Join Date: May 2002
Location: in a crystal tower
Posts: 10
MatrixCPA

Can you post your startup script "startup.sh" or re-link. Link was bad.

I just wanted to see it. I am running Linux Ded Server 1.03 seems to be working fine but very interested in the server restartability.

Also can anyone tell me how to add a bot once the server is started... i have 4 but if I get lonley ????

-skeeeeeeeeeeep


-skeep
mmm yeah this is my sig!

Last edited by skeep; 05-20-2002 at 04:19 PM.
skeep is offline   you may: quote & reply,
Old 05-23-2002, 03:05 AM   #62
willum
 
Join Date: May 2002
Posts: 13
I have a script I use which is pretty simple. I run this script from the user willum. i call it restart.sh
--------------------------------------------------------------------
#!/bin/bash
willumpid() {
/usr/sbin/lsof -i UDP:$1 -F '' | cut -f 1-
}
pid=`willumpid 27960`
if [ -z "$pid" ];
then
/home/willum/server.sh
fi

--------------------------------------------------------------------
if the server is down it executes my startup script server.sh
------------------------------------------------------------------------
#!/bin/sh

echo Starting up JK2 dedicated server: CTF

cd /home/willum/jk2

screen -A -m -d -S JK2 ./jk2ded +set com_hunkmegs 128 +set dedicated 2 +set sv_pure 1 +sets gamestartup \"`date
+"%m-%d-%y %T"`\" +set ttycon 0 +set net_ip 207.19.97.119 +set net_port 27960 +exec jk2ctf.cfg &
--------------------------------------------------------------------------------
then i have crontab check every 5 mins if the port is open
------------------------------------------------------------------------
*/5 * * * * /home/willum/restart.sh

-----------------------------------------------------------------
hope this helps!


willum is offline   you may: quote & reply,
Old 05-24-2002, 02:29 AM   #63
Farslayer
 
Farslayer's Avatar
 
Join Date: May 2002
Posts: 3
Thanks for all the pointers

WOW this thread has been a lot of help.. I actually got my linux server up before I located this forum, but now my configs are tweaked a bit better, and that screens command was exactly what I was looking for last night..

well as for the question I had when I came here, I just figured it out.. couldn't get autodownload working it was because I had the config wrong..

seta cl_allowdownload 1
instead of the correct command
seta sv_allowdownload 1

and farther up the thread someone mentioned server specs .... heres mine

PIII 800
256 MB RDRAM
20 GB HD
RedHat 7.3
eth0 Internet
4 - T1's (6MB Internet connection)

and heres the config I'm running, it might help someone else out... if anyone see's anything in my config that I should change or might improve performance (or options that don't work for jk2) please let me know.. but it's up and running fine at the moment

//////////////////////////
// Server Information //
//////////////////////////

seta g_motd "Welcome to Farslayers Nightmare"
seta sv_hostname "Farslayers-linux v1.03"
set Administrator "Farslayer"
set Email ""
set url ""
set Location "USA"

//////////////////////////
// Server Configuration //
//////////////////////////

seta g_needpass "0"
seta sv_privatePassword "********"
seta rconpassword "********"
seta sv_maxclients "32"
seta sv_minclients "0"
seta sv_privateClients "1"
seta sv_maxRate "10000"
seta sv_maxping "500"
seta g_ghostRespawn "0"
seta g_forcerespawn "1"
seta g_inactivity "0"
seta g_warmup "0"
seta sv_pure "1"
seta sv_master5 ""
seta sv_master4 ""
seta sv_master3 ""
seta sv_master2 ""
seta sv_master1 "masterjk2.ravensoft.com"
seta g_allowvote "1"
seta sv_allowDownload "1"
seta g_friendlyfire "0"
seta g_teamForceBalance "1"
seta g_teamAutoJoin "1"
seta sv_floodProtect "1"
seta g_duelWeaponDisable "0"
seta g_privateDuel "0"
seta g_friendlySaber "1"

//seta g_gravity 800

//////////////////////////
// Game Settings //
//////////////////////////
seta fraglimit "0"
seta timelimit "20"
seta capturelimit "5"


//////////////////////////
// MODE Settings //
//////////////////////////
//
// Set one line for gametype and one for PMOD
//
//Normal CTF is gametype 7

seta g_gametype 7


// Map Stuff


// Maps for Normal CTF

set d1 "map ctf_spaceport ; set nextmap vstr d2"
set d2 "map ctf_imperial ; set nextmap vstr d3"
set d3 "map ctf_ns_streets ; set nextmap vstr d4"
set d4 "map ctf_Yavin ; set nextmap vstr d5"
set d5 "map EchoBaseCTF ; set nextmap vstr d6"
set d6 "map ctf_destroyer ; set nextmap vstr d7"
set d7 "map ctf-massassi ; set nextmap vstr d8"
set d8 "map ctf_bespin ; set nextmap vstr d9"
set d9 "map ctf_tanzin ; set nextmap vstr d1"
vstr d1

--------------------------------------------------------------------------------

I'm relatively new to linux, this is my first attempt at hosting a linux game server, I must say it's not too bad after you start to locate all the information you need. Probably would have helped if I had hosted a Quake server in the past as well no matter what the platform...

Thx again.

Far...out

Last edited by Farslayer; 05-24-2002 at 10:46 PM.
Farslayer is offline   you may: quote & reply,
Old 05-24-2002, 04:05 PM   #64
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
Ok, here's my comments on the config. I've seen a bunch of variations of that one and they all have the same things wrong:

Administrator, Email, URL, Connection, Location should all use sets and not seta.

I don't believe sv_autoDownload is a valid cvar.

You have g_autoMapCycle on, but use a custom rotation. I'd recommend turning it off.

Any cvar that starts with cl_, cg_, ui_, r_, or s_ can be ignored for a dedicated server as they don't make any difference. There are a few in your config.

Otherwise, it's hard to knock it if it's working. I only make the comments about the client-side cvars because people keep including them needlessly after looking at posted configs that contain them.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 05-24-2002, 10:44 PM   #65
Farslayer
 
Farslayer's Avatar
 
Join Date: May 2002
Posts: 3
I appreciate the feedback, Like you guessed I pulled the config from around here and modified it, I don't really understand the whole thing yet. but your pointers should help me clean it up a bit and trim it down. Config is Updated, I'll just edit the last post and replace it there for further pointers.. seems not too many people play CTF though since the server has been pretty much empty for the last 2 days.. 4-T1's sitting Idle.. 6Mb of bandwidth and no players, how depressing is that ?

Far...out


Far... out
Farslayer is offline   you may: quote & reply,
Old 05-25-2002, 05:29 PM   #66
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
My CTF Saber-Only server is full nearly 24/7.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 05-26-2002, 04:22 PM   #67
skeep
 
Join Date: May 2002
Location: in a crystal tower
Posts: 10
yeah my CTF server had crashed last night and when i restarted this morning with in 3 minutes I had players and within the hour I had 20+

Whats wierd is I personally cant see the server the master-list. but from the traffic it seems other people can.

oh and there are some CTF maps that I downloaded that im sure people dont have. Is there a way to get people to download if they dont have them since you say "I don't believe sv_autoDownload is a valid cvar. " ???


-skeep


-skeep
mmm yeah this is my sig!

Last edited by skeep; 05-26-2002 at 04:36 PM.
skeep is offline   you may: quote & reply,
Old 05-27-2002, 04:13 AM   #68
Farslayer
 
Farslayer's Avatar
 
Join Date: May 2002
Posts: 3
map Download

seta sv_allowDownload "1"

is the correct option to turn on Map downloading on the server.. I have tested it and it works

Finally figured it out by going to the server list and viewing options it has the valid ones listed. and it listed allowDownload instead of autodownload I tried it, and it works.

Far..out


Far... out
Farslayer is offline   you may: quote & reply,
Old 05-27-2002, 05:29 AM   #69
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
Just remember that for the download to occur, both the server and the client need to have downloads enabled. There is no way to "force" a client to accept a download. By default, the client-side download feature is off.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 05-28-2002, 03:13 AM   #70
skeep
 
Join Date: May 2002
Location: in a crystal tower
Posts: 10
okay now next question is how bad do downloads tax the server? I also host UT servers and I know that it pretty much kills it unless you redirect to a different box. In other words should i leave it off? I have a 25 player max set and the network lights are solid when the server is full.

-skeep


-skeep
mmm yeah this is my sig!
skeep is offline   you may: quote & reply,
Old 05-28-2002, 05:12 AM   #71
rcol
 
rcol's Avatar
 
Join Date: May 2002
Posts: 4
Saber-Only problem

Thanks in advance for you help;

I've set up and run my jk2 server without a hitch...except one.

I'm attempting a Duel/lightsaber-only server, but it always loads up with all the weapons. I've put in the line:

seta g_weaponDisable "65531"

but it still screws up and loads all the weapons/allows them all.

It even says "saber only" when you attempt to connect, but...it just says it.

If anyone could help me out, it'd be much appreciated.
rcol is offline   you may: quote & reply,
Old 05-28-2002, 03:33 PM   #72
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
It's helpful, since the search feature is disabled, if you post questions in their own thread with a suitable title so that others with the same question can more readily find it. I'll answer your questions here out of the kindness of my heart.

Quote:
okay now next question is how bad do downloads tax the server? I also host UT servers and I know that it pretty much kills it unless you redirect to a different box. In other words should i leave it off? I have a 25 player max set and the network lights are solid when the server is full.
Well, unlike UT, a JK2 server cannot redirect downloads. However, downloads don't tax the server because the download speed is limited to the sv_maxrate. So, the player downloading a map uses no more bandwidth than a player who is playing. The downside is that it can take FOREVER to download a map this way--especially if the server has a maxrate around 5000-6000. Remember that a maxrate of 5000 is designed to accomodate a 56k user.

Quote:
I'm attempting a Duel/lightsaber-only server, but it always loads up with all the weapons. I've put in the line:

seta g_weaponDisable "65531"

but it still screws up and loads all the weapons/allows them all.

It even says "saber only" when you attempt to connect, but...it just says it.
You need to also use the following in your config:

seta g_duelWeaponDisable "65531"

There's 2 cvars for disabling weapons, one for duels and one for all other times.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 05-31-2002, 05:49 PM   #73
SenseiHitokiri
 
Join Date: May 2002
Posts: 2
Assets2.pk3?

In the 103a zip it says that you need Assets2.pk3 from the 103 patch... where is that? I'm not sure if that's the problem... but I keep getting seg faults when running the game... I'm new to linux... actually just started using it for this ... but it gets all the way to loading the is :
g_weaponDisable\0\g_redteam\Empire\g_blueteam\Rebe llion
then it seg faults.

I also just noticed that it cant exec autoexec.cfg

Last edited by SenseiHitokiri; 05-31-2002 at 06:09 PM.
SenseiHitokiri is offline   you may: quote & reply,
Old 05-31-2002, 06:58 PM   #74
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
The autoexec.cfg isn't necessary and you can ignore the error. If you really want to get rid of it, just create an empty file with that name and put it in the base directory. Now, as far as the assets2.pk3 file, you need to copy that from a 1.03 patched client. It will be in the gamedata/base directory.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 05-31-2002, 09:47 PM   #75
SenseiHitokiri
 
Join Date: May 2002
Posts: 2
Good

Got it to works, thanks... for some reason I was missing assets2.pk3... dunno where it went... I got it off someone and now the server runs.

And now I have another problem

It is said the default loads internet play... but for some reason mine doesn't... what's the command for running it in internet mode?

Ok well I found out that it does work on the internet it's just that when people attempt to join it stops at awaiting connection... any idea?

Last edited by SenseiHitokiri; 05-31-2002 at 10:39 PM.
SenseiHitokiri is offline   you may: quote & reply,
Old 06-02-2002, 04:55 AM   #76
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
What do you see server-side when they connect? Are you behind a firewall/router?


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 06-04-2002, 03:18 AM   #77
Sn1PeR
 
Sn1PeR's Avatar
 
Join Date: May 2002
Posts: 26
Is there a way for the server to get the pk3 files off of the cd, instead of having to copy them all into the base folder, I dont have enuf hd space on the box Gunna have to take the thing apart and put a new drive in next week I guess....
Sn1PeR is offline   you may: quote & reply,
Old 06-04-2002, 05:35 AM   #78
MatrixCPA
Senior Member
 
Join Date: Apr 2002
Location: Southern California
Posts: 1,199
That's what I'd recommend. Even though it might be possible to run them off the cd with symlinks, it'd be slow as molasses in Canada in January.


"Do you expect me to talk?"

"No, Mr. Bond, I expect you to DIE."
MatrixCPA is offline   you may: quote & reply,
Old 06-10-2002, 04:36 AM   #79
DarthSeldon
 
DarthSeldon's Avatar
 
Join Date: Jun 2002
Posts: 1
Error

I see the server listed fine but when I go to start the client it gives me this error:

Error: User interface is version 6, expected 7

Any ideas?

06/11/02

I had the wrong version of pk* files.

Last edited by DarthSeldon; 06-11-2002 at 09:22 PM.
DarthSeldon is offline   you may: quote & reply,
Old 06-14-2002, 04:54 AM   #80
Reefn Koff
 
Reefn Koff's Avatar
 
Join Date: May 2002
Posts: 3
I want to make an unpure server for skin purpouses so would the comand be set sv_pure 0 ?
Reefn Koff is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Help Center > Technical Help > Linux Server howto

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:05 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.