lfnetwork.com mark read register faq members calendar
View Poll Results: Did this Thread Help you with your Video Card problem?
Yes, Thank You. 13 36.11%
No, It did not help me. 23 63.89%
Voters: 36. You may not vote on this poll


Thread: ** OPENGL / VIDEO CARD PROBLEMS, LOOK HERE!**
Thread Tools Display Modes
Post a new thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Prev Previous Post   Next Post Next
Old 10-30-2002, 01:04 AM   #1
Andy867
McCan Caoma
 
Andy867's Avatar
 
Join Date: Apr 2002
Location: The Shire
Posts: 3,236
**OPENGL / VIDEO CARD PROBLEMS, LOOK HERE!**

Ok, I figured I'd make a sticky of this because a lot of people get this error, and instead of 100 individual posts about the same error being made, why not just one post that explains the fix. What I am talking about is if you go to load up Jedi Outcast after installation, whether its from a new format of the hard drive, or just for the first time, and you are all excited and you get this error:
Quote:

JK2: v1.0x win-x86 Mar 4 2002
Initialising zone memory .....
----- FS_Startup -----
Current search path:
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets1.pk3 (8011 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets0.pk3 (6674 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData/base

----------------------
14685 files in pk3 files
execing default.cfg
couldn't exec autoexec.cfg
...detecting CPU, found AMD w/ 3DNow!

------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.
------------------------------------

------- Force Feedback Initialization -------
...inhibited, not initializing

----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Working directory: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using desktop display depth of 16
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem



You begin to freak out because you are unsure of what this means, so you come here to the Lucasforums, and the answer to this dilemma is that you need updated drivers that have support for OpenGL.

Here are some of the more popular video card manufacturer websites which have drivers that support OpenGL:
http://www.nvidia.com For those with GeForce, Ti, MX, and other cards (the recommended download is version 30.18 i believe, but I personally go with the Detonation Drivers, which are pretty stable, and you can access them under Download Drivers-> Download drivers-> Graphics and Drivers- > Detonator 40-> [Choose OS]


http://www.ati.com For Those with Radeon cards.


So, hopefully, this will solve the basic OpenGL subsystem errors.


Shut yo face before I punch you in the mouth, break your teeth and call you Snaggle-tooth.
Andy867 is offline   you may: quote & reply,
Post a new thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Help Center > Technical Help > ** OPENGL / VIDEO CARD PROBLEMS, LOOK HERE!**

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:42 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.