lfnetwork.com mark read register faq members calendar

Thread: Clients crash at Awaiting Gamestate (1.01 patch)
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 11-16-2003, 02:23 PM   #1
redstar
 
Join Date: Jul 2002
Posts: 10
Clients crash at Awaiting Gamestate (1.01 patch)

I upgraded my Linux server with the new patch, but now when any of the clients want to join a game their MP crashes... rolling back to the previous version works fine.... I've seen this problem on one other server so it's not just me.....

anyone else seen something similar?
redstar is offline   you may: quote & reply,
Old 11-16-2003, 03:43 PM   #2
Bilbo Skywalker
 
Bilbo Skywalker's Avatar
 
Join Date: Jun 2002
Location: Mid
Posts: 703
I've never had that problem, post your IP and ill check it.

OE redstar?


For all your current and upcoming Star Wars needs come too...

[size=big]echonetwork[/size]

Check out my CTF guide for JA Here
Bilbo Skywalker is offline   you may: quote & reply,
Old 11-17-2003, 04:54 AM   #3
redstar
 
Join Date: Jul 2002
Posts: 10
yes...well we're running the old server version.... but I may get our host to change it....

our server is at
66.98.178.12:25000

a server I found that has the same problem as us is at:
65.38.207.51:29070
redstar is offline   you may: quote & reply,
Old 11-17-2003, 06:07 AM   #4
Amidala from Chop Shop
Politically-correct jerk
 
Join Date: Mar 2003
Location: In exile
Posts: 1,433
Updating a server so a patched (1.01) client can connect is a two step process:

1. First the patch (1.01) must be installed
2. Second the server must be updated to the latest (1.0.1.1) dedicated server

If neither of these steps are done, unpatched clients (1.00) can still connect but patched (1.01) clients can't connect. If both steps are completed, patched clients can connect but unpatched clients can't. If only one of the steps is performed (patch but no update), I suspect neither client can connect (haven't tested it because I followed the update instructions in the readme and did both steps).

Amidala from Chop Shop is offline   you may: quote & reply,
Old 11-19-2003, 11:51 AM   #5
redstar
 
Join Date: Jul 2002
Posts: 10
this isn't just a matter of connection.... the problem is that the client crashes when connecting to a certain server.... both the client and server are running protocol 26 (i.e. the patched versions)...

try connecting to the second server in my thread and see what happens...
redstar is offline   you may: quote & reply,
Old 11-19-2003, 02:18 PM   #6
Proto
 
Proto's Avatar
 
Join Date: Jun 2002
Location: Poland
Posts: 116
Yeah, I have the same problem (stated here). Unfortunatelly persons responsible for running our clan server haven't come up with any sollution so far :/.


Proto is offline   you may: quote & reply,
Old 11-20-2003, 04:34 PM   #7
redstar
 
Join Date: Jul 2002
Posts: 10
crappy....

if you find the solution post it here or mail me at ratm3ever@hotmail.com....

I'll do the same if I get it working...
redstar is offline   you may: quote & reply,
Old 11-21-2003, 11:35 AM   #8
Karrde
Lurker
 
Join Date: Sep 2003
Posts: 2
The solution is pretty simple
Clients local .cfg files created by the old ver. of the server are the problem. Delete them, and it should be OK. At least in our situation everything is OK now.

--EDIT
Oh, sorry, not only .cfg, but .dll's too. Just delete the whole directory that server create's in your GameData
Karrde is offline   you may: quote & reply,
Old 11-25-2003, 12:57 PM   #9
redstar
 
Join Date: Jul 2002
Posts: 10
anyway.. I fixed the stupid problem by uploading assets3.pk3 client file that the patch generates to the base directory of the server...... I wonder why the patch didn't do this automatically.....
redstar is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Help Center > Dedicated Server > Clients crash at Awaiting Gamestate (1.01 patch)

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:03 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.