lfnetwork.com mark read register faq members calendar

Thread: hosting multiplayer JA
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 01-18-2004, 05:04 PM   #1
moop
Lurker
 
Join Date: Jan 2004
Posts: 6
hosting multiplayer

I am having some trouble hosting a server. My friend and I want to play a private duel, but we cannot find each other's servers. The search for a player online also does not work. What do you think we are doing wrong? We both have the patch and have no trouble finding and joining other servers. I appeal to your sense of gaming compassion that you offer any assistance that you can. Thank you.
moop is offline   you may: quote & reply,
Old 01-18-2004, 05:25 PM   #2
Amidala from Chop Shop
Politically-correct jerk
 
Join Date: Mar 2003
Location: In exile
Posts: 1,433
1. If you have a router, make sure ports 29060-29062 and 29070-29075 are open\forwarded to your server's computer. Disable software firewalls like ZoneAlarm or configure them to allow your server to access the Internet.

2. Start your server.

3. Find out exactly what your IP address is with www.whatismyip.com

4. Tell your friend the IP address you got from step 3. Have him use "New Favorite" to add the IP address to his Favorites. He can then join your server using the Favorite he created.

Amidala from Chop Shop is offline   you may: quote & reply,
Old 01-18-2004, 08:46 PM   #3
moop
Lurker
 
Join Date: Jan 2004
Posts: 6
Yes I tried to add his IP adress into my favorites and it didnt work. For some reason, our servers just don't seem to be getting out there. Should I run a pure server? Is there some kind of option that would cause this?
moop is offline   you may: quote & reply,
Old 01-18-2004, 09:53 PM   #4
Amidala from Chop Shop
Politically-correct jerk
 
Join Date: Mar 2003
Location: In exile
Posts: 1,433
Non-pure servers are easier to connect to. Read step 1 again. This is most commonly a router\firewall issue.

Amidala from Chop Shop is offline   you may: quote & reply,
Old 01-18-2004, 10:00 PM   #5
BawBag™
Senior Member
 
Join Date: May 2003
Location: Scotland
Posts: 1,706
Or one of you type in "/connect <IP>" (quotes exempt) to immediately connect to one anothers server.
BawBag™ is offline   you may: quote & reply,
Old 01-19-2004, 07:39 PM   #6
moop
Lurker
 
Join Date: Jan 2004
Posts: 6
that is quite handy BawBag, thanks. Where would one type that?
moop is offline   you may: quote & reply,
Old 01-19-2004, 07:40 PM   #7
BawBag™
Senior Member
 
Join Date: May 2003
Location: Scotland
Posts: 1,706
Bring down the console with the shift button and the tilde (left of the 1 key)
Type it in there.
BawBag™ is offline   you may: quote & reply,
Old 01-19-2004, 09:31 PM   #8
moop
Lurker
 
Join Date: Jan 2004
Posts: 6
Thanks for that command, it seems to work. Our new problem is the fact that the connecting screen just keeps counting upwards instead of joining. If anyone can proffer a solution to this new problem you shall live on in an immortal shrine of gratitude. Thank you.
moop is offline   you may: quote & reply,
Old 01-20-2004, 04:46 AM   #9
Andy867
McCan Caoma
 
Andy867's Avatar
 
Join Date: Apr 2002
Location: The Shire
Posts: 3,236
If using a linksys router, make sure to access it (usually 192.168.1.1) and type in admin for the password. Then from there, you will need to go to the advanced screen, and under the filter option, make sure that the option BLOCK WAN REQUEST is DISABLED. Also, make sure to set the forwarding tabs to just 29070 (no sense in having extra ports open since only one is being opened by Academy.) And make sure to set your ip in (use whatismyip.com as suggested by Amidala) and then make sure the connection is set for UDP (NOT TCP) and then under dmz, enter in the last 2-3 digits of your ip and make sure to apply ANY Change made on EACH of the screens once you are done on that page. And that should help get your server up and running IF using a linksys router, although other routers shouldnt be much different.


Shut yo face before I punch you in the mouth, break your teeth and call you Snaggle-tooth.
Andy867 is offline   you may: quote & reply,
Old 01-20-2004, 10:32 AM   #10
BawBag™
Senior Member
 
Join Date: May 2003
Location: Scotland
Posts: 1,706
Quote:
Originally posted by moop
Thanks for that command, it seems to work. Our new problem is the fact that the connecting screen just keeps counting upwards instead of joining. If anyone can proffer a solution to this new problem you shall live on in an immortal shrine of gratitude. Thank you.
Be sure there are no firewalls enabled on either machine, this won't allow a connection, and if a connection eventually does happen, the game will be extremely laggy.
BawBag™ is offline   you may: quote & reply,
Old 01-20-2004, 05:59 PM   #11
Agen
The Spoon Guy
 
Agen's Avatar
 
Join Date: Jul 2001
Location: A house
Posts: 5,216
I disagree, if it's just someone next door or down the road the ping's a dream (20)
Agen is offline   you may: quote & reply,
Old 01-24-2004, 01:04 AM   #12
moop
Lurker
 
Join Date: Jan 2004
Posts: 6
No routers employed by anyone and all firewalls off. Even the built-in one for windows xp. Still cant find each other's servers, while joining public ones works fine. You guys have been great but I think i'm about ready to give up on this one.
moop is offline   you may: quote & reply,
Old 01-26-2004, 04:27 PM   #13
Kurgan
Headhunter
 
Kurgan's Avatar
 
Join Date: Nov 1997
Location: The Dawn of Time
Posts: 18,322
LFN Staff Member 10 year veteran! 
Don't give up yet! I'm transfering this thread to the proper "Dedicated Server" forum where you can read up and probably will find your solution there.

Configure your XP firewall to allow the ports that JA uses (in fact, give it full access if you can) and it should work.

29060-29099 TCP & UDP worked for me.

You said you were both using the 1.01 patch so that's good.

Try having them type in your exact IP to their favorites:

Ie: xxx.xxx.xxx.xxx:29070

(ie: for the x's put in whatever IP your server is using)


Download JK2 maps for JA Server|BOOT CAMP!|Strategic Academy|
(JA Server: 108.178.55.189:29070)


"The Concussion Rifle is the weapon of a Jedi Knight Player, an elegant weapon, from a more civilized community." - Kyle Katarn
Kurgan is offline   you may: quote & reply,
Old 01-27-2004, 09:13 PM   #14
moop
Lurker
 
Join Date: Jan 2004
Posts: 6
we've tried the ip address thing. It's nice of you to be concerned, but we have a solution: join the same empty server
moop is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Help Center > Dedicated Server > hosting multiplayer JA

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:58 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.