lfnetwork.com mark read register faq members calendar

Thread: Trouble with sound
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 05-21-2008, 06:55 PM   #1
HP1000
Lurker
 
Join Date: May 2008
Posts: 1
Trouble with sound

Hi!


This is the first time I try to play Grim Fandango on my own. I've played it with a friend some years back and I just picked it up a few days ago thinking it would be hilarious to relive the old days.

But I have a problem with the sound. It starts fine and all but as soon as I hit F1 to enter the options menu's the sound vanishes and doesn't come back untill I restart the whole game from Windows.

I have of course used the patch but that doesn't seem to do anything for me. I use XP home edition with a regular soundcard for my laptop. Anyone out there who have been in the same kinda trouble and solved the problem?

I have looked forward to playing this for some time and it would be a shame to let it go to waste. (Can't imagine I would play it through without sound or bothering restarting the game all the time)

Thx in advance!
HP1000 is offline   you may: quote & reply,
Old 10-27-2008, 12:26 PM   #2
robearth
Rookie
 
robearth's Avatar
 
Join Date: Oct 2008
Location: sweden
Posts: 70
I have the EXACT same problem with my other computer!
I lose all sound when I hit F1... allthough sometimes the game manages to prevail and I get to keep my sound even though I hit F1 : )

the F1 button in general seems to be a real problemcreator! when I first installed GF on this computer (my regular computer), everytime I hit options in F1menu, the game locked up!
Anyone out here with solutions for us!?
robearth is offline   you may: quote & reply,
Old 12-04-2008, 04:56 PM   #3
mudpie210
Lurker
 
Join Date: Dec 2008
Posts: 4
I also have a similar problem. It's not always when I hit F1, but after playing shortly the game sound cuts off, any help please?
mudpie210 is offline   you may: quote & reply,
Old 01-05-2009, 04:14 PM   #4
AdrielFisher
Lurker
 
Join Date: Jan 2009
Posts: 3
I have this problem too. I suspect it's a sound card issue, but hey ho. As a workaround I've installed a fan-made game launcher which is available from the downloads section of www.grimfandango.net. It doesn't fix the issue, but it does let you load the last saved game instantly, which means you can play the game, and only open the options menu when you need to save and quit. Unfortunately on my machine it won't let me have any conversations with people, but maybe it will work for you. Hope that helps!

Last edited by AdrielFisher; 01-05-2009 at 04:34 PM.
AdrielFisher is offline   you may: quote & reply,
Old 01-05-2009, 04:46 PM   #5
AdrielFisher
Lurker
 
Join Date: Jan 2009
Posts: 3
Quote:
Originally Posted by Circuitous View Post
Okay! Found something that works.

Download this.

Unpack it to C: or somewhere you can find it.

Start -> Run -> "cmd"

Navigate to the directory you put imagecfg in, for example:

cd c:\

When you're in the right directory, type:

imagecfg -a 0x1 "C:\Directory\Where\You\Insalled\GRIMFANDANGO. exe"

It'll output four lines of text, and then you're done. Turn off compatibility for GRIMFANDANGO.exe, and run the game.

Basically it sets the CPU Affinity before the game is running (since changing it in realtime doesn't help, and doesn't stick!), and saves it. It is woot.
Aha, found this solution that helps. Presumably it's a dual-core cpu issue. I had to Google to find the tool though, the link in the quote doesn't work anymore.
AdrielFisher is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Grim Fandango Discussion > General Forums > Glottis' Garage > Trouble with sound

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:21 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.