lfnetwork.com mark read register faq members calendar

Thread: Black Reskin Problem
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 02-07-2009, 01:29 AM   #1
HK-42
HK47+Marvin=
 
HK-42's Avatar
 
Join Date: Jun 2006
Location: The Unknown Regions
Posts: 2,040
Current Game: AssassinsCreed,kotor
Hot Topic Starter 
Black Reskin Problem

Ok Once again having a Module reskin problem. This time im Sure I did everystep. However everything in the module is black- and I can see through part of the floor. This is K1 by the way, in the Taris Hideout. The black is not due to lightmaps I dont think as this module does not have any, or any vis.

I hexedited the mdl's changing LTS to anp and m02af to m98aa.
I renamed all files with original m02af to m98aa(pth, git, mdx, mdl, wok.
I opened the lyt file and changed all the m02af to m98aa.
Opened the module.ifo and changed m02af to m98aa. Did the same with the .are and renamed git file.
Dropped everything in override, and packed the ifo git and are into my .mod.

Any ideas?

EDIT: Hold on, I think I found it, the bifs are not in order so I might have missed a file.

HK-42 is offline   you may: quote & reply,
Old 02-15-2009, 04:23 PM   #2
HK-42
HK47+Marvin=
 
HK-42's Avatar
 
Join Date: Jun 2006
Location: The Unknown Regions
Posts: 2,040
Current Game: AssassinsCreed,kotor
Hot Topic Starter 
Revive!

Once again having this problem. I edited the lightmaps, vis, git, are, ifo, mdl, mdx, pth, textures, lyts, txi, wok, everything. But black again! What is the problem?

EDIT: I was able to fix a bit of it, but now another problem. I can now walk in the module and see. But the module is completly white. I checked the mdls and they all have anb_texutre name. And the anb textures are in the override. Help?

EDIT2: redid everything. Got the skins working! But now the module is transparent? You can see through some walls.

HK-42 is offline   you may: quote & reply,
Old 02-15-2009, 04:24 PM   #3
Canderis
Mercenary
 
Canderis's Avatar
 
Join Date: Jun 2008
Location: Unknown
Posts: 2,513
Current Game: Skyrim
Veteran Modder Helpful! 
Make sure there is no visible alpha channel in any of the textures.




Canderis is offline   you may: quote & reply,
Old 02-15-2009, 04:26 PM   #4
TriggerGod
Senior Member
 
TriggerGod's Avatar
 
Join Date: Mar 2008
Location: hiding
Posts: 2,415
Helpful! 
Quote:
Originally Posted by HK-42 View Post
EDIT2: redid everything. Got the skins working! But now the module is transparent? You can see through some walls.
Do the texture files that you make have an alpha channel applied to it? If you said yes than make a .txi file. If no, read on
Did the textures you replaced have an alpha channel/shader on it? (you can check this in the image viewer. there is a white box with words in it. If any of those words are coherent and say "CM_Baremetal" or some variation, theres your problem.) If yes, than make the txi file with what the image viewer says (you can do this easily by selecting whats in the white box, and click "save selection as txi" or something like that. remember to change the .txi file to the name of your texture.)
TriggerGod is offline   you may: quote & reply,
Old 02-15-2009, 05:33 PM   #5
HK-42
HK47+Marvin=
 
HK-42's Avatar
 
Join Date: Jun 2006
Location: The Unknown Regions
Posts: 2,040
Current Game: AssassinsCreed,kotor
Hot Topic Starter 
Fixed, I was able to remove the channels. No problems now. Except another revival.....soon.

HK-42 is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Knights of the Old Republic > Editing / Modding > Holowan Laboratories > Black Reskin Problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:06 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.