lfnetwork.com mark read register faq members calendar

Thread: Can't play the game
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 02-10-2009, 11:16 PM   #1
ynoh
Lurker
 
Join Date: Feb 2009
Posts: 5
Can't play the game

I've looked browsed through forums and other sources, and found there to be a lot of problems in starting up the game. I've spent hours and hours trying solutions to no avail.

Im running Windows xp, 2gb ram, 2.66ghz processor, and NVIDIA GeForce 8800 GTS.

While I am able to install the game without any problems, and am able to start the game. The game crashes after the opening scene, or right after I skip the opening scene.

Error message:
"GrimFandango has encountered a problem and needs to close. Sorry for the inconvenience."

Ive tried:
- applying the patch
- copying+pasting cd1+cd2+patch
- Setting affinity via the Windows Task Manager -> processes etc.
- downloading imagecfg and going to DOS and do relevant stuff
- setting compatibility to windows 98.

none of these worked for me

any help would be greatly appreciated.
ynoh is offline   you may: quote & reply,
Old 02-11-2009, 09:55 AM   #2
Manny_Calavera
Lurker
 
Manny_Calavera's Avatar
 
Join Date: Oct 2008
Posts: 4
I'm not sure but when my friend opened the game by pressing F1 at first, try to tamper with graphics settings
Manny_Calavera is offline   you may: quote & reply,
Old 02-11-2009, 05:34 PM   #3
ynoh
Lurker
 
Join Date: Feb 2009
Posts: 5
thats kinda did that trick, though im hit with another problem. The main character has all these lines on him, graphical error i presume.




Tried fidling with nvidia settings to no avail. Ill try fidling more later. Anyone got any other suggestion?
ynoh is offline   you may: quote & reply,
Old 02-13-2009, 12:28 AM   #4
ynoh
Lurker
 
Join Date: Feb 2009
Posts: 5
found the problem, http://www.lucasforums.com/showthrea...79#post2588379
ynoh is offline   you may: quote & reply,
Old 02-17-2009, 11:44 PM   #5
Redhouse
Lurker
 
Join Date: Feb 2009
Posts: 4
I have this problem. It appears only when using the 3d acceleration in fullscreen mode. Trying to use software in fullscreen mode causes the game to crash. Using windowed mode is fine, but ugly.

My system is:
core2 quad 6600
8800GT 1GB
2GB ram
winxp sp2

I just found a fix that allowed me to play fullscreen without this transparancy in the characters.

run dxdiag
goto display tab
disable directdraw acceleration
run application

when done, re-enable directdraw (and direct3d will automatically kick back in)

fyi when I tried this on a backup machine that has a 6600GT/athlon64 3500+ on winxp sp2 there is no issue in fullscreen. I just went through this little battle to see if there was a win. I'm hoping to find an application specific way to disable directdraw like this, that would be the cleanest workaround.
Redhouse is offline   you may: quote & reply,
Old 02-18-2009, 06:07 PM   #6
Longcat
Junior Member
 
Longcat's Avatar
 
Join Date: Sep 2006
Posts: 291
let me get this straight.
it runs with hardware acceleration this way? or only software mode?

screenshot please
Longcat is offline   you may: quote & reply,
Old 02-18-2009, 08:42 PM   #7
Redhouse
Lurker
 
Join Date: Feb 2009
Posts: 4
Quote:
Originally Posted by Jona View Post
let me get this straight.
it runs with hardware acceleration this way? or only software mode?

screenshot please
This runs in software mode, and takes directx out of the loop it seems. It's pretty seamless for me as cpus have advanced much since I bought this game 11-12yrs ago.

I can run fullscreen with hardware acceleration but due to something with either my graphics card, or my drivers there are transparent portions to the active character models all over the place.
Redhouse is offline   you may: quote & reply,
Old 02-19-2009, 01:32 AM   #8
Longcat
Junior Member
 
Longcat's Avatar
 
Join Date: Sep 2006
Posts: 291
Yes, this is because you have a newer Nvidia card. I was hoping for a fix for hardware mode but oh well
Longcat is offline   you may: quote & reply,
Old 02-19-2009, 03:01 AM   #9
ynoh
Lurker
 
Join Date: Feb 2009
Posts: 5
Quote:
Originally Posted by Redhouse View Post
run dxdiag
goto display tab
disable directdraw acceleration
run application
Awesome! This seems to have done the trick!



I haven't played this game before, so im not quite sure how things should look like, but it looks fine.
ynoh is offline   you may: quote & reply,
Old 02-19-2009, 01:56 PM   #10
Sallim
Forumite
 
Sallim's Avatar
 
Join Date: Aug 2003
Location: moenchengladbach /germany/europe
Posts: 664
Quote:
Originally Posted by ynoh View Post
Awesome! This seems to have done the trick!



I haven't played this game before, so im not quite sure how things should look like, but it looks fine.
yep, looks fine to me
have fun ;D


- supreme pleasure -
Sallim is offline   you may: quote & reply,
Old 02-24-2009, 11:07 AM   #11
Kloppstock
Rookie
 
Join Date: Nov 2005
Posts: 83
"Originally Posted by Redhouse
run dxdiag
goto display tab
disable directdraw acceleration
run application"

Hmm, that trick disabled the hardware accelerator i wanted to keep "on" and still have in combination with no graphic corruption somehow, but if i leave the accelerator "on" the charachters completley dissapear from the picture lol, i see some textures in certain angles only

i accually dont have a modern Geforce card,
but i have a modern Radeon EAH4850 TOP, the question is if there is any way to keep hardware accelerator on with clean graphic? beacuse if i sett it to "Off" i instead will have a shadow corruption after the charachter that leaves a black trail that never goes away, so its hell and hell both alternatives

have setted it to win 98 mode, without any difference
Kloppstock is offline   you may: quote & reply,
Old 02-24-2009, 06:12 PM   #12
Longcat
Junior Member
 
Longcat's Avatar
 
Join Date: Sep 2006
Posts: 291
Try setting processor affinity to 1 using imgcfg.exe.

Alternately, download a premodified exe from the Stickys in this forum section.
Longcat is offline   you may: quote & reply,
Old 02-25-2009, 10:15 AM   #13
Governor Phatt
 
Governor Phatt's Avatar
 
Join Date: Aug 2002
Location: Phatt island: Tresspassers not carrying Foodstuffs will be prosecuted
Posts: 145
Unhappy

"Originally Posted by Redhouse
run dxdiag
goto display tab
disable directdraw acceleration
run application"

Well that worked for me, with my widescreen monitor, i can now see Manny, but now when i am playing for more than a couple of minute the grame freezes up and crashes


Disce quasi semper victurus; vive quasi cras moriturus...
Governor Phatt is offline   you may: quote & reply,
Old 03-06-2009, 09:17 AM   #14
Kloppstock
Rookie
 
Join Date: Nov 2005
Posts: 83
Quote:
Originally Posted by Jona View Post
Try setting processor affinity to 1 using imgcfg.exe.

Alternately, download a premodified exe from the Stickys in this forum section.
I dont know where to find this imgcfg.exe ?

http://www.lucasforums.com/showthread.php?t=195709 ?
That didnt change for me unfortentley (i even manually merged goodtime.reg to my reg)


Free Image Hosting by ImageBam.com
without harware or with hardware

lol
Kloppstock is offline   you may: quote & reply,
Old 03-08-2009, 12:09 PM   #15
Longcat
Junior Member
 
Longcat's Avatar
 
Join Date: Sep 2006
Posts: 291
the patch you applied has already been modified with imagecfg.exe.

I'm guessing the problem is not related to GF but to your graphic cards driver.
Longcat is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Grim Fandango Discussion > General Forums > Glottis' Garage > Can't play the game

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:06 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.