lfnetwork.com mark read register faq members calendar

Thread: Driving me crazy - No method can get KOTOR 2 past the character creation..
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 09-18-2009, 04:44 PM   #1
wtfiforgotmysn
Rookie
 
wtfiforgotmysn's Avatar
 
Join Date: Jun 2005
Posts: 11
Unhappy Driving me crazy - No method can get KOTOR 2 past the character creation..

I feel bad posting this in a board littered with solutions and topics related to this. Trust me, I've read them all.

Here's my specs:
[SWKotOR]
ReportDateTime=9/18/2009 3:37:09 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=None
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=1
CPUSpeed=1795
CPUFamily=6
CPUModel=7
CPUStepping=10
CPUVendor=Intel
CPUName=Celeron(R) Dual-Core CPU T3000 @ 1.80GHz
Status=Pass

[Memory]
RAM=2048
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=13.94GB
E: (NTFS), UNICODE=7.71GB
F: (NTFS), UNICODE=1.33GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\,G:\
Drives=TSSTcorp DVD+-RW TS-L633B

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=2048
Desktop Resolution=1366x768x32 @ 60Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=2.1.0 - Build 8.15.10.1872
OpenGL Vendor=Intel
OpenGL Renderer=Mobile Intel(R) 4 Series Express Chipset Family
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers / Headphones (IDT High Definition Audio CODEC)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Disable Sound=0

[Graphics Options]
EnableHardwareMouse=1
FullScreen=0

[Game Options]

[config]
firstrun=0

Things Worth Noting
  • I'm actually running under Windows 7, but I'm running in compatibility mode. I thought that would fix my problem initially.
  • I have the Mobile Intel(R) 4 Series Express Chipset Family integrated chip. I've read the fix for Intel Chipsets, and I've changed my 'flip mode' to 'blit'. This seemed to help everyone that had a problem with Intels.. but not me, unfortunately.
  • Eventually I just got tired with it and assumed it was a Windows issue. So I made a separate partition and installed Windows XP on it, and tried installing and running the game on that partition. Still, nothing.
  • I've tried the 3DAnalyze trick, still nothing.
  • Running under 7 or Vista compatibility mode, I've replaced the infamous troubled .dll file in my root folder with the original KOTOR one. And a separate one claiming to be 'patched'.. not sure if there's a difference.
  • I had JUST FINISHED finishing a playthrough of the original KOTOR.

I don't know what else to do. I feel like I'm out of options here.. I figured I'd post as a last resort.. and well. My last resort is here.

Does anyone have ANY suggestions? I'll give you my firstborn if you can get my game past that character creation intro text crawl screen.
wtfiforgotmysn is offline   you may: quote & reply,
Old 09-18-2009, 08:46 PM   #2
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Have you tried the Dantooine lag fix?
Quote:
Originally Posted by stingerhs View Post
  • First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
  • When you find it, just double-click on the file to open it in Notepad.
  • Scroll down the file until you find the Graphics Options
  • Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini), add "Disable Vertex Buffer Objects=1", without the quotes.
  • Goto File, then Save.
Try this first. Also, do you set CPU affinity to one core when starting the game?


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-18-2009, 09:50 PM   #3
wtfiforgotmysn
Rookie
 
wtfiforgotmysn's Avatar
 
Join Date: Jun 2005
Posts: 11
I've tried both. No luck with either
wtfiforgotmysn is offline   you may: quote & reply,
Old 09-19-2009, 12:31 PM   #4
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Your screen appears to have one of those funky 16:9 resolutions.

PM sent.

It also might help to post the entire report that swconfig spits out.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-19-2009, 04:30 PM   #5
wtfiforgotmysn
Rookie
 
wtfiforgotmysn's Avatar
 
Join Date: Jun 2005
Posts: 11
No luck from his PM .

Still gameless.

I don't understand this at all?
wtfiforgotmysn is offline   you may: quote & reply,
Old 09-19-2009, 06:22 PM   #6
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Are you editing and saving the .ini file with administrator privileges?


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-19-2009, 08:59 PM   #7
wtfiforgotmysn
Rookie
 
wtfiforgotmysn's Avatar
 
Join Date: Jun 2005
Posts: 11
Everything is done with Administrator privileges
wtfiforgotmysn is offline   you may: quote & reply,
Old 09-19-2009, 10:06 PM   #8
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Have you tried turning on v-sync from the in-game menu?


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-20-2009, 05:47 AM   #9
DarthParametric
I bent my Wookiee
 
DarthParametric's Avatar
 
Join Date: Apr 2004
Location: Oz
Posts: 2,724
10 year veteran! Forum Veteran Helpful! 
Just use a save made after character creation and edit it to whatever you want using KSE. Here's one I made for this sort of problem (previous versions of ATI's Catalyst drivers would cause a GPU lockup on my 4850 in the character creation of both games).

http://www.lucasforums.com/showpost....5&postcount=82
DarthParametric is offline   you may: quote & reply,
Old 09-20-2009, 03:55 PM   #10
Dooms
Rookie
 
Dooms's Avatar
 
Join Date: Sep 2009
Posts: 12
I'm in a similar position to the original poster. I can get as far as customizing my character, and then I'll get the opening crawl with the story outlined. But once the game starts up, the screen itself goes blank and then crashes. I have no idea what else to do.

I'm running my game on a MacBook, with a bootcamp Windows XP SP3 Partition.

I'm also using an Integrated Chipset, which seems to be what's causing the problem. Anyway, the actual chipset and other details are:
Quote:
Originally Posted by Dooms' ChipsetDetails

Intel(R) Graphics Media Accelerator Driver for Mobile Report


Report Date: 09/20/2009
Report Time[hr:mm:ss]: 19:45:45
Driver Version: 6.14.10.4833
Operating System: Windows XP* Professional, Service Pack 3, v.5755 (5.1.2600)
Default Language: English
DirectX* Version: 9.0
Physical Memory: 992 MB
Minimum Graphics Memory: 16 MB
Maximum Graphics Memory: 224 MB
Graphics Memory in Use: 10 MB
Processor: x86 family 6 Model 15 Stepping 6
Processor Speed: 1995 MHZ
Vendor ID: 8086
Device ID: 27A2
Device Revision: 03


* Accelerator Information *

Accelerator in Use: Mobile Intel(R) 945 Express Chipset Family
Video BIOS: 1284
Current Graphics Mode: 1280 by 800 True Color (60 Hz)



* Devices Connected to the Graphics Accelerator *


Active Notebook Displays: 1


* Notebook *

Monitor Name: Plug and Play Monitor
Display Type: Digital
Gamma Value: 3.54
DDC2 Protocol: Supported
Maximum Image Size: Horizontal: Not Available
Vertical: Not Available
Monitor Supported Modes:
1280 by 800 (60 Hz)
Display Power Management Support:
Standby Mode: Not Supported
Suspend Mode: Not Supported
Active Off Mode: Supported


* SDVO Encoder Report *

** Encoder 1 **
Vendor ID: Silicon Image
Device ID: 170
Device Revision: 3
Major Version: 1
Minor Version: 1
I also tried this but with no luck:

Quote:
Originally Posted by stingerhs

* First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
* When you find it, just double-click on the file to open it in Notepad.
* Scroll down the file until you find the Graphics Options
* Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini), add "Disable Vertex Buffer Objects=1", without the quotes.
* Goto File, then Save.
This is extremely bothersome, I just re-bought the game after selling it a while ago, and I've completed a whole game of KotOR 1 on this very computer and never had this problem.

Last edited by Dooms; 09-20-2009 at 04:55 PM. Reason: Typo
Dooms is offline   you may: quote & reply,
Old 09-20-2009, 04:22 PM   #11
wtfiforgotmysn
Rookie
 
wtfiforgotmysn's Avatar
 
Join Date: Jun 2005
Posts: 11
Seems like we're in the same situation, Doom.

I just tried with the pre-made Gamesave. Still crashes before loading the Peragus. I feel like I'm out of options here.
wtfiforgotmysn is offline   you may: quote & reply,
Old 09-20-2009, 04:30 PM   #12
Dooms
Rookie
 
Dooms's Avatar
 
Join Date: Sep 2009
Posts: 12
Quote:
Originally Posted by wtfiforgotmysn View Post
Seems like we're in the same situation, Doom.

I just tried with the pre-made Gamesave. Still crashes before loading the Peragus. I feel like I'm out of options here.
I, too have tried the quicksave, same thing happens, the game crashes.
Sucks to be us, then.
I guess the thing that annoys me the most is that KotOR runs perfectly fine, I'm just wondering why 2 doesn't even want to run on this machine.
Anyway, to anyone who can actually help, is there any more information on my set-up that you would need?

I'll also post my ini settings here just incase there's anything there that might need changed:

Quote:
Originally Posted by Dooms KotOR 2 Ini settings
[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
EAX=0
Sound Init=0
Disable Sound=0
Force Software=0

[Graphics Options]
Anisotropy=1
Frame Buffer=0
Grass=0
Soft Shadows=0
Shadows=0
Brightness=57
EnableHardwareMouse=1
FullScreen=0
RefreshRate=60
Width=800
Height=600
V-Sync=1
Texture Quality=0
Anti Aliasing=0
Emitters=1
Disable Vertex Buffer Objects=1

[Game Options]
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
UnlockedPlanetSongs=3
TooltipDelay Sec=1
Disable Movies=0

[config]
firstrun=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action268=52
Action265=58
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=60
Action213=62
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

[Autopause Options]
End Of Combat Round=0
Mine Sighted=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[Movies Shown]
Movie10=0
Movie 9=0
Movie 8=0
Movie 7=0
Movie 6=0
Movie 5=0
Movie 4=0
Movie 3=0
Movie 2=0
Movie 1=0
Movie 0=4
Quote:
Originally Posted by Kotor 2 Version
2.00.420 English

Last edited by Dooms; 09-20-2009 at 04:52 PM. Reason: Left out a minor detail
Dooms is offline   you may: quote & reply,
Old 09-20-2009, 05:00 PM   #13
wtfiforgotmysn
Rookie
 
wtfiforgotmysn's Avatar
 
Join Date: Jun 2005
Posts: 11
Exactly. I'm not super computer savvy (in terms of gaming, I've always tended to be loyal to my consoles).. but as far as I knew, KOTOR 1 and KOTOR 2 ran with the same engine/graphics. I wouldn't have such a hard time accepting defeat if I hadn't just played through the first with absolutely no problem.. mods and all.

I just rechecked to make sure I had the latest Mobile Intel 4 Series Express Chipset Family driver for Windows 7 Ultimate. I also retried emulating T&L with 3DAnalyze. Nothing. If only to make matters worse, I get to hear the bubbling of the healing pod and beeps of the droids before the game completely crashes. I'm supposing that narrows it down to a graphics problem.. but I don't know how else to tweak it.
wtfiforgotmysn is offline   you may: quote & reply,
Old 09-21-2009, 01:16 AM   #14
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
OK. I installed KotOR 2 on my Vista laptop which has an Intel Mobile 965 Express chipset & GPU on it to fiddle around with it and see if I could get it to work. I did so following the instructions laid out in the first two posts in this thread, and I started with updating DirectX. I succeeded in getting it up and running, and here are my findings:

1) That widescreen fix that I PMed you about won't work. Why, I don't know (it's worked on several other computers that I know of, in both XP and Vista), but you'll need to use either the original .exe if you're using XP or the one that's been fixed for Vista by SecuROM (in the Vista fix thread) if you're using Vista. KotOR 2 actually supports 1280x768 natively (NOT 1280x800 like I originally believed). All you'll have to do is set it to that resolution under both "Display Options" and "Graphics Options" in swkotor2.ini. I'd try running it at 800x600 first, then bump it up to 1024x768 from the main menu before trying the 1280x768 .ini hack.

2) The flipping policy in the Intel graphics driver settings does indeed need to be set to "blit". It's done under "3D Options" in the driver settings menu on the more modern drivers.

3) Make sure that Fullscreen=1 under both "Display Options" and "Graphics Options"

4) DON'T run the configuration utility after messing with the settings because chances are it will screw them up (sort of like Baldur's Gate 2)!


I've managed to get it running at 1280x768 with the high texture setting and 2xAF, which is all that the Mobile 965 Express can manage and it ran OK, movies and all. It can become a slide show in certain places (try to avoid smoke) at those settings, but it's still perfectly playable.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker

Last edited by Q; 09-21-2009 at 02:45 AM.
Q is offline   you may: quote & reply,
Old 09-21-2009, 07:09 AM   #15
Dooms
Rookie
 
Dooms's Avatar
 
Join Date: Sep 2009
Posts: 12
Quote:
Originally Posted by Evil Q View Post
OK. I installed KotOR 2 on my Vista laptop which has an Intel Mobile 965 Express chipset & GPU on it to fiddle around with it and see if I could get it to work. I did so following the instructions laid out in the first two posts in this thread, and I started with updating DirectX. I succeeded in getting it up and running, and here are my findings:

1) That widescreen fix that I PMed you about won't work. Why, I don't know (it's worked on several other computers that I know of, in both XP and Vista), but you'll need to use either the original .exe if you're using XP or the one that's been fixed for Vista by SecuROM (in the Vista fix thread) if you're using Vista. KotOR 2 actually supports 1280x768 natively (NOT 1280x800 like I originally believed). All you'll have to do is set it to that resolution under both "Display Options" and "Graphics Options" in swkotor2.ini. I'd try running it at 800x600 first, then bump it up to 1024x768 from the main menu before trying the 1280x768 .ini hack.

2) The flipping policy in the Intel graphics driver settings does indeed need to be set to "blit". It's done under "3D Options" in the driver settings menu on the more modern drivers.

3) Make sure that Fullscreen=1 under both "Display Options" and "Graphics Options"

4) DON'T run the configuration utility after messing with the settings because chances are it will screw them up (sort of like Baldur's Gate 2)!


I've managed to get it running at 1280x768 with the high texture setting and 2xAF, which is all that the Mobile 965 Express can manage and it ran OK, movies and all. It can become a slide show in certain places (try to avoid smoke) at those settings, but it's still perfectly playable.
I tried all that, and no luck. Thanks for trying though.

Edit: I tried it on 800x600 and the game crashed first thing after the story crawl.

when I tried it on 1280x768, it worked for a few seconds, I got a glimpse of the opening scene with T3, from his perspective. He was looking up at the roof and then brought his vision to the top of a passageway on the ebon hawk and then... then game crashed. Dammit. I got my hopes up after the first few seconds.

Last edited by Dooms; 09-21-2009 at 07:20 AM.
Dooms is offline   you may: quote & reply,
Old 09-21-2009, 01:22 PM   #16
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Maybe you should mess around with your video driver's aspect ratio settings. Try out different ones. In my experience Intel GPUs cannot scale (stretch the image to fit the screen) this game at all. It has to be 1:1 pixel mapping or the game won't run.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-21-2009, 02:02 PM   #17
Dooms
Rookie
 
Dooms's Avatar
 
Join Date: Sep 2009
Posts: 12
Quote:
Originally Posted by Evil Q View Post
Maybe you should mess around with your video driver's aspect ratio settings. Try out different ones. In my experience Intel GPUs cannot scale (stretch the image to fit the screen) this game at all. It has to be 1:1 pixel mapping or the game won't run.


The only options I get for Aspect Ratio are:

Maintain Aspect Ratio

Full Screen (No Border) *Current*

Center Desktop.

I don't get any 1:1 style options.

I'll give you a list of the 3D options I have with my card:

Asynchronous Flip: On/Off (currently OFF)
Triple Buffering: Default/ON/OFF (currently Defualt)
FLipping Policy: Flip/BLit (currently Blit)
Depth Buffer: Default/ 16 Bit Depth Buffer/ 24 Bit Depth Buffer (currently Default)
Force S3TC Texture Compression: ON/OFF (Currently OFF)
Force FXT Texture Compression: ON/OFF (Currently OFF)
Driver Memory Footprint: Normal/Low/High (Currently Normal)
Texture Color Depth: 16 Bits per Texel/ 32 Bits per Texel/ Desktop Color Depth (Currently Desktop Colour Depth
Anisotropic Filtering: ON/OFF/ Application Control ( Currently Application Control)

So yeah, the only 3D option I've changed was to make it BLIT, other than that, are there any other options that may help this to work?
Dooms is offline   you may: quote & reply,
Old 09-21-2009, 02:40 PM   #18
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Try either of the other two aspect ratio settings before launching the game. You could also try changing the desktop resolution to whatever you have the game set to.

Also; you're NOT trying to run this game with an antivirus and firewall running in the background, are you?


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-21-2009, 02:45 PM   #19
Dooms
Rookie
 
Dooms's Avatar
 
Join Date: Sep 2009
Posts: 12
Quote:
Originally Posted by Evil Q View Post
Try either of the other two aspect ratio settings before launching the game.

Also you're NOT trying to run this game with an antivirus and firewall running in the background, are you?

No, I'm just running the game and firefox in the background. I think I tried the first ratio before, no luck, will try the other one now.

Edit: No luck.

Last edited by Dooms; 09-21-2009 at 02:51 PM. Reason: update.
Dooms is offline   you may: quote & reply,
Old 09-21-2009, 02:52 PM   #20
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
You're surfing without antivirus and firewall?


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-21-2009, 02:57 PM   #21
Dooms
Rookie
 
Dooms's Avatar
 
Join Date: Sep 2009
Posts: 12
Quote:
Originally Posted by Evil Q View Post
You're surfing without antivirus and firewall?
Only on this forum. But that's beside the point anyway. i still couldn't get those two ratios to work.
Dooms is offline   you may: quote & reply,
Old 09-21-2009, 03:06 PM   #22
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Have you tried running the game after a clean boot, with NOTHING running in the background?

Well, other than uninstalling the game, deleting any leftover files and folders, running a registry cleaner like CCleaner and reinstalling, I'm out of suggestions.

I installed the game last night on my cheap Toshiba Satellite with a Pentium Dual-Core 1.6GHz and Mobile 965 Express chipset, and I got it to run with a minimum of fuss even on Vista, so I haven't a clue as to why you all can't get it to run on very similar hardware.

Like I said; I'm out of suggestions.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-21-2009, 03:10 PM   #23
Dooms
Rookie
 
Dooms's Avatar
 
Join Date: Sep 2009
Posts: 12
Quote:
Originally Posted by Evil Q View Post
Well, other than uninstalling the game, deleting any leftover files and folders, running a registry cleaner like CCleaner and reinstalling, I'm out of suggestions.

I installed the game last night on my cheap Toshiba Satellite with a Pentium Dual-Core 1.6GHz and Mobile 965 Express chipset, and I got it to run with a minimum of fuss even on Vista, so I haven't a clue why you all can't get it to run on very similar hardware.

Like I said; I'm out of suggestions.

Mine runs a 945 Express chipset, that could be the difference, although I really doubt it's down to that. I may just uninstall the game and try a fresh install, see if it works. If it doesn't, then I don't think I'll ever get it running on this machine. Oh well. Thanks for helping out anyway.
Dooms is offline   you may: quote & reply,
Old 09-21-2009, 03:17 PM   #24
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Try running it after a clean boot first. Do you know what a clean boot is?

Quote:
Originally Posted by Microsoft
Step 1: Start the System Configuration Utility
Click Start, click Run, type msconfig, and then click OK.
The System Configuration Utility dialog box is displayed.
Step 2: Configure selective startup options
In the System Configuration Utility dialog box, click the General tab, and then click Selective Startup.
Click to clear the Process SYSTEM.INI File check box.
Click to clear the Process WIN.INI File check box.
Click to clear the Load Startup Items check box. Verify that Load System Services and Use Original BOOT.INI are checked.
Click the Services tab.
Click to select the Hide All Microsoft Services check box.
Click Disable All, and then click OK.
When you are prompted, click Restart to restart the computer.
Step 3: Log on to Windows
If you are prompted, log on to Windows.
When you receive the following message, click to select the Don't show this message or launch the System Configuration Utility when Windows start check box, and then click OK.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-21-2009, 03:39 PM   #25
Dooms
Rookie
 
Dooms's Avatar
 
Join Date: Sep 2009
Posts: 12
Quote:
Originally Posted by Evil Q View Post
Try running it after a clean boot first. Do you know what a clean boot is?
Thanks. I'll try this. For some reason some of the files didn't get removed and it's now linked with Kotor1 whenever i try and boot the Kotor 2 CD.



Think I'll just re-format my computer. Much easier to get rid of all the bugs.

Last edited by Dooms; 09-21-2009 at 03:51 PM.
Dooms is offline   you may: quote & reply,
Old 09-21-2009, 04:25 PM   #26
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Whatever.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-21-2009, 06:02 PM   #27
wtfiforgotmysn
Rookie
 
wtfiforgotmysn's Avatar
 
Join Date: Jun 2005
Posts: 11
Well. I tried everything up to the clean boot.. and still nothing.

I suppose it's time to just count my losses and shell $20 or so on the unmoddable Xbox version of the same game that I've already bought. If I were to be angry at anyone here, who would it be? Lucasarts, Obsidian, Intel, or Windows?

Either way, the incompatibility with all these systems in ridiculous.
wtfiforgotmysn is offline   you may: quote & reply,
Old 09-21-2009, 06:21 PM   #28
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
I don't know what else to say. I got it to run on the first try on an Intel Mobile 965 Express chipset and with Vista to boot.

Try uninstalling the game, running CCleaner's registry cleaner and starting over, and run the game on a clean boot after getting it installed.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker

Last edited by Q; 09-21-2009 at 06:38 PM.
Q is offline   you may: quote & reply,
Old 09-21-2009, 08:03 PM   #29
wtfiforgotmysn
Rookie
 
wtfiforgotmysn's Avatar
 
Join Date: Jun 2005
Posts: 11
Will do, I'll post my results in a bit, although I'm getting ever more pessimistic with each attempt.

My brother threw an old XP-running Toshiba laptop on me after he bought a new one, since it "broke". I know it's got an ATI card. Only problem is it runs for about 10 minutes at a time, and then shuts down. I'm assuming it's a motherboard issue. But, if I can't get this to cooperate and I get desperate enough, getting that to stay on may just be my next course of action. Not sure how far I'll get, but wish me luck!
wtfiforgotmysn is offline   you may: quote & reply,
Old 09-21-2009, 10:39 PM   #30
Dooms
Rookie
 
Dooms's Avatar
 
Join Date: Sep 2009
Posts: 12
Anyway, I tried reinstalling it, no luck. I guess there's a slight difference in the 945 to the 965 which lacks certain features to run this game. Unfortunate but there's not much I can do to run it, it seems.

Anyway, to the guy with the Link avatar, try this site:

http://www.systemrequirementslab.com/referrer/srtest

Click Kotor 2 from the drop down menu. If your comp can run it, it will let you know. Otherwise, I guess it will save you wasting time trying to get it to run if it simply won't work.

Anyway, Evil Q, thanks for all the suggestions, I appreciate that you tried to help out.
Dooms is offline   you may: quote & reply,
Old 09-21-2009, 11:43 PM   #31
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
You're welcome. I'm really sorry that we couldn't get it to run.

I know how frustrating stuff like this can be.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 09-22-2009, 01:46 PM   #32
Dooms
Rookie
 
Dooms's Avatar
 
Join Date: Sep 2009
Posts: 12
Quote:
Originally Posted by Evil Q View Post
You're welcome. I'm really sorry that we couldn't get it to run.

I know how frustrating stuff like this can be.
It's ok, I have KotOR 1 and X Wing Alliance to console myself with. Those two games alone have tons of replay value.
Dooms is offline   you may: quote & reply,
Old 09-22-2009, 03:50 PM   #33
wtfiforgotmysn
Rookie
 
wtfiforgotmysn's Avatar
 
Join Date: Jun 2005
Posts: 11
I got a "fail" from systemrequirements labs.. I tried the original KOTOR as well, and I got "fail", but the only category that failed was the OS category.. so I disregarded it, considering it couldn't even identify my system as Windows 7.

BUT. With KOTOR 2, my graphics card category failed too, with these results.

Video Card
Minimum: 32 MB OpenGL 1.4 compliant AGP or PCX 3D Graphics card with Hardware Transform and Lighting (T&L) Capability required.
You Have: Mobile Intel(R) 4 Series Express Chipset Family (Mobile Intel(R) 4 Series Express Chipset Family) FAIL: Sorry, your video card does not meet this minimum requirement.
Video Card Features - Minimum attributes of your Video Card Video RAM: Required - 32 MB , You have - 1.2 GB
Video Card 3D Acceleration: Required - Yes , You have - Yes
Video HW Rasterization: Required - yes , You have - Yes
Video HW Transform & Lighting: Required - Yes , You have - Yes


Well. I guess it's a dead cause to keep trying. Thanks for the link, Dooms.
wtfiforgotmysn is offline   you may: quote & reply,
Old 09-29-2009, 12:54 AM   #34
Lunar4
Rookie
 
Join Date: Dec 2004
Posts: 28
I have the 945 aswell and I havnt been able to get TSL to run at all. It just wont work
Lunar4 is offline   you may: quote & reply,
Old 03-15-2010, 11:56 PM   #35
ivan09193
Lurker
 
Join Date: Mar 2010
Posts: 1
Bumping this thread up

Exact same problem as the original poster on a Gateway laptop with an Intel GMA 965 chipset. I've done all of the Vista fixes, and I've set for blitting. I can get past the opening scene, start hearing the music of the opening level, and then the game crashes. I can play the original KOTOR just fine. Suggestions would be welcome.
ivan09193 is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Knights of the Old Republic > Trouble Shooting > The Work Bench > Driving me crazy - No method can get KOTOR 2 past the character creation..

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:31 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.