lfnetwork.com mark read register faq members calendar

Thread: Please... I'm desperate for help
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 02-18-2010, 12:57 AM   #1
LordOfTheFish
Senior Member
 
LordOfTheFish's Avatar
 
Join Date: Oct 2007
Location: USA
Posts: 2,724
Current Game: Tomb Raider
Forum Veteran 
Please... I'm desperate for help

I really have no idea what has happened to my laptop. Unfortunately I think I may have a virus.

So here is what happened-

A few days ago I decided to clean up my computer a little bit. So I go to my control pannel and go to the uninstall/remove program feature. I deleted a few games, and some other stuff that I don't use anymore. After that I went and cleaned out my pictures. And then deleted a few more files laying around that seemed useless.

I believe it was the next morning or later that night that I came to get back on my computer and tried to start up itunes. And error apearded saying if I remember correctly, a "ddl. or dll. file" was missing but I didn't touch any of the itunes folders.

So then I went to the internet to search for a solution after it suggested reinstalling itunes. When I clicked the shortcut I noticed it was taking a long time to connect. Then a message appeared saying that it was trying to configure "HP Smart Web Search" but a file could not be found.

I then went to try another program to make sure it wasn't all of the programs missing a file. Sure enough, that game could not load because a certain file was missing.

-----

I restored my computer twice to two different points. After the second restore I caught onto that the restored programs I deleted were also missing files. So I just deleted them again hoping it wouldn't matter.

So now I sit here with this problem. After trying to start up Microsoft Word Works, it had to reconfigure. I let that run while I went to dinner. When I came back all of my desktop shortcut icons were gone and this one symbol was being used and almost half of my programs were deleted.

HELP?

LordOfTheFish is offline   you may: quote & reply,
Old 02-18-2010, 05:37 AM   #2
Astrotoy7
A Face from The Past
 
Astrotoy7's Avatar
 
Join Date: Apr 2002
Posts: 10,284
Notable contributor Helpful! Folder extraordinaire LFN Staff Member 
Quote:
Originally Posted by LordOfTheFish View Post
And then deleted a few more files laying around that seemed useless.
The devil is in the details! Do you remember any of these?

There are bits of malware that can also mess with system restore.

Have you run an antivirus/malware scan ??

Some good freeware ones: (pick one)
*Avast
*Microsoft Security Essentials
*Avira
*AVG Free Edition

Also, Malwarebytes Anti-Malware is a must have when sweeping for nasties

mtfbwya


Asinus asinum fricat
Astrotoy7 is offline   you may: quote & reply,
Old 02-18-2010, 10:08 AM   #3
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
I also recommend Microsoft Security Essentials. It's a great free antivirus.

Alongside Malwarebytes I'd recommend a second adware/malware scanner like SUPERAntiSpyware because a second opinion is always a good idea.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 02-18-2010, 05:42 PM   #4
LordOfTheFish
Senior Member
 
LordOfTheFish's Avatar
 
Join Date: Oct 2007
Location: USA
Posts: 2,724
Current Game: Tomb Raider
Forum Veteran 
Thanks both of you. I have run a McAfee virus scan and it detects nothing. I suppose I'll try another program to see what it can find.

Quote:
Originally Posted by Astrotoy7 View Post
The devil is in the details! Do you remember any of these?
Not specifically no. But I did read over the names and make sure I didn't delete anything I wasn't suppose to. They files from program file that were either empty or stuff that I don't use anymore. I'm beginning to wonder if some files were not where they were suppose to be...

[EDIT]

I downloaded Malwarebytes' and swept my computer. It found over 200 infected (I don't know if that's a lot) files, most of which are registry keys starting with HKEY_. It also found lot's of files, memory modules, and memory processes from "mywebsearch" which I've had bad experiences with in the past. I'm not even sure how it got onto my computer unless it's a default program and I don't know it.

I'm assuming it's safe to just remove all infected files? I haven't done so yet, but is that right?

Thanks,

-Fish-


Last edited by LordOfTheFish; 02-18-2010 at 10:54 PM.
LordOfTheFish is offline   you may: quote & reply,
Old 02-20-2010, 07:59 AM   #5
Astrotoy7
A Face from The Past
 
Astrotoy7's Avatar
 
Join Date: Apr 2002
Posts: 10,284
Notable contributor Helpful! Folder extraordinaire LFN Staff Member 
Malware proggies usually make a backup, but if you want to be double sure just make a system checkpoint yourself.

Of course, before you do *anything* else - it goes without saying that you should have all important stuff backed onto an external drive/dvd, the cloud etc.

As for the 200 finds, whilst there always is the possibility of some false positives and harmless detritus floating around - you'd still prefer MBAM to find zero entries, or course

Also, if you post any follow up, please specify your OS

mtfbwya


Asinus asinum fricat

Last edited by Astrotoy7; 02-20-2010 at 08:08 AM.
Astrotoy7 is offline   you may: quote & reply,
Old 02-20-2010, 09:14 PM   #6
LordOfTheFish
Senior Member
 
LordOfTheFish's Avatar
 
Join Date: Oct 2007
Location: USA
Posts: 2,724
Current Game: Tomb Raider
Forum Veteran 
Here is my MBAM log. And by OS I'm asuming you mean operating system? If so I'm using Vista.

Show spoiler


Everything seems to be related to mywebsearch. I'm not sure how that got onto my computer...

LordOfTheFish is offline   you may: quote & reply,
Old 02-25-2010, 03:51 PM   #7
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
If everything's that f'd up, I see a reformat in your future. Nuke it from orbit. Only way to be sure.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Community Discussion > General LFNetwork Forums > General Tech Discussion > Please... I'm desperate for help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:09 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.