lfnetwork.com mark read register faq members calendar

Thread: Black Screen on Main Menu
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 06-15-2010, 05:31 PM   #1
SheBear
Rookie
 
Join Date: Dec 2006
Posts: 32
Black Screen on Main Menu

I am trying to install TSL and have installed following the directions in the Vista compatibility thread. My nVidia drivers are up to date, I installed the game in compatibility mode, and installed the patch in compatibility mode.

The only thing I did that the thread didn't talk about was install the HQ Music and Movies patches after the game patch.

My problem is that when I start the game it begins the Lucas Arts and Obsidian logos, then becomes a black screen, but the main menu is there, the music plays and I can actually click on different parts of the menu and move to different menus, but obviously I can't see the menu.

EDIT: I just reinstalled my nVidia drivers, and the game (again according to instructions) and the same thing happened. I also neglected to mention that if I alt-tab out of TSL after it has gotten to this "black menu" thing then upon trying to reopen it, or shifting to another window it will crash and cause a "this program has had to close" error message (the fastest way to do this is ctrl-alt-del to open the task manager and then it happens).

Any ideas on what may be causing this?

Last edited by SheBear; 06-17-2010 at 06:10 PM.
SheBear is offline   you may: quote & reply,
Old 06-17-2010, 08:30 PM   #2
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Did you follow the large-print directions in the second post of the Vista thread?


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 06-17-2010, 08:56 PM   #3
SheBear
Rookie
 
Join Date: Dec 2006
Posts: 32
Yes I did. Twice. Which is why I don't know what is wrong. I feel like it is some type of video card/general graphics issue since it isn't just straight crashing it just isn't loading the graphics for the title loading screen or for the main menu.
SheBear is offline   you may: quote & reply,
Old 06-18-2010, 12:27 AM   #4
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
You're probably right about that. It could be a simple fix. Would you be so kind as to use the game's configuration utility to post your system specs?
Quote:
Originally Posted by stingerhs View Post
Post your system specs
Sometimes we're just not going to be able to help you if we don't know what kind of hardware you have on your machine. If you don't know what you have on your machine, then follow these steps below:
  • Bring up the launcher menu for Kotor 1 or 2.
  • Click on "Configure".
  • Click the "Scan Hardware" button on the lower center of the window.
  • Click "Yes" to continue.
  • Click "Details" to view your system specs.
  • Click "Save Report" and save the file to your desktop.
  • Whenever you post your problem, open the file you just saved and copy and paste the contents to your post.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 06-18-2010, 09:54 AM   #5
SheBear
Rookie
 
Join Date: Dec 2006
Posts: 32
Here is my system information, though on a quick read through it doesn't detect my actual graphics cards (two GTX 280M), but that is a known problem I believe (which causes the error when I ran the scan tool that said that there was a problem with the drivers for the nVidia card, correct?). It is also strange that it thinks my OS is XP, I guess that is because of installing in compatibility mode.

EDIT: Another strange thing I see is that under the section listing things from the .ini file it says that under Display options the Height and Width are 640x480, while if I go into the .ini file and look under Display options they say 1024x768 (which I changed it to on the advice from your post, Evil Q, in the Vista/7 thread). I also have in the .ini file under Graphics height and width set to 1024x768 (which is what the scan found).

I hope something in there helps.

Quote:
[SWKotOR]
ReportDateTime=6/18/2010 9:49:42 AM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=None
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=1
CPUSpeed=2000
CPUFamily=6
CPUModel=7
CPUStepping=10
CPUVendor=Intel
CPUName=Intel(R) Core(TM)2 Quad CPU Q9000 @ 2.00GHz
Status=Pass

[Memory]
RAM=3840
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=28.37GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\
Drives=

[Video]
Video Card Name=
Video Memory=4096
Desktop Resolution=0x0x0
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=3.3.0
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce 9400/PCI/SSE2
NVidia Driver=(null)
Vid Card Status=Warning
Vid Card Driver Status=Fail
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers / Headphones (IDT High Definition Audio CODEC)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
EAX=0
Sound Init=0
Disable Sound=0
Force Software=0

[Graphics Options]
Anisotropy=16
Frame Buffer=1
Grass=1
Soft Shadows=1
Shadows=1
Brightness=57
EnableHardwareMouse=0
FullScreen=0
RefreshRate=60
Width=1024
Height=768
V-Sync=0
Texture Quality=2
Anti Aliasing=8
Emitters=1

[Game Options]
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
TooltipDelay Sec=1
Disable Movies=0

[config]
firstrun=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action268=52
Action265=58
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=60
Action213=62
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

[Autopause Options]
End Of Combat Round=0
Mine Sighted=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[Movies Shown]
Movie10=0
Movie 9=0
Movie 8=0
Movie 7=0
Movie 6=0
Movie 5=0
Movie 4=0
Movie 3=0
Movie 2=0
Movie 1=0
Movie 0=0
SheBear is offline   you may: quote & reply,
Old 06-18-2010, 04:31 PM   #6
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Um, WOW! Nice laptop! I'd hate to see how much that sucker cost.

OK, I'm seeing a few things that would cause the game to screw up:

1) Your video card driver status is Fail. Though swconfig doesn't recognize newer video cards as adequate because the game itself is so old, if your driver status is Fail, it indicates another problem. Have you updated DirectX?

2) You need to do the Dantooine lag fix. This is crucial if you want the game to run at all. If you did do it, then it was not saved properly and needs to be done again.

3) As you noted, the "Width" and "Height" need to be set to the same values under both "Display Options" and "Graphics Options" (and at a resolution that the game supports), but so does "Fullscreen".

4) The game supports SLI, but it will actually run with fewer anomalies if you set it to run in single-GPU mode in your Nvidia control panel. One of your cards is more than powerful enough to run the game at its highest settings.

5) Are you running Vista or 7? With Vista you'll have to use Task Manager to set CPU affinity to a single core every time you launch the game, but 7 will do that automatically.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 06-18-2010, 05:03 PM   #7
SheBear
Rookie
 
Join Date: Dec 2006
Posts: 32
haha, Thanks. Yeah, it cost quite a bit.

1) I did update my video card driver to the latest version: 8.17.12.5721
I think everything DirectX related it totally up to date, checking with DirectX Diagnostic Tool it says I have DirectX 11. I also have installed the DirectX Redistributable Package and when the game installed the most recent time it did say (in the end when it checks DirectX version) that the most up to date 9.0c was installed.


2) I did the lag fix ("Disable Vertex Buffer Objects=1" as the last line under [Graphics Options] in the .ini. At least that what the .ini file looks like in the SWKotOR2 folder.

3) For the width and height, I need to have Width=1024 and Height=768 as lines in the .ini under both the [Display Options] and the [Graphics Options]? I had that before. But I will try that again.

4) I just changed the setting in the nVidia Control Panel called CUDA-GPUs from all of them to GeForce GTX 280M (1 of 2).

5) I have Vista, but when I try to set the CPU affinity in the Task Manager (start the game, Ctrl-Alt-Del > open Task Manager > set the affinity to single core) the game crashes (either from trying to Alt-Tab back into the game or just from opening the Task Manager).

Last edited by SheBear; 06-18-2010 at 05:44 PM.
SheBear is offline   you may: quote & reply,
Old 06-18-2010, 06:46 PM   #8
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Quote:
Originally Posted by SheBear View Post
1) I did update my video card driver to the latest version: 8.17.12.5721
I think everything DirectX related it totally up to date, checking with DirectX Diagnostic Tool it says I have DirectX 11. I also have installed the DirectX Redistributable Package and when the game installed the most recent time it did say (in the end when it checks DirectX version) that the most up to date 9.0c was installed.
Then you should be fine, here.
Quote:
Originally Posted by SheBear
2) I did the lag fix ("Disable Vertex Buffer Objects=1" as the last line under [Graphics Options] in the .ini. At least that what the .ini file looks like in the SWKotOR2 folder.

3) For the width and height, I need to have Width=1024 and Height=768 as lines in the .ini under both the [Display Options] and the [Graphics Options]? I had that before. But I will try that again.
This would seem to indicate that the .ini hacks are not saving correctly. Are you using an administrator account? It's not critical, but you really should just to bypass all of that lovely permissions crap. If you don't want to, that's fine, but you'll have to move that .ini file to your desktop, make the necessary changes, save and then move it back into your game folder for the changes to stick.
Quote:
Originally Posted by SheBear
4) I just changed the setting in the nVidia Control Panel called CUDA-GPUs from all of them to GeForce GTX 280M (1 of 2).
Under 3d Settings>Program Settings there should be list of program .exes and swkotor2.exe should be on it. Select that, and there will be an option to set SLI Performance Mode to Single-GPU. Do that and hit "Apply".
5) I have Vista, but when I try to set the CPU affinity in the Task Manager (start the game, Ctrl-Alt-Del > open Task Manager > set the affinity to single core) the game crashes (either from trying to Alt-Tab back into the game or just from opening the Task Manager).
The KotOR games hate Alt-Tab. I need to update the guide (it's a never-ending work in progress) to say that launching Task Manager before starting the game, hitting the Windows key after waiting for the main game menu to appear, setting CPU affinity and then hitting the game's icon in the taskbar works best for me.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 06-18-2010, 07:21 PM   #9
SheBear
Rookie
 
Join Date: Dec 2006
Posts: 32
Quote:
Originally Posted by Evil Q View Post
This would seem to indicate that the .ini hacks are not saving correctly. Are you using an administrator account? It's not critical, but you really should just to bypass all of that lovely permissions crap. If you don't want to, that's fine, but you'll have to move that .ini file to your desktop, make the necessary changes, save and then move it back into your game folder for the changes to stick.
Ok, so I just discovered something very strange and interesting. In the SWKotOR2 folder on the ribbon of actions I can perform in the folder (Organize, Views, etc) one of them says: Compatibility Files. I clicked it, not having even noticed it before.
There are two things: A saves folder and swkotor2.ini! But, I open it, this isn't the same file as in the general SWKotOR2 folder. It looks like the .ini file which the scan pulls up and copies into it's text file. So I copy it to the desktop and change the necessary things (making the width and height under both Display and Graphics Options the same, adding "Disable Vertex Buffer Objects=1" to the end of the Graphics Options section and setting "Fullscreen=1" where it is 0). I then save it and put that back into the folder I was just in (SWKotOR2>Compatibility Files).
I run the scan and the graphics card still fails in the scan, but looking at the file all of the changes I had made in that .ini file have been changed in the scan's log under the .ini file copy. So... was this what I was supposed to be editing all along, and there just happens to be another .ini file that is very similar but not under Compatibility Files in the SWKotOR2 folder?
Unfortunately it didn't fix the issue though, I tried starting the game and had the same exact issue as before.

Quote:
Originally Posted by Evil Q View Post
Under 3d Settings>Program Settings there should be list of program .exes and swkotor2.exe should be on it. Select that, and there will be an option to set SLI Performance Mode to Single-GPU. Do that and hit "Apply".
I don't have a SLI Performance Mode option, but I do have a SLI Rendering Mode, which I set to Single-GPU. I'm assuming that is the same thing? I did this before the stuff I detailed just above, so it didn't help run the game correctly though.

Quote:
Originally Posted by Evil Q View Post
The KotOR games hate Alt-Tab. I need to update the guide (it's a never-ending work in progress) to say that launching Task Manager before starting the game, hitting the Windows key after waiting for the main game menu to appear, setting CPU affinity and then hitting the game's icon in the taskbar works best for me.
This still didn't work for me. It is probably because the game isn't running correctly to begin with, and so it is being more touchy than it should be. When I have the Task Manager all ready (with the show all processes already enabled) and then I start the game, wait for it to get to the menu (still a black screen which I can move my mouse around and click on parts of the menu-I actually at one point accidentally clicked on the Exit Game button on the menu and it worked fine and exited the game), then hit the Windows key it brings up the Task Manager but then once I get to setting the affinity it minimizes TSL and at that point I can't get back into it and the Task Manager reports that it is not responding.
EDIT: What I wrote just above it only partly correct, it does that if I have other programs running than just the Task Manager or TSL (I was running this forum/the SWKotOR2 folder before). I just tried with only the Task Manager and TSL running and what you described worked perfectly, I was able to set the affinity and then get back to the main menu. It was still a black screen with the menu underneath, but it did work. I tried to use the Windows key to do the same thing again and it took me all the way to the desktop unlike before and it crashed TSL. But, I guess I figured out how to get that to work (in the case I can ever see the menu).

Last edited by SheBear; 06-18-2010 at 07:27 PM.
SheBear is offline   you may: quote & reply,
Old 06-18-2010, 10:40 PM   #10
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
1) Which version of the game are you running? Original disks or a digital download?

2) Did you patch the game before replacing the .exe?
Quote:
Originally Posted by SheBear View Post
Ok, so I just discovered something very strange and interesting. In the SWKotOR2 folder on the ribbon of actions I can perform in the folder (Organize, Views, etc) one of them says: Compatibility Files. I clicked it, not having even noticed it before.
There are two things: A saves folder and swkotor2.ini! But, I open it, this isn't the same file as in the general SWKotOR2 folder. It looks like the .ini file which the scan pulls up and copies into it's text file. So I copy it to the desktop and change the necessary things (making the width and height under both Display and Graphics Options the same, adding "Disable Vertex Buffer Objects=1" to the end of the Graphics Options section and setting "Fullscreen=1" where it is 0). I then save it and put that back into the folder I was just in (SWKotOR2>Compatibility Files).
I run the scan and the graphics card still fails in the scan, but looking at the file all of the changes I had made in that .ini file have been changed in the scan's log under the .ini file copy. So... was this what I was supposed to be editing all along, and there just happens to be another .ini file that is very similar but not under Compatibility Files in the SWKotOR2 folder? Unfortunately it didn't fix the issue though, I tried starting the game and had the same exact issue as before.
I've only edited the .ini file in the game folder itself. Did you open it again to see if the changes are there? If not, move it to the desktop, right-click on it, select "Properties" and unselect "Read-Only" if it is checked. Then make the changes, save and move it back. Check your work by re-opening the .ini file to see if the changes took, then use the configuration utility to scan your hardware again.
Quote:
Originally Posted by SheBear
I don't have a SLI Performance Mode option, but I do have a SLI Rendering Mode, which I set to Single-GPU. I'm assuming that is the same thing? I did this before the stuff I detailed just above, so it didn't help run the game correctly though.
Once we get it running, it will help it run better.
Quote:
Originally Posted by SheBear
EDIT: What I wrote just above it only partly correct, it does that if I have other programs running than just the Task Manager or TSL (I was running this forum/the SWKotOR2 folder before). I just tried with only the Task Manager and TSL running and what you described worked perfectly, I was able to set the affinity and then get back to the main menu. It was still a black screen with the menu underneath, but it did work. I tried to use the Windows key to do the same thing again and it took me all the way to the desktop unlike before and it crashed TSL. But, I guess I figured out how to get that to work (in the case I can ever see the menu).
Once you edit the actual .ini file in the game folder itself, make sure that the mss32.dll and the swkotor2.exe files got replaced properly by the new ones that you downloaded by replacing them again just to be sure. If you still get the black screen, look in your Nvidia control panel under "Change resolution" and see if 1024x768 is in the list of supported resolutions. If not, then you'll have to make a custom resolution. The game supports 1280x768 natively by simply changing the .ini width and height settings to those values (again, under both "Display Options" and "Graphics Options"), which might fit your screen better (it is widescreen, right?). Just make sure that it's on the list in the Nvidia control panel under "Change resolution", and then select the "Use Nvidia scaling" (with or without fixed aspect ratio -try both).


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 06-18-2010, 11:52 PM   #11
SheBear
Rookie
 
Join Date: Dec 2006
Posts: 32
*Grump* Well, none of that worked either.

1)I have the original disks.
2) Yes, I did patch the game before replacing swkotor2.exe or mss32.dll.

With the .ini files. I have checked multiple times both versions of the .ini file keep the changes that I make to them, they are both not Read Only, and I originally saved copies of them to the desktop, made changes and then copied them back into the SWKotOR2 folder.

I replaced the .exe and the .dll file after changing the .ini file(s) again (to your suggested 1280x768, which I also added to the nVidia control panel, and set it to use plain nVidia scaling). I didn't know I needed to replace them after editing the .ini file. I haven't restarted after doing that though, but I'll try that and see if that changes anything.

EDIT: After a restart I tried again and the same thing still happens.

Also, does it really not matter that the scan doesn't read my video card at all? It doesn't even list it/any of the three (the integrated or the two 280Ms), which seems troubling, but is that just because they are too advanced for the scan/TSL to detect or whatever?

By the way, thanks so much for all your help in these attempts.

Last edited by SheBear; 06-19-2010 at 12:50 AM.
SheBear is offline   you may: quote & reply,
Old 06-19-2010, 01:05 AM   #12
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
OMG, that's it! Why didn't I notice this sooner?

The game is trying to use your on-board GPU instead of your GTX 280M. You're most likely going to have to reinstall the game again, but try disabling your integrated (on-board) GPU, first in Device Manager, then in the BIOS and running the configuration utility and scanning your hardware again first. If that doesn't work, reinstall the game with the on-board disabled and it should recognize the GTX 280Ms and the drivers.
Quote:
Originally Posted by SheBear View Post
I replaced the .exe and the .dll file after changing the .ini file(s) again (to your suggested 1280x768, which I also added to the nVidia control panel, and set it to use plain nVidia scaling). I didn't know I needed to replace them after editing the .ini file.
You don't, usually; that's just me being paranoid.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker

Last edited by Q; 06-19-2010 at 01:21 AM.
Q is offline   you may: quote & reply,
Old 06-19-2010, 01:14 PM   #13
SheBear
Rookie
 
Join Date: Dec 2006
Posts: 32
Well, just disabling the integrated graphics card and trying to run the game didn't work, but in a different way than before.

But doing that also caused my 280Ms to not work correctly. I couldn't bring up the nVidia control panel (it wasn't an option when I right clicked on the desktop), and the icon in my system tray for the SLI enabled cards running was completely gone. And in the device manager they had little warning signs next to their icons and said something about Error 31, or something like that.

I also ran into a different problem running the configuration tool scan, here is the scan with the integrated card disabled:

Quote:
[SWKotOR]
ReportDateTime=6/19/2010 12:59:30 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=None
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=1
CPUSpeed=2000
CPUFamily=6
CPUModel=7
CPUStepping=10
CPUVendor=Intel
CPUName=Intel(R) Core(TM)2 Quad CPU Q9000 @ 2.00GHz
Status=Pass

[Memory]
RAM=3840
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=33.10GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\
Drives=

[Video]
Video Card Name=
Video Memory=0
Desktop Resolution=1440x900x32
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=1.1.0
OpenGL Vendor=Microsoft Corporation
OpenGL Renderer=GDI Generic
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Fail
DX Status=Pass

[Audio]
Sound Card Name=Speakers / Headphones (IDT High Definition Audio CODEC)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=1280
Height=768
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
EAX=0
Sound Init=0
Disable Sound=0
Force Software=0

[Graphics Options]
Anisotropy=16
Frame Buffer=1
Grass=1
Soft Shadows=1
Shadows=1
Brightness=57
EnableHardwareMouse=0
FullScreen=1
RefreshRate=60
Width=1280
Height=768
V-Sync=0
Texture Quality=2
Anti Aliasing=8
Emitters=1
Disable Vertex Buffer Objects=1

[Game Options]
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
TooltipDelay Sec=1
Disable Movies=0

[config]
firstrun=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action268=52
Action265=58
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=60
Action213=62
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

[Autopause Options]
End Of Combat Round=0
Mine Sighted=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[Movies Shown]
Movie10=0
Movie 9=0
Movie 8=0
Movie 7=0
Movie 6=0
Movie 5=0
Movie 4=0
Movie 3=0
Movie 2=0
Movie 1=0
Movie 0=0
"GL Status=Fail" That line looks to be the issue now.

And when I tried to run TSL it started loading and before it got to the Lucas Arts logo it crashed to the desktop with the standard error message.

I will try disabling the integrated graphics card again later, then reinstalling and see if that does anything to help. But I have some graduation parties for friends of mine to go to now so I will have to do that later. If you have any suggestions from the new scan file let me know though. Thanks!

EDIT: Ok, I tried uninstalling TSL, then disabling the integrated graphics card, then reinstalling TSL. I have the same problem as when I just disabled the integrated graphics card without reinstalling TSL. It crashes upon start up before getting to the Lucas Arts logo. And it gives the same error in the scan.

Also, upon looking more closely at the BIOS file, under Graphics Options (or whatever it is actually called) the Integrated Graphics label of Enabled/Disabled are grayed out and I can't get to it, but it is just grayed out saying Enabled. Which seems to look like I need to have the integrated graphics card running or the dedicated aren't going to work (which seems to be proved by when the integrated is enabled the dedicated graphics cards work again and the nVidia control panel comes back - this happened after reinstalling the 280M's drivers to see if it would fix the issue of the scan saying that the Open GL wasn't new enough or whatever, but when I restarted the computer had enabled the integrated graphics card).

Last edited by SheBear; 06-19-2010 at 06:41 PM.
SheBear is offline   you may: quote & reply,
Old 06-19-2010, 06:43 PM   #14
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Are all three GPUs SLIed together? Weird.

At this point, it would definitely help to know the make and model of your laptop so that I can find out more about it.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 06-19-2010, 06:51 PM   #15
SheBear
Rookie
 
Join Date: Dec 2006
Posts: 32
It is an Alienware M17x.
(copying things from my System info in the control panel)
It is Vista 64-bit, Service Pack 2.
Processor: Intel Core2 Quad CPU Q9000 @ 2.00GHz 2.00GHz.
4.00 GB of RAM
Graphics Cards listed under Device Manager>Display Adapters: NVIDIA GeForce 9400, NVIDIA GeForce GTX 280M, NVIDIA GeForce GTX 280M.

Last edited by SheBear; 06-19-2010 at 06:59 PM.
SheBear is offline   you may: quote & reply,
Old 06-19-2010, 07:23 PM   #16
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
What I really would like to know is what type of chipset the motherboard has. I'm guessing it's an Nvidia chipset of some sort, but I need to know if that integrated GPU has to be enabled for the discrete cards to work.

I have no experience with this particular model. The laptops that most people trying to get these games to run on are ~$500 models with Intel GPUs, so this might be beyond my ability to help, but knowing what type of chipset it has might point you in the right direction, such as Alienware's or Nvidia's forums, where you'd have a decent chance of finding someone who can help you.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 06-19-2010, 07:28 PM   #17
SheBear
Rookie
 
Join Date: Dec 2006
Posts: 32
In the manual it says: System Chipset NVIDIA GeForce 9400 G

Looking at the manual more (under the information about the BIOS settings), it seems I can turn off both the Hybrid Graphics and the Integrated Graphics with the BIOS and still get the graphics cards to run. I guess I can try doing that too.

There is a table in the manual with my graphics options: Hybrid On, Integrated Grayed Out; Hybrid Off, Integrated Off; Hybrid Off, Integrated On

EDIT: I GOT IT TO WORK! (at least the menu appeared!) I went into the BIOS and disabled both the Hybrid and Integrated graphics and then restarted and tried loading the game again. Woohoo! I guess your guess was correct, I just wasn't disabling the Integrated Graphics card correctly. Thank you so much for you help and patience with my issues, Evil Q.

Now hopefully I can install the mods I want without issue and play TSL again finally!

Last edited by SheBear; 06-19-2010 at 07:55 PM.
SheBear is offline   you may: quote & reply,
Old 06-19-2010, 08:14 PM   #18
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Ah, it's a hybrid setup, meaning that the computer uses that on-board 9400 for mundane operations to conserve battery power, then switches over to the 280Ms only for graphics-intensive stuff. Try selecting "Hybrid Off, Integrated Off", then boot into Windows and try another hardware scan with the game's configuration utility to see if it recognizes the 280Ms. If it doesn't, restart and re-enter the BIOS to make sure that the on-board is indeed disabled before booting into Windows and reinstalling the game (yes, again ). You might have to reinstall the drivers with the on-board disabled, but I don't think that you will.

I'm pretty sure that the hybrid setup is what's screwing up the game installation because the game has no clue which GPU to use. It's an old game, after all. The downside to doing this is that your laptop's going to eat through battery life like crazy, so hopefully you can get away with powering on, entering the BIOS, disabling hybrid and on-board and booting into Windows just to play TSL, then restarting, entering the BIOS to enable the hybrid/on-board, then booting into Windows for normal usage. It'll be a PITA, but, if it works, you'll at least be able to play the game.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Knights of the Old Republic > Trouble Shooting > The Work Bench > Black Screen on Main Menu

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:59 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.