lfnetwork.com mark read register faq members calendar

Thread: KOTOR Crashing Issues
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 02-06-2012, 08:32 PM   #1
xXMythicXx
Lurker
 
Join Date: Feb 2012
Posts: 3
KOTOR Crashing Issues

Alright, so I just bought a new copy of KOTOR. I have a Windows XP 32 bit that I'm trying to run it on, but it doesn't even make it to the starting movies. It comes up with the loading picture (the Ebon Hawk if I'm not mistaken), but then it disappears after 5-10 seconds. Here are my specs:

[SWKotOR]
ReportDateTime=2/6/2012 6:31:51 PM
SysInfoVersion=v1.00.19
GameExists=1
GameVersion=v1.00.514058
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 3
Service Pack=Service Pack 3
Status=Pass

[SwapFiles]
c:\pagefile.sys=2046

[CPU]
CPUCount=1
CPUSpeed=2992
CPUFamily=15
CPUModel=4
CPUStepping=1
CPUVendor=Intel
CPUName= Intel(R) Pentium(R) 4 CPU 3.00GHz
Status=Pass

[Memory]
RAM=2047
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=3.54GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\,E:\
Drives=PHILIPS DVD8631

[Video]
Video Card Name=NVIDIA GeForce 8400 GS
Video Memory=512
Desktop Resolution=800x600x32 @ 60Hz
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=3.3.0
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce 8400 GS/PCI/SSE2
Vid Card Status=Warning
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=SoundMAX Integrated Digital Audio
Status=Pass


;Game Options from swkotor.ini

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=100
Force Software=0
EAX=3
Disable Sound=0
Number 3D Voices=16
Number 2D Voices=24
Environment Effects Level=0.60
2D3D Bias=1.50
Environment Effects=1

[Game Options]
Hide InGame GUI=0
Use Small Fonts=0
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=33
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
Reverse Minigame YAxis=0
Combat Movement=1
Enable Tooltips=1
Difficulty Level=1
TooltipDelay Sec=1.000000
Memory Access=1
Memory Level=1

[Movies Shown]
Movie 0=0
Movie 1=0
Movie 2=0
Movie 3=0
Movie 4=0
Movie 5=0
Movie 6=0
Movie 7=0
Movie 8=0
Movie 9=0
Movie10=0

[Alias]
HD0=.\
OVERRIDE=.\Override
TEMP=.\Temp
MODULES=.\Modules
LOGS=.\Logs
LOCALVAULT=.\LocalVault
DMVAULT=.\DMVault
SERVERVAULT=.\ServerVault
STREAMMUSIC=.\StreamMusic
TEMPCLIENT=.\Tempclient
SAVES=.\saves
CURRENTGAME=.\currentgame
TEXTUREPACKS=.\texturepacks
STREAMWAVES=.\StreamWaves

[Graphics Options]
V-Sync=0
Anisotropy=1
Frame Buffer=1
Anti Aliasing=0
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=0
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=1

[Autopause Options]
Mine Sighted=1
End Of Combat Round=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[config]
firstrun=0

I've tried downloading the newest version of DirectX, but that does nothing. All the fixes are either for Vista/Windows 7 or they require setting the permission level to administrator (I don't know what the hell the password is) and setting the compatibility options to Win XP SP3 which isn't there. Please help!
xXMythicXx is offline   you may: quote & reply,
Old 02-06-2012, 09:37 PM   #2
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
Thanks for posting your specs. Makes things easier for me. Since you have XP, you shouldn't have to do much to get the game running.

The first thing you need to do is patch your game. KotOR1's updater should still be able to do it.

The second thing you need to do is the Dantooine lag fix, which is needed by any video card that supports DX10 or newer:
Quote:
Originally Posted by stingerhs View Post
  • First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
  • When you find it, just double-click on the file to open it in Notepad.
  • Scroll down the file until you find the Graphics Options
  • Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini"), add "Disable Vertex Buffer Objects=1", without the quotes.
  • Goto File, then Save.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Old 02-06-2012, 09:45 PM   #3
xXMythicXx
Lurker
 
Join Date: Feb 2012
Posts: 3
Thanks. I'll give it a try.

EDIT: It's working! Thanks.

Last edited by xXMythicXx; 02-06-2012 at 10:07 PM. Reason: Response
xXMythicXx is offline   you may: quote & reply,
Old 02-07-2012, 12:49 PM   #4
Q
The one who knocks
 
Q's Avatar
 
Join Date: May 2006
Location: ABQ
Posts: 6,643
Current Game: Mowing down neos with my M60
LF Jester Forum Veteran Helpful! 
You're welcome.


"They should rename the team to the Washington Government Sucks. Put Obama on the helmet. Line the entire walls of the stadium with the actual text of the ACA.
Fix their home team score on the board to the debt clock, they can win every game 17,000,000,000,000 to 24. Losing team gets taxed by the IRS 100%, then droned."
-Toker
Q is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Knights of the Old Republic > Trouble Shooting > The Work Bench > KOTOR Crashing Issues

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:06 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.