lfnetwork.com mark read register faq members calendar

Thread: GLimp_Init() - Invalid GL Driver
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 06-29-2002, 06:22 AM   #1
Mike Supafly
 
Mike Supafly's Avatar
 
Join Date: Jun 2002
Posts: 9
Unhappy GLimp_Init() - Invalid GL Driver

Lately I updated to windows XP from windows ME. I decided to play a happy game of Jedi Knight II when suddenly Satan sprung forth from the ground and cursed my computer! I try to start multiplayer but it goes to a black screen then dumps me back at my desktop again. I try single player and I get an error message in the console after it loads a black screen and dumps me at my desktop again. Here is the error:


JK2: v1.02a win-x86 Mar 4 2002
Initialising zone memory .....
----- FS_Startup -----
Current search path:
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\WeaponsGlow.pk3 (2 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\Ultimate_Maul.pk3 (26 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\TBM.pk3 (5 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\skin_scom.pk3 (15 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\sithstatue.pk3 (17 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\ROTJ_bowcaster.pk3 (14 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\nergen_swamper.pk3 (9 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\Mandalorian.pk3 (288 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\jonathanodell_darthmaul.pk3 (34 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\ddcd.pk3 (7 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\darth_mekanus.pk3 (45 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\clonetrooper.pk3 (30 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets2.pk3 (289 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets1.pk3 (8011 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets0.pk3 (6674 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData/base

----------------------
15466 files in pk3 files
execing default.cfg
execing jk2config.cfg
couldn't exec autoexec.cfg
...detecting CPU, found AMD w/ 3DNow!

------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.
------------------------------------

------- Force Feedback Initialization -------
...inhibited, not initializing

----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Working directory: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): failed
...shutting down QGL
...unloading OpenGL DLL
-----------------------
GLimp_Init() - Invalid GL Driver


If anyone can help, please do! The forums don't allow you to search, so unfortunately I have to create a new thread. :\

Thanks in advance.

Edit: Oops, should this have gone in the bug forum? I didn't see it before posting. Sorry.
Mike Supafly is offline   you may: quote & reply,
Old 06-29-2002, 06:35 AM   #2
IMNORFIN
 
Join Date: May 2002
Posts: 27
Mmm try changing your resolution of your desktop, I've heard that that could 'cause problems maybe.
IMNORFIN is offline   you may: quote & reply,
Old 06-29-2002, 06:46 AM   #3
Mike Supafly
 
Mike Supafly's Avatar
 
Join Date: Jun 2002
Posts: 9
Unhappy No sir, don't work.

I tried on different resolutions and it didn't change a thing. Thanks anyways. Any other ideas?
Mike Supafly is offline   you may: quote & reply,
Old 06-29-2002, 07:04 AM   #4
HellFyre69
 
HellFyre69's Avatar
 
Join Date: Jun 2002
Posts: 588
If you are running Winxp, and U have a Geforce Video card.... then u need to dl the detonator (drivers) for winxp.


It is obvious this contest cannot be decided by our knowledge of the Force, but by our skills with the lightsaber."

-Count Dooku

HellFyre69 is offline   you may: quote & reply,
Old 06-30-2002, 12:37 AM   #5
Mike Supafly
 
Mike Supafly's Avatar
 
Join Date: Jun 2002
Posts: 9
Thank you very much! It works just like it used to. :)
Mike Supafly is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Game Discussion > Jedi Outcast > GLimp_Init() - Invalid GL Driver

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:09 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.