lfnetwork.com mark read register faq members calendar

Thread: Technical Question - TSOMI
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 11-05-2002, 07:50 AM   #1
kev_stanley
 
Join Date: Nov 2002
Location: Deepest Staffordshire
Posts: 4
Technical Question - TSOMI

Hi all

Well before I realised you could download emulators and the like to run old games I went out and bought myself an old compaq presario (the all in one jobbie)

I dug out my old copy of MI and after scandisking the floppies to death I managed to install it.

However I can't get any sound :-(

Does anyone know if there is some way of specifying what IRQ, DMA, ports to use as the only reason I can think of that the sound doesn't work is because the programs trying to use unused ports.

Any other suggestions would be greatly appriciated as I'm dying to get playing again!

Cheers
Kev

PS - The sound does work with some other old games.


Ding dang do, you'll do for me!
kev_stanley is offline   you may: quote & reply,
Old 11-05-2002, 08:10 AM   #2
Yoghurt
 
Yoghurt's Avatar
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 131
hmmmm,

I assume you run the games under dos right?

Be sure to have the soundblaster drivers properly installed in DOS, then be sure to start Monkey Island as:

monkey.exe g - for gameblaster (soundblaster)
monkey.exe a - for adlib
monkey.exe r - for roland
monkey.exe p - for pc speaker (am I right??)


Smith ey? That's an unusual name!

Last edited by Yoghurt; 11-06-2002 at 03:28 AM.
Yoghurt is offline   you may: quote & reply,
Old 11-05-2002, 01:32 PM   #3
bgbennyboy
Festively Plump
 
bgbennyboy's Avatar
 
Status: Super Moderator
Join Date: Feb 2002
Location: England
Posts: 1,984
LFN Staff Member 
Moved to help, look at threads in here for previous posts ive made about irq, dma etc.
Click show threads from the beginning.
If Yoghurt's reply doesnt tell you enough then reply here and i'll try and help you some more.

bgbennyboy is offline   you may: quote & reply,
Old 11-06-2002, 04:02 AM   #4
kev_stanley
 
Join Date: Nov 2002
Location: Deepest Staffordshire
Posts: 4
Hi again

Firstly cheers for the help, I now have sound, however it resembles a dj scratching the wheels of steel. I'd better add that this is the 3 disk version of MI, 2 Double Density disks and a single density disk.

I'm guessing this is due to the IRQ or DMA settings as I've had this before with other games, the solution was to alter their values in a setup program.

However as MI doesn't have this I'm guessing I'll have to mix and match my settings till I find the right on, then knock up a batch file to change the settings and run MI all in one.

Don't suppose anyone knows the default Port, IRQ, and DMA values?

It would save me a bit of time when I get back from work!

Cheers
Kev


Ding dang do, you'll do for me!
kev_stanley is offline   you may: quote & reply,
Old 11-06-2002, 08:26 AM   #5
bgbennyboy
Festively Plump
 
bgbennyboy's Avatar
 
Status: Super Moderator
Join Date: Feb 2002
Location: England
Posts: 1,984
LFN Staff Member 
Well if you're talking soundblaster its usually:
Port 220
IRQ 7
DMA 1

bgbennyboy is offline   you may: quote & reply,
Old 11-06-2002, 11:38 AM   #6
kev_stanley
 
Join Date: Nov 2002
Location: Deepest Staffordshire
Posts: 4
Cheers, I think mines the same except for IRQ = 5

I'll give it go a later and post how I get on

Thanks a lot!

Kev


Ding dang do, you'll do for me!
kev_stanley is offline   you may: quote & reply,
Old 11-07-2002, 04:48 AM   #7
kev_stanley
 
Join Date: Nov 2002
Location: Deepest Staffordshire
Posts: 4
In the words of Brian Potter, Balls

Nothing seems to work, adlib causes a crash on divide by zero and roland complains one of the files is corrupt.

I don't think the scandisking of the 6 year old disks to get it installed in the 1st place can of really helped either.

Ebay here I come


Ding dang do, you'll do for me!
kev_stanley is offline   you may: quote & reply,
Old 11-07-2002, 07:42 AM   #8
Yoghurt
 
Yoghurt's Avatar
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 131
try to charter the cd-rom version - muchos better music


Smith ey? That's an unusual name!
Yoghurt is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Mixnmojo.com > Mojo Discussion Forums > Help! > Technical Question - TSOMI

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:21 AM.


LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.