lfnetwork.com mark read register faq members calendar

Thread: buttons...
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 05-09-2003, 04:16 AM   #1
fattysbox
 
fattysbox's Avatar
 
Join Date: Apr 2003
Posts: 67
Question buttons...

Ok this maybe a duh question, and I'm new to mapping...

I have a button which triggers a lift. However when I go to press it, it (the button) moves in a direction opposite me (very little) without me actually hitting the use key. The lift works just fine. I feel like I got the hardest part of making lifts, but cant make a frikin decent button.

Does it have to do with:

1) a button shader?
2) func_usable?
3) trigger?

OK, I will try all three, but figure I could use the feedback. Thanks fellas

J

fattysbox is offline   you may: quote & reply,
Old 05-09-2003, 02:27 PM   #2
Obsidian-Jovani
 
Obsidian-Jovani's Avatar
 
Join Date: Apr 2003
Location: Onderon
Posts: 223
Quote:
However when I go to press it, it (the button) moves in a direction opposite me (very little) without me actually hitting the use key.
The button is moving because of your trigger settings. In the entities window for your trigger check the "USE_BUTTON" box. This will get your desired effect. Good luck.


Binary Sunset Studios

WIP: A SP Project entitled "Resurgence"
Obsidian-Jovani is offline   you may: quote & reply,
Old 05-10-2003, 06:13 AM   #3
Shotokan
 
Shotokan's Avatar
 
Join Date: Jan 2003
Posts: 899
You should make a trigger and make it a trigger_multiple. After that then check the use_button box. Basically... Do what obsidian jovani told you to do


Online name: _Leviathan_
Shotokan is offline   you may: quote & reply,
Old 05-10-2003, 06:56 AM   #4
War Master
 
Join Date: Jul 2002
Location: On the battle field
Posts: 212
If your button isn't going the right way change the angle. Set the angle on the trigger too.
War Master is offline   you may: quote & reply,
Old 05-10-2003, 05:34 PM   #5
Leslie Judge
Teacher
 
Leslie Judge's Avatar
 
Join Date: Aug 2002
Location: Budapest, Hungary
Posts: 1,382
If you set the angle on the trigger, check the FACING spawnflag too.


L. J.
Leslie Judge is offline   you may: quote & reply,
Old 05-10-2003, 05:56 PM   #6
fattysbox
 
fattysbox's Avatar
 
Join Date: Apr 2003
Posts: 67
Well, did what you guys said but still the button is being "pressed" in the opposite direction of me without me actually using the button. It just presses when I come near it.

I think my problem is with triggers sadly enough. My button is linked to my lift, and thats it. I was not aware that I need a trigger_multiple... Where should I put it - around the button and then link it to the button? But then my button is linked to my lift allready. And assuming I put the trigger right, which I know I did not, what facing should it be?

Ok, I need a tutorial on triggers!!!!

Thanks fellas,

J
fattysbox is offline   you may: quote & reply,
Old 05-11-2003, 09:48 AM   #7
Leslie Judge
Teacher
 
Leslie Judge's Avatar
 
Join Date: Aug 2002
Location: Budapest, Hungary
Posts: 1,382
Have you every tried this one?

http://richdiesal.jedioutcastmaps.co...br201lsn7.html


L. J.
Leslie Judge is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Editing Central > JO Mapping > buttons...

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:45 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.